L'équipe Vigil@nce veille les vulnérabilités publiques qui affectent votre parc informatique, puis propose des correctifs sécurité, une base et des outils pour y remédier.

Vulnérabilité de Noyau Linux : boucle infinie via hid_debug_events_read

Synthèse de la vulnérabilité

Un attaquant peut provoquer une boucle infinie via hid_debug_events_read() du noyau Linux, afin de mener un déni de service.
Gravité de cette vulnérabilité informatique : 1/4.
Date création : 28/01/2019.
Références de cette annonce : CERTFR-2019-AVI-131, CERTFR-2019-AVI-145, CERTFR-2019-AVI-418, CERTFR-2019-AVI-419, CERTFR-2019-AVI-441, CVE-2019-3819, DLA-1731-1, DLA-1731-2, DLA-1771-1, openSUSE-SU-2019:1193-1, RHBUG-1669187, SUSE-SU-2019:0765-1, SUSE-SU-2019:0767-1, SUSE-SU-2019:2263-1, SUSE-SU-2019:2299-1, USN-3932-1, USN-3932-2, USN-4115-1, USN-4115-2, USN-4118-1, VIGILANCE-VUL-28378.

Description de la vulnérabilité

Un attaquant peut provoquer une boucle infinie via hid_debug_events_read() du noyau Linux, afin de mener un déni de service.
Bulletin Vigil@nce complet... (Essai gratuit)

Cette alerte de menace concerne les logiciels ou systèmes comme Debian, Linux, openSUSE Leap, SUSE Linux Enterprise Desktop, SLES, Ubuntu.

Notre équipe Vigil@nce a déterminé que la gravité de cette vulnérabilité cybersécurité est faible.

Le niveau de confiance est de type confirmé par l'éditeur, avec une provenance de shell privilégié.

Un attaquant avec un niveau de compétence expert peut exploiter cette faille cybersécurité.

Solutions pour cette menace

Noyau Linux : version 4.20.8.
La version 4.20.8 est corrigée :
  https://cdn.kernel.org/pub/linux/kernel/v4.x/

Noyau Linux : version 4.19.21.
La version 4.19.21 est corrigée :
  https://cdn.kernel.org/pub/linux/kernel/v4.x/

Noyau Linux : version 4.14.100.
La version 4.14.100 est corrigée :
  https://cdn.kernel.org/pub/linux/kernel/v4.x/

Noyau Linux : version 4.9.157.
La version 4.9.157 est corrigée :
  https://cdn.kernel.org/pub/linux/kernel/v4.x/

Noyau Linux : version 4.4.175.
La version 4.4.175 est corrigée :
  https://cdn.kernel.org/pub/linux/kernel/v4.x/

Noyau Linux : version 3.18.135.
La version 3.18.135 est corrigée :
  https://cdn.kernel.org/pub/linux/kernel/v3.x/

Noyau Linux : version 3.16.64.
La version 3.16.64 est corrigée :
  https://cdn.kernel.org/pub/linux/kernel/v3.x/

Noyau Linux : patch pour hid_debug_events_read.
Un patch est indiqué dans les sources d'information.

Debian 8 : nouveaux paquetages linux (27/03/2019).
De nouveaux paquetages sont disponibles :
  Debian 8 : linux 3.16.64-2

Debian 8 : nouveaux paquetages linux-4.9.
De nouveaux paquetages sont disponibles :
  Debian 8 : linux-4.9 4.9.168-1~deb8u1

openSUSE Leap 15.0 : nouveaux paquetages kernel.
De nouveaux paquetages sont disponibles :
  openSUSE Leap 15.0 : kernel 4.12.14-lp150.12.58.1

SUSE LE 12 SP2 : nouveaux paquetages kernel.
De nouveaux paquetages sont disponibles :
  SUSE LE 12 SP2 : kernel 4.4.121-92.120.1

SUSE LE 12 SP3 : nouveaux paquetages kernel.
De nouveaux paquetages sont disponibles :
  SUSE LE 12 SP3 : kernel 4.4.180-94.103.1

SUSE LE 12 SP4 : nouveaux paquetages kernel (27/03/2019).
De nouveaux paquetages sont disponibles :
  SUSE LE 12 SP4 : kernel 4.12.14-95.13.1

SUSE LE 12 SP4 : nouveaux paquetages kernel-azure.
De nouveaux paquetages sont disponibles :
  SUSE LE 12 SP4 : kernel-azure 4.12.14-6.9.1

Ubuntu 16/18 : nouveaux paquetages linux-image-aws.
De nouveaux paquetages sont disponibles :
  Ubuntu 16.04 LTS : linux-image-aws 4.15.0.1047.47
  Ubuntu 18.04 LTS : linux-image-aws 4.15.0.1047.46

Ubuntu : nouveaux paquetages linux-image-4.15.0.
De nouveaux paquetages sont disponibles :
  Ubuntu 16.04 LTS : linux-image-generic-hwe-16.04 4.15.0.62.82
  Ubuntu 18.04 LTS : linux-image-generic 4.15.0.62.64

Ubuntu : nouveaux paquetages linux-image-4.4.0.
De nouveaux paquetages sont disponibles :
  Ubuntu 14.04 LTS : linux-image-generic-lts-xenial 4.4.0.144.127
  Ubuntu 16.04 LTS : linux-image-generic 4.4.0.145.153
Bulletin Vigil@nce complet... (Essai gratuit)

Service de veille sur les vulnérabilités informatiques

Vigil@nce fournit des avis de vulnérabilités applicatives. La veille sécurité Vigil@nce publie des bulletins de vulnérabilités pour les failles qui impactent le système d'information.