L'équipe Vigil@nce veille les vulnérabilités publiques qui affectent votre parc informatique, puis propose des correctifs sécurité, une base de données de vigilance et des outils pour y remédier.

Vulnérabilité de Noyau Linux : buffer overflow via fbcon_redraw_softback

Synthèse de la vulnérabilité 

Un attaquant peut provoquer un buffer overflow via fbcon_redraw_softback() du noyau Linux, afin de mener un déni de service, et éventuellement d'exécuter du code.
Produits impactés : Debian, Linux, openSUSE Leap, Slackware, SUSE Linux Enterprise Desktop, SLES, Ubuntu.
Gravité de ce bulletin : 2/4.
Date de création : 15/09/2020.
Références de cette menace : CERTFR-2020-AVI-614, CERTFR-2020-AVI-625, CERTFR-2020-AVI-642, CERTFR-2020-AVI-672, CERTFR-2020-AVI-678, CERTFR-2020-AVI-699, CERTFR-2020-AVI-764, CERTFR-2020-AVI-776, CERTFR-2020-AVI-784, CERTFR-2020-AVI-786, CERTFR-2021-AVI-125, CVE-2020-14390, DLA-2385-1, DLA-2420-1, DLA-2420-2, openSUSE-SU-2020:1586-1, openSUSE-SU-2020:1655-1, openSUSE-SU-2021:0242-1, SSA:2020-295-01, SUSE-SU-2020:2879-1, SUSE-SU-2020:2904-1, SUSE-SU-2020:2905-1, SUSE-SU-2020:2906-1, SUSE-SU-2020:2907-1, SUSE-SU-2020:2908-1, SUSE-SU-2020:2999-1, SUSE-SU-2020:3014-1, SUSE-SU-2020:3501-1, SUSE-SU-2020:3503-1, SUSE-SU-2020:3532-1, SUSE-SU-2020:3544-1, SUSE-SU-2021:14630-1, USN-4657-1, USN-4658-1, USN-4658-2, USN-4660-1, USN-4660-2, VIGILANCE-VUL-33321.

Description de la vulnérabilité 

Un attaquant peut provoquer un buffer overflow via fbcon_redraw_softback() du noyau Linux, afin de mener un déni de service, et éventuellement d'exécuter du code.
Bulletin complet, filtrage par logiciel, emails, correctifs, ... (Demandez votre essai gratuit)

Cette vulnérabilité informatique concerne les logiciels ou systèmes comme Debian, Linux, openSUSE Leap, Slackware, SUSE Linux Enterprise Desktop, SLES, Ubuntu.

Notre équipe Vigil@nce a déterminé que la gravité de cette annonce cybersécurité est moyen.

Le niveau de confiance est de type confirmé par l'éditeur, avec une provenance de shell utilisateur.

Un démonstrateur ou un outil d'attaque est disponible, donc vos équipes doivent traiter cette alerte. Un attaquant avec un niveau de compétence technicien peut exploiter cette annonce de menace.

Solutions pour cette menace 

Noyau Linux : version 5.8.10.
La version 5.8.10 est corrigée :
  https://cdn.kernel.org/pub/linux/kernel/v5.x/

Noyau Linux : version 5.4.66.
La version 5.4.66 est corrigée :
  https://cdn.kernel.org/pub/linux/kernel/v5.x/

Noyau Linux : version 4.19.146.
La version 4.19.146 est corrigée :
  https://cdn.kernel.org/pub/linux/kernel/v4.x/

Noyau Linux : version 4.14.199.
La version 4.14.199 est corrigée :
  https://cdn.kernel.org/pub/linux/kernel/v4.x/linux-4.14.199.tar.xz

Noyau Linux : version 4.9.237.
La version 4.9.237 est corrigée :
  https://cdn.kernel.org/pub/linux/kernel/v4.x/linux-4.9.237.tar.xz

Noyau Linux : version 4.4.237.
La version 4.4.237 est corrigée :
  https://cdn.kernel.org/pub/linux/kernel/v4.x/linux-4.4.237.tar.xz

Noyau Linux : patch pour fbcon_redraw_softback.
Un patch est indiqué dans les sources d'information.

Debian 9 : nouveaux paquetages linux.
De nouveaux paquetages sont disponibles :
  Debian 9 : linux 4.9.240-2

Debian 9 : nouveaux paquetages linux-4.19 (28/09/2020).
De nouveaux paquetages sont disponibles :
  Debian 9 : linux-4.19 4.19.146-1~deb9u1

openSUSE Leap 15.1 : nouveaux paquetages kernel (12/10/2020).
De nouveaux paquetages sont disponibles :
  openSUSE Leap 15.1 : kernel 4.12.14-lp151.28.71.1

openSUSE Leap 15.2 : nouveaux paquetages kernel (02/10/2020).
De nouveaux paquetages sont disponibles :
  openSUSE Leap 15.2 : kernel 5.3.18-lp152.44.1

openSUSE Leap 15.2 : nouveaux paquetages kernel-rt.
De nouveaux paquetages sont disponibles :
  openSUSE Leap 15.2 : kernel-rt 5.3.18-lp152.3.5.1

Slackware 14.2 : nouveaux paquetages kernel (22/10/2020).
De nouveaux paquetages sont disponibles :
  Slackware 14.2 : kernel 4.4.240-i586-1

SUSE LE 11 SP4 : nouveaux paquetages kernel.
De nouveaux paquetages sont disponibles :
  SUSE LE 11 SP4 : kernel 3.0.101-108.120.1

SUSE LE 12 SP2 : nouveaux paquetages kernel-default.
De nouveaux paquetages sont disponibles :
  SUSE LE 12 SP2 : kernel-default 4.4.121-92.146.1
  SUSE LE 12 SP2 : kernel-default 4.4.121-92.146.1

SUSE LE 12 SP3 : nouveaux paquetages kernel-default.
De nouveaux paquetages sont disponibles :
  SUSE LE 12 SP3 : kernel-default 4.4.180-94.135.1

SUSE LE 12 SP4 : nouveaux paquetages kernel-default.
De nouveaux paquetages sont disponibles :
  SUSE LE 12 SP4 : kernel-default 4.12.14-95.65.1

SUSE LE 12 SP5 : nouveaux paquetages kernel (13/10/2020).
De nouveaux paquetages sont disponibles :
  SUSE LE 12 SP5 : kernel 4.12.14-122.41.1

SUSE LE 12 SP5 : nouveaux paquetages kernel-rt.
De nouveaux paquetages sont disponibles :
  SUSE LE 12 SP5 : kernel-rt 4.12.14-10.19.1

SUSE LE 15 : nouveaux paquetages kernel.
De nouveaux paquetages sont disponibles :
  SUSE LE 15 RTM : kernel-default-livepatch 4.12.14-150.63.1, kernel-livepatch 4_12_14-150_63-default-1-1.5.1

SUSE LE 15 SP1 : nouveaux paquetages kernel.
De nouveaux paquetages sont disponibles :
  SUSE LE 15 SP1 : kernel 4.12.14-197.61.1

SUSE LE 15 SP1 : nouveaux paquetages kernel-azure (13/10/2020).
De nouveaux paquetages sont disponibles :
  SUSE LE 15 SP1 : kernel-azure 4.12.14-8.47.1

SUSE LE 15 SP1 : nouveaux paquetages kernel-rt (23/10/2020).
De nouveaux paquetages sont disponibles :
  SUSE LE 15 SP1 : kernel-rt 4.12.14-14.36.1

SUSE LE 15 SP2 : nouveaux paquetages kernel (09/10/2020).
De nouveaux paquetages sont disponibles :
  SUSE LE 15 SP2 : kernel 5.3.18-24.24.1

SUSE LE 15 SP2 : nouveaux paquetages kernel-azure (13/10/2020).
De nouveaux paquetages sont disponibles :
  SUSE LE 15 SP2 : kernel-azure 5.3.18-18.21.1

Ubuntu : nouveaux paquetages linux-image-4.15.0.
De nouveaux paquetages sont disponibles :
  Ubuntu 14.04 ESM : linux-image-azure 4.15.0.1100.75
  Ubuntu 16.04 LTS : linux-image-generic-hwe-16.04 4.15.0.128.127
  Ubuntu 18.04 LTS : linux-image-generic 4.15.0.128.115

Ubuntu : nouveaux paquetages linux-image-4.4.0 (02/12/2020).
De nouveaux paquetages sont disponibles :
  Ubuntu 14.04 ESM : linux-image-generic-lpae-lts-xenial 4.4.0.197.172
  Ubuntu 16.04 LTS : linux-image-generic 4.4.0.197.203

Ubuntu : nouveaux paquetages linux-image-5.4.0.
De nouveaux paquetages sont disponibles :
  Ubuntu 18.04 LTS : linux-image-generic-hwe-18.04 5.4.0.58.64~18.04.53
  Ubuntu 20.04 LTS : linux-image-generic 5.4.0.58.61

Wind River Linux : version 10.18.44.20.
La version 10.18.44.20 est corrigée :
  https://support2.windriver.com/index.php?page=cve&on=list&show=50&product_id=1&product_version%5B0%5D=23&id_status%5B0%5D=4&cve_id_filter=&s=&submit=&order_by=cve_modified_date&order_way=desc#list
Bulletin complet, filtrage par logiciel, emails, correctifs, ... (Demandez votre essai gratuit)

Service de veille sur les vulnérabilités informatiques 

Vigil@nce fournit une analyse de vulnérabilité de système. L'équipe Vigil@nce surveille les vulnérabilités informatiques de systèmes et d'applications.