L'équipe Vigil@nce veille les vulnérabilités publiques qui affectent votre parc informatique, puis propose des correctifs sécurité, une base de données de vigilance et des outils pour y remédier.

Vulnérabilité de Noyau Linux : buffer overflow via vhost/vhost_net

Synthèse de la vulnérabilité 

Un attaquant, dans un système invité, peut provoquer un buffer overflow via vhost/vhost_net du noyau Linux, afin de mener un déni de service, et éventuellement d'exécuter du code sur le système hôte.
Logiciels vulnérables : Debian, Fedora, Junos Space, Linux, openSUSE Leap, oVirt, RHEL, Slackware, SUSE Linux Enterprise Desktop, SLES, Ubuntu.
Gravité de cette annonce : 2/4.
Date création : 17/09/2019.
Date révision : 25/09/2019.
Références de cette vulnérabilité informatique : CERTFR-2019-AVI-448, CERTFR-2019-AVI-451, CERTFR-2019-AVI-455, CERTFR-2019-AVI-457, CERTFR-2019-AVI-466, CERTFR-2019-AVI-467, CERTFR-2019-AVI-502, CERTFR-2019-AVI-503, CERTFR-2019-AVI-530, CERTFR-2019-AVI-561, CERTFR-2019-AVI-575, CERTFR-2019-AVI-612, CERTFR-2020-AVI-029, CVE-2019-14835, DLA-1930-1, DLA-1940-1, DSA-4531-1, FEDORA-2019-a570a92d5a, FEDORA-2019-e3010166bd, JSA10993, openSUSE-SU-2019:2173-1, openSUSE-SU-2019:2181-1, RHSA-2019:2827-01, RHSA-2019:2828-01, RHSA-2019:2829-01, RHSA-2019:2830-01, RHSA-2019:2854-01, RHSA-2019:2862-01, RHSA-2019:2863-01, RHSA-2019:2864-01, RHSA-2019:2865-01, RHSA-2019:2866-01, RHSA-2019:2867-01, RHSA-2019:2869-01, RHSA-2019:2899-01, RHSA-2019:2900-01, RHSA-2019:2901-01, SSA:2019-311-01, SUSE-SU-2019:14218-1, SUSE-SU-2019:2412-1, SUSE-SU-2019:2424-1, SUSE-SU-2019:2648-1, SUSE-SU-2019:2651-1, SUSE-SU-2019:2658-1, SUSE-SU-2019:2738-1, SUSE-SU-2019:2949-1, SUSE-SU-2019:2950-1, SUSE-SU-2019:2984-1, SUSE-SU-2019:3200-1, SUSE-SU-2020:0093-1, USN-4135-1, USN-4135-2, VIGILANCE-VUL-30355.

Description de la vulnérabilité 

Un attaquant, dans un système invité, peut provoquer un buffer overflow via vhost/vhost_net du noyau Linux, afin de mener un déni de service, et éventuellement d'exécuter du code sur le système hôte.
Bulletin complet, filtrage par logiciel, emails, correctifs, ... (Demandez votre essai gratuit)

Cette alerte de faille informatique concerne les logiciels ou systèmes comme Debian, Fedora, Junos Space, Linux, openSUSE Leap, oVirt, RHEL, Slackware, SUSE Linux Enterprise Desktop, SLES, Ubuntu.

Notre équipe Vigil@nce a déterminé que la gravité de cette alerte de vulnérabilité informatique est moyen.

Le niveau de confiance est de type confirmé par l'éditeur, avec une provenance de document.

Un démonstrateur ou un outil d'attaque est disponible, donc vos équipes doivent traiter cette alerte. Un attaquant avec un niveau de compétence spécialiste peut exploiter cet avis sécurité.

Solutions pour cette menace 

Noyau Linux : version 4.9.193.
La version 4.9.193 est corrigée :
  https://cdn.kernel.org/pub/linux/kernel/v4.x/

Noyau Linux : version 4.4.193.
La version 4.4.193 est corrigée :
  https://cdn.kernel.org/pub/linux/kernel/v4.x/

Noyau Linux : version 3.16.74.
La version 3.16.74 est corrigée :
  https://cdn.kernel.org/pub/linux/kernel/v3.x/linux-3.16.74.tar.xz

Noyau Linux : patch pour vhost/vhost_net.
Un patch est indiqué dans les sources d'information.

Debian 8 : nouveaux paquetages linux.
De nouveaux paquetages sont disponibles :
  Debian 8 : linux 3.16.74-1

Debian 8 : nouveaux paquetages linux-4.9.
De nouveaux paquetages sont disponibles :
  Debian 8 : linux-4.9 4.9.189-3+deb9u1~deb8u1

Debian 9, 10 : nouveaux paquetages linux.
De nouveaux paquetages sont disponibles :
  Debian 9 : linux 4.9.189-3+deb9u1
  Debian 10 : linux 4.19.67-2+deb10u1

Fedora 29 : nouveaux paquetages kernel.
De nouveaux paquetages sont disponibles :
  Fedora 29 : kernel 5.2.17-100.fc29

Fedora 29 : nouveaux paquetages kernel-headers.
De nouveaux paquetages sont disponibles :
  Fedora 29 : kernel-headers 5.2.17-100.fc29

Fedora 29 : nouveaux paquetages kernel-tools.
De nouveaux paquetages sont disponibles :
  Fedora 29 : kernel-tools 5.2.17-100.fc29

Fedora 30 : nouveaux paquetages kernel.
De nouveaux paquetages sont disponibles :
  Fedora 30 : kernel 5.2.15-200.fc30

Fedora 30 : nouveaux paquetages kernel-headers.
De nouveaux paquetages sont disponibles :
  Fedora 30 : kernel-headers 5.2.15-200.fc30

Junos Space : version 19.4R1.
La version 19.4R1 est corrigée :
  https://www.juniper.net/support/downloads/

openSUSE Leap 15 : nouveaux paquetages kernel.
De nouveaux paquetages sont disponibles :
  openSUSE Leap 15.0 : kernel 4.12.14-lp150.12.73.1
  openSUSE Leap 15.1 : kernel 4.12.14-lp151.28.16.1

oVirt : version 4.3.6.
La version 4.3.6 est corrigée.

RHEL 6.5 : nouveaux paquetages kernel.
De nouveaux paquetages sont disponibles :
  RHEL 6 : kernel 2.6.32-431.96.2.el6

RHEL 7.2 : nouveaux paquetages kernel.
De nouveaux paquetages sont disponibles :
  RHEL 7 : kernel 3.10.0-327.82.1.el7

RHEL 7.3 : nouveaux paquetages kernel.
De nouveaux paquetages sont disponibles :
  RHEL 7 : kernel 3.10.0-514.69.1.el7

RHEL 7, 8 : nouveaux paquetages kernel-rt.
De nouveaux paquetages sont disponibles :
  RHEL 8 : kernel-rt 4.18.0-80.11.2.rt9.157.el8_0
  RHEL 7 : kernel-rt 3.10.0-1062.1.2.rt56.1025.el7

RHEL 7 : nouveaux paquetages kernel-alt.
De nouveaux paquetages sont disponibles :
  RHEL 7 : kernel-alt 4.14.0-115.13.1.el7a

RHEL 7 : nouveaux paquetages kpatch-patch.
De nouveaux paquetages sont disponibles :
  RHEL 7 : kpatch-patch 3_10_0-1062-1-1.el7
  RHEL 7.6 : kpatch-patch 3_10_0-957_35_1-1-1.el7

RHEL : nouveaux paquetages kernel.
De nouveaux paquetages sont disponibles :
  RHEL 8 : kernel 4.18.0-80.11.2.el8_0
  RHEL 7 : kernel 3.10.0-1062.1.2.el7
  RHEL 7.6 : kernel 3.10.0-957.35.2.el7
  RHEL 7.5 : kernel 3.10.0-862.41.2.el7
  RHEL 7.4 : kernel 3.10.0-693.59.1.el7
  RHEL 6 : kernel 2.6.32-754.23.1.el6
  RHEL 6.6 : kernel 2.6.32-504.81.2.el6

Slackware 14.2 : nouveaux paquetages kernel.
De nouveaux paquetages sont disponibles :
  Slackware 14.2 : kernel 4.4.199-*-1

SUSE LE 11 SP4 : nouveaux paquetages kernel.
De nouveaux paquetages sont disponibles :
  SUSE LE 11 SP4 : kernel 3.0.101-108.108.1

SUSE LE 12 SP1 : nouveaux paquetages kernel (13/11/2019).
De nouveaux paquetages sont disponibles :
  SUSE LE 12 SP1 : kernel 3.12.74-60.64.124.1

SUSE LE 12 SP2 : nouveaux paquetages kernel.
De nouveaux paquetages sont disponibles :
  SUSE LE 12 SP2 : kernel 4.4.121-92.125.1

SUSE LE 12 SP3 : nouveaux paquetages kernel (13/11/2019).
De nouveaux paquetages sont disponibles :
  SUSE LE 12 SP3 : kernel 4.4.180-94.107.1

SUSE LE 12 SP4 : nouveaux paquetages kernel-azure.
De nouveaux paquetages sont disponibles :
  SUSE LE 12 SP4 : kernel-azure 4.12.14-6.26.1

SUSE LE 12 SP4 : nouveaux paquetages kernel-default.
De nouveaux paquetages sont disponibles :
  SUSE LE 12 SP4 : kernel-default 4.12.14-95.32.1

SUSE LE 12 SP5 : nouveaux paquetages kernel (09/12/2019).
De nouveaux paquetages sont disponibles :
  SUSE LE 12 SP5 : kernel 4.12.14-122.7.1

SUSE LE 12 SP5 : nouveaux paquetages kernel-azure.
De nouveaux paquetages sont disponibles :
  SUSE LE 12 SP5 : kernel-azure 4.12.14-16.7.1

SUSE LE 15 : nouveaux paquetages kernel-azure.
De nouveaux paquetages sont disponibles :
  SUSE LE 15 RTM : kernel-azure 4.12.14-5.41.1
  SUSE LE 15 SP1 : kernel-azure 4.12.14-8.16.1

SUSE LE 15 SP1 : nouveaux paquetages kernel-default.
De nouveaux paquetages sont disponibles :
  SUSE LE 15 SP1 : kernel-default 4.12.14-197.18.1

SUSE LE 15 SP1 : nouveaux paquetages kernel-rt.
De nouveaux paquetages sont disponibles :
  SUSE LE 15 SP1 : kernel-rt 4.12.14-14.11.1

Ubuntu : nouveaux paquetages linux-image.
De nouveaux paquetages sont disponibles :
  Ubuntu 19.04 : linux-image-5.0.0-29-generic 5.0.0-29.31
  Ubuntu 18.04 LTS : linux-image-4.15.0-64-generic 4.15.0-64.73
  Ubuntu 16.04 LTS : linux-image-4.4.0-164-generic 4.4.0-164.192
  Ubuntu 14.04 ESM : linux-image-3.13.0-173-generic 3.13.0-173.224, linux-image-4.4.0-164-generic 4.4.0-164.192~14.04.1, linux-image-generic 3.13.0.173.184
  Ubuntu 12.04 ESM : linux-image-3.13.0-173-generic 3.13.0-173.224~12.04.1, linux-image-3.2.0-143-generic 3.2.0-143.190, linux-image-generic 3.2.0.143.158

Wind River Linux : version 10.18.44.12.
La version 10.18.44.12 est corrigée :
  https://support2.windriver.com/
Bulletin complet, filtrage par logiciel, emails, correctifs, ... (Demandez votre essai gratuit)

Service de veille sur les vulnérabilités informatiques 

Vigil@nce fournit un correctif de vulnérabilités informatiques. Chaque administrateur peut personnaliser la liste des produits pour lesquels il souhaite recevoir des alertes de vulnérabilités.