L'équipe Vigil@nce veille les vulnérabilités publiques qui affectent votre parc informatique, puis propose des correctifs sécurité, une base de données de vigilance et des outils pour y remédier.

Vulnérabilité de Noyau Linux : corruption de mémoire de sctp_getsockopt_local_addrs_old

Synthèse de la vulnérabilité 

Un attaquant local peut créer une socket SCTP afin de stopper le système et éventuellement d'y exécuter du code.
Produits impactés : Debian, Linux, Mandriva Linux, openSUSE, RHEL.
Gravité de ce bulletin : 2/4.
Date de création : 08/07/2008.
Références de cette menace : BID-29990, CERTA-2002-AVI-206, CVE-2008-2826, DSA-1630-1, MDVSA-2008:167, MDVSA-2008:174, RHSA-2008:0585-01, RHSA-2008:0849-5, SUSE-SA:2008:037, SUSE-SA:2008:052, VIGILANCE-VUL-7935.

Description de la vulnérabilité 

Le protocole SCTP (Stream Control Transmission Protocol) permet de créer des associations pour faire transiter plusieurs flux.

La fonction sctp_getsockopt_local_addrs_old() du fichier net/sctp/socket.c définit les adresses locales et est appelée via setsockopt(). Cependant, cette fonction ne vérifie pas le nombre d'adresses reçues (addr_num), ce qui provoque un débordement d'entier, puis l'allocation d'une zone mémoire trop courte.

Un attaquant local peut donc créer une socket SCTP afin de stopper le système et éventuellement d'y exécuter du code.
Bulletin complet, filtrage par logiciel, emails, correctifs, ... (Demandez votre essai gratuit)

Cette menace informatique concerne les logiciels ou systèmes comme Debian, Linux, Mandriva Linux, openSUSE, RHEL.

Notre équipe Vigil@nce a déterminé que la gravité de cette alerte de menace informatique est moyen.

Le niveau de confiance est de type confirmé par l'éditeur, avec une provenance de compte utilisateur.

Un attaquant avec un niveau de compétence expert peut exploiter ce bulletin de menace informatique.

Solutions pour cette menace 

Noyau Linux : version 2.6.26.
La version 2.6.26 est corrigée :
  http://www.kernel.org/

Noyau Linux : version 2.6.25.9.
La version 2.6.25.9 est corrigée :
  http://kernel.org/

Noyau Linux : version 2.6.18.
La version est corrigée :
Source archives: http://security.debian.org/pool/updates/main/l/linux-2.6/linux-2.6_2.6.18.dfsg.1-22etch2.diff.gz

Noyau Linux : version 2.6.16.62.
La version 2.6.16.62 est corrigée :
  http://www.kernel.org/

Noyau Linux : version 2.4.37.
La version 2.4.37 est corrigée :
  http://www.kernel.org/pub/linux/kernel/v2.4/

Noyau Linux : version 2.4.36.7.
La version 2.4.36.7 est corrigée :
  ftp://ftp.kernel.org/pub/linux/kernel/v2.4/

Debian : nouveaux paquetages noyau.
De nouveaux paquetages sont disponibles :
http://security.debian.org/pool/updates/main/l/linux-2.6/linux*-2.6.18-6-alpha-legacy_2.6.18.dfsg.1-22etch2_*.deb

Mandriva : nouveaux paquetages kernel.
De nouveaux paquetages sont disponibles :
Corporate 4.0:
corporate/4.0/SRPMS/kernel-2.6.12.36mdk-1-1mdk.*.rpm

Mandriva : nouveaux paquetages noyau.
La version est corrigée :
kernel-2.6.24.7

openSUSE 10.3 : nouveaux paquetages kernel.
De nouveaux paquetages sont disponibles :
   http://download.opensuse.org/pub/opensuse/update/10.3/rpm/*/kernel-*-2.6.22.19-0.1.*.rpm

RHEL 5 : nouveaux paquetages noyau.
De nouveaux paquetages sont disponibles :
kernel-rt*-2.6.24.7-74.el5rt.*.rpm

SUSE : nouveaux paquetages noyau.
De nouveaux paquetages sont disponibles :
  http://download.opensuse.org/pub/opensuse/update/11.0/rpm/i586/kernel-*-2.6.25.11-0.1.*.rpm
Bulletin complet, filtrage par logiciel, emails, correctifs, ... (Demandez votre essai gratuit)

Service de veille sur les vulnérabilités informatiques 

Vigil@nce fournit des annonces de vulnérabilités applicatives. La cellule de veille technologique suit les menaces sécurité qui ciblent le parc informatique.