L'équipe Vigil@nce veille les vulnérabilités publiques qui affectent votre parc informatique, puis propose des correctifs sécurité, une base de données de vigilance et des outils pour y remédier.

Vulnérabilité de Noyau Linux : corruption de mémoire via AGPgart

Synthèse de la vulnérabilité 

Un attaquant local peut employer deux vulnérabilités d'AGPgart, afin de corrompre la mémoire, pour mener un déni de service ou élever ses privilèges.
Systèmes vulnérables : Debian, Fedora, Linux, openSUSE, RHEL, SUSE Linux Enterprise Desktop, SLES, ESX.
Gravité de cette menace : 2/4.
Nombre de vulnérabilités dans ce bulletin : 3.
Date de création : 21/04/2011.
Références de cette faille : BID-47534, BID-47535, BID-47843, CVE-2011-1745, CVE-2011-1746, CVE-2011-1747, CVE-2011-2022, DSA-2240-1, DSA-2264-1, FEDORA-2011-6447, FEDORA-2011-6541, openSUSE-SU-2011:0860-1, RHSA-2011:0927-01, RHSA-2011:1253-01, RHSA-2011:1350-01, SUSE-SA:2011:031, SUSE-SA:2011:034, SUSE-SA:2011:040, SUSE-SU-2011:0832-1, SUSE-SU-2011:0899-1, SUSE-SU-2011:0928-1, SUSE-SU-2011:1058-1, VIGILANCE-VUL-10592.

Description de la vulnérabilité 

Le module AGPgart (Graphics Address Remapping Table) est utilisé par les cartes vidéo ayant peu de mémoire. Il utilise /dev/agpgart, et est impacté par deux vulnérabilités.

Les ioctls AGPIOC_BIND et AGPIOC_UNBIND appellent les fonctions agp_generic_insert_memory() et agp_generic_remove_memory(). Un attaquant peut les employer pour écrire en mémoire noyau. [grav:2/4; BID-47534, BID-47843, CVE-2011-1745, CVE-2011-2022]

L'ioctl AGPIOC_ALLOCATE appelle les fonctions agp_create_user_memory() et agp_allocate_memory(). Un attaquant peut les employer pour provoquer un buffer overflow. [grav:2/4; BID-47535, CVE-2011-1746]

Un attaquant peut employer les ioctls AGPIOC_RESERVE et AGPIOC_ALLOCATE afin d'allouer des portions de mémoire qui ne seront jamais libérées. [grav:1/4; CVE-2011-1747]

Un attaquant local peut donc employer deux vulnérabilités d'AGPgart, afin de corrompre la mémoire, pour mener un déni de service ou élever ses privilèges.
Bulletin complet, filtrage par logiciel, emails, correctifs, ... (Demandez votre essai gratuit)

Ce bulletin de vulnérabilité informatique concerne les logiciels ou systèmes comme Debian, Fedora, Linux, openSUSE, RHEL, SUSE Linux Enterprise Desktop, SLES, ESX.

Notre équipe Vigil@nce a déterminé que la gravité de cette alerte cybersécurité est moyen.

Le niveau de confiance est de type confirmé par l'éditeur, avec une provenance de shell utilisateur.

Ce bulletin concerne 3 vulnérabilités.

Un attaquant avec un niveau de compétence expert peut exploiter cet avis de faille.

Solutions pour cette menace 

Noyau Linux : version 2.6.39.
La version 2.6.39 est corrigée :
  http://www.kernel.org/pub/linux/kernel/v2.6/

Noyau Linux : version 2.6.38.5.
La version 2.6.38.5 est corrigée :
  http://www.kernel.org/pub/linux/kernel/v2.6/

Noyau Linux : version 2.6.33.13.
La version 2.6.33.13 est corrigée :
  http://www.kernel.org/pub/linux/kernel/v2.6/

Noyau Linux : version 2.6.32.40.
La version 2.6.32.40 est corrigée :
  http://www.kernel.org/pub/linux/kernel/v2.6/

Noyau Linux : version 2.6.27.60.
La version 2.6.27.60 est corrigée :
  http://www.kernel.org/pub/linux/kernel/v2.6/longterm/v2.6.27/

Noyau Linux : patch pour AGPgart.
Deux patches sont disponibles dans les sources d'information.

Debian : nouveaux paquetages linux-2.6 (20/06/2011).
De nouveaux paquetages sont disponibles :
  linux-2.6 2.6.26-26lenny3

Debian : nouveaux paquetages linux-2.6 (25/05/2011).
De nouveaux paquetages sont disponibles :
  linux-2.6 2.6.32-34squeeze1

Fedora 13 : nouveaux paquetages kernel (22/06/2011).
De nouveaux paquetages sont disponibles :
  kernel-2.6.34.9-69.fc13

Fedora 14 : nouveaux paquetages kernel.
De nouveaux paquetages sont disponibles :
  Fedora 14 : kernel-2.6.35.13-91.fc14

openSUSE 11.4 : nouveaux paquetages kernel (02/08/2011).
De nouveaux paquetages sont disponibles :
  kernel-*-2.6.37.6-0.7.1

RHEL 5 : nouveaux paquetages kernel.
De nouveaux paquetages sont disponibles :
  kernel-2.6.18-238.19.1.el5

RHEL 6 MRG : nouveaux paquetages kernel-rt.
De nouveaux paquetages sont disponibles :
MRG Realtime for RHEL 6 Server : kernel-rt-*-2.6.33.9-rt31.75.el6rt

RHEL 6 : nouveaux paquetages kernel (06/10/2011).
De nouveaux paquetages sont disponibles :
  kernel-2.6.32-131.17.1.el6

SUSE LE 10 SP3 : nouveaux paquetages kernel (21/09/2011).
De nouveaux paquetages sont disponibles, comme indiqué dans les sources d'informations.

SUSE LE 10 SP4 : nouveaux paquetages kernel (12/08/2011).
De nouveaux paquetages sont disponibles, comme indiqué dans les sources d'informations.

SUSE LE 11 : nouveaux paquetages kernel.
De nouveaux paquetages sont disponibles, comme indiqué dans les sources d'informations.

SUSE LE 9 : nouveaux paquetages kernel (23/08/2011).
De nouveaux paquetages sont disponibles :
http://download.novell.com/patch/finder/?keywords=c05dae2ea95bb787f18166cf12f585e3

VMware ESX 4.1 : patch ESX410-201201001.
Un patch est disponible :
  ESX410-201201001
  http://downloads.vmware.com/go/selfsupport-download
  http://kb.vmware.com/kb/2009142
Bulletin complet, filtrage par logiciel, emails, correctifs, ... (Demandez votre essai gratuit)

Service de veille sur les vulnérabilités informatiques 

Vigil@nce fournit une annonce cyber-sécurité. Le service de veille sur les vulnérabilités informatiques Vigil@nce alerte vos équipes des failles et des menaces qui concernent votre système d'information.