L'équipe Vigil@nce veille les vulnérabilités publiques qui affectent votre parc informatique, puis propose des correctifs sécurité, une base et des outils pour y remédier.

vulnérabilité informatique CVE-2016-4997

Noyau Linux : corruption de mémoire via IP6T_SO_SET_REPLACE

Synthèse de la vulnérabilité

Un attaquant local peut provoquer une corruption de mémoire via IP6T_SO_SET_REPLACE sur le noyau Linux, afin de mener un déni de service, et éventuellement d'exécuter du code.
Produits concernés : Debian, Fedora, Android OS, Linux, openSUSE, openSUSE Leap, RHEL, SUSE Linux Enterprise Desktop, SLES, Ubuntu.
Gravité : 2/4.
Date création : 29/09/2016.
Date révision : 29/09/2016.
Références : CERTFR-2016-AVI-220, CERTFR-2016-AVI-267, CVE-2016-4997, DSA-3607-1, FEDORA-2016-1c409313f4, FEDORA-2016-63ee0999e4, FEDORA-2016-73a733f4d9, openSUSE-SU-2016:1798-1, openSUSE-SU-2016:2144-1, openSUSE-SU-2016:2184-1, openSUSE-SU-2016:2290-1, RHSA-2016:1847-01, RHSA-2016:1875-01, RHSA-2016:1883-01, SUSE-SU-2016:1709-1, SUSE-SU-2016:1710-1, SUSE-SU-2016:1937-1, SUSE-SU-2016:1985-1, SUSE-SU-2016:2018-1, SUSE-SU-2016:2105-1, SUSE-SU-2016:2245-1, USN-3016-1, USN-3016-2, USN-3016-3, USN-3016-4, USN-3017-1, USN-3017-2, USN-3017-3, USN-3018-1, USN-3018-2, USN-3019-1, USN-3020-1, VIGILANCE-VUL-20735.

Description de la vulnérabilité

Le noyau Linux dispose d'un module ip6_tables ou ip_tables.

Cependant, l'option IP6T_SO_SET_REPLACE ou IPT_SO_SET_REPLACE de setsockopt() ne vérifie pas correctement les offsets, ce qui permet de corrompre la mémoire.

Un attaquant local peut donc provoquer une corruption de mémoire via IP6T_SO_SET_REPLACE sur le noyau Linux, afin de mener un déni de service, et éventuellement d'exécuter du code.
Bulletin Vigil@nce complet.... (Essai gratuit)

Service de veille sur les vulnérabilités informatiques

Vigil@nce fournit une base de vulnérabilités de réseaux. La base de vulnérabilités Vigil@nce contient plusieurs milliers de failles. L'équipe Vigil@nce surveille les vulnérabilités informatiques de systèmes et d'applications. La veille sécurité Vigil@nce publie des bulletins de vulnérabilités pour les failles qui impactent le système d'information.