L'équipe Vigil@nce veille les vulnérabilités publiques qui affectent votre parc informatique, puis propose des correctifs sécurité, une base de données de vigilance et des outils pour y remédier.

Vulnérabilité de Noyau Linux : corruption de mémoire via SNDRV_RAWMIDI_IOCTL_PARAMS

Synthèse de la vulnérabilité 

Un attaquant peut provoquer une corruption de mémoire via SNDRV_RAWMIDI_IOCTL_PARAMS du noyau Linux, afin de mener un déni de service, et éventuellement d'exécuter du code.
Systèmes vulnérables : Debian, Junos Space, Linux, openSUSE Leap, RHEL, SUSE Linux Enterprise Desktop, SLES, Ubuntu.
Gravité de cette menace : 2/4.
Date de création : 21/08/2018.
Références de cette faille : CERTFR-2018-AVI-415, CERTFR-2018-AVI-456, CERTFR-2018-AVI-459, CERTFR-2018-AVI-460, CERTFR-2018-AVI-462, CERTFR-2018-AVI-480, CERTFR-2018-AVI-608, CERTFR-2019-AVI-079, CERTFR-2019-AVI-188, CERTFR-2019-AVI-325, CERTFR-2019-AVI-592, CERTFR-2021-AVI-120, CVE-2018-10902, DLA-1529-1, DLA-1531-1, DSA-4308-1, JSA10951, openSUSE-SU-2018:2738-1, openSUSE-SU-2018:3071-1, RHSA-2018:3083-01, RHSA-2018:3096-01, RHSA-2019:0415-01, RHSA-2019:3217-01, RHSA-2019:3967-01, SUSE-SU-2018:2538-1, SUSE-SU-2018:2539-1, SUSE-SU-2018:2858-1, SUSE-SU-2018:2862-1, SUSE-SU-2018:2879-1, SUSE-SU-2018:2907-1, SUSE-SU-2018:2908-1, SUSE-SU-2018:2908-2, SUSE-SU-2018:3083-1, SUSE-SU-2018:3084-1, SUSE-SU-2018:3088-1, SUSE-SU-2021:0452-1, USN-3776-1, USN-3776-2, USN-3847-1, USN-3847-2, USN-3847-3, USN-3849-1, USN-3849-2, VIGILANCE-VUL-27050, ZDI-18-965.

Description de la vulnérabilité 

Un attaquant peut provoquer une corruption de mémoire via SNDRV_RAWMIDI_IOCTL_PARAMS du noyau Linux, afin de mener un déni de service, et éventuellement d'exécuter du code.
Bulletin complet, filtrage par logiciel, emails, correctifs, ... (Demandez votre essai gratuit)

Cette menace cybersécurité concerne les logiciels ou systèmes comme Debian, Junos Space, Linux, openSUSE Leap, RHEL, SUSE Linux Enterprise Desktop, SLES, Ubuntu.

Notre équipe Vigil@nce a déterminé que la gravité de ce bulletin de menace informatique est moyen.

Le niveau de confiance est de type confirmé par l'éditeur, avec une provenance de shell utilisateur.

Un attaquant avec un niveau de compétence expert peut exploiter cette vulnérabilité cybersécurité.

Solutions pour cette menace 

Noyau Linux : version 4.17.10.
La version 4.17.10 est corrigée :
  https://cdn.kernel.org/pub/linux/kernel/v4.x/

Noyau Linux : version 4.14.58.
La version 4.14.58 est corrigée :
  https://cdn.kernel.org/pub/linux/kernel/v4.x/

Noyau Linux : version 4.9.115.
La version 4.9.115 est corrigée :
  https://cdn.kernel.org/pub/linux/kernel/v4.x/

Noyau Linux : version 4.4.144.
La version 4.4.144 est corrigée :
  https://cdn.kernel.org/pub/linux/kernel/v4.x/

Noyau Linux : version 3.18.117.
La version 3.18.117 est corrigée :
  https://cdn.kernel.org/pub/linux/kernel/v3.x/

Noyau Linux : version 3.16.58.
La version 3.16.58 est corrigée :
  https://cdn.kernel.org/pub/linux/kernel/v3.x/

Noyau Linux : patch pour SNDRV_RAWMIDI_IOCTL_PARAMS.
Un patch est indiqué dans les sources d'information.

Debian 8 : nouveaux paquetages linux (05/10/2018).
De nouveaux paquetages sont disponibles :
  Debian 8 : linux 3.16.59-1

Debian 8 : nouveaux paquetages linux-4.9.
De nouveaux paquetages sont disponibles :
  Debian 8 : linux-4.9 4.9.110-3+deb9u5~deb8u1

Debian 9 : nouveaux paquetages linux.
De nouveaux paquetages sont disponibles :
  Debian 9 : linux 4.9.110-3+deb9u5

Junos Space : version 19.2R1.
La version 19.2R1 est corrigée :
  https://www.juniper.net/support/downloads/

openSUSE Leap 15.0 : nouveaux paquetages kernel.
De nouveaux paquetages sont disponibles :
  openSUSE Leap 15.0 : kernel 4.12.14-lp150.12.19.2

openSUSE Leap 42.3 : nouveaux paquetages kernel.
De nouveaux paquetages sont disponibles :
  openSUSE Leap 42.3 : kernel 4.4.155-68.1

RHEL 6 : nouveaux paquetages kernel.
De nouveaux paquetages sont disponibles :
  RHEL 6 : kernel 2.6.32-754.11.1.el6

RHEL 7.5 : nouveaux paquetages kernel.
De nouveaux paquetages sont disponibles :
  RHEL 7.0-7.7 : kernel 3.10.0-862.44.2.el7

RHEL 7 : nouveaux paquetages kernel.
De nouveaux paquetages sont disponibles :
  RHEL 7 : kernel 3.10.0-957.el7

RHEL 7 : nouveaux paquetages kernel-alt.
De nouveaux paquetages sont disponibles :
  RHEL 7 : kernel-alt 4.14.0-115.14.1.el7a

RHEL 7 : nouveaux paquetages kernel-rt.
De nouveaux paquetages sont disponibles :
  RHEL 7 : kernel-rt 3.10.0-957.rt56.910.el7

SUSE LE 11 SP3 : nouveaux paquetages kernel.
De nouveaux paquetages sont disponibles :
  SUSE LE 11 SP3 : kernel 3.0.101-0.47.106.50.1

SUSE LE 11 SP4 : nouveaux paquetages kernel.
De nouveaux paquetages sont disponibles :
  SUSE LE 11 SP4 : kernel 3.0.101-108.71.1

SUSE LE 11 SP4 : nouveaux paquetages kernel-rt.
De nouveaux paquetages sont disponibles :
  SUSE LE 11 SP4 : kernel-rt 3.0.101.rt130-69.36.1

SUSE LE 12 RTM : nouveaux paquetages kernel.
De nouveaux paquetages sont disponibles :
  SUSE LE 12 RTM : kernel default-3.12.61-52.146.1

SUSE LE 12 SP1 : nouveaux paquetages kernel.
De nouveaux paquetages sont disponibles :
  SUSE LE 12 SP1 : kernel 3.12.74-60.64.104.1

SUSE LE 12 SP2 : nouveaux paquetages kernel.
De nouveaux paquetages sont disponibles :
  SUSE LE 12 SP2 : kernel 4.4.121-92.95.1

SUSE LE 12 SP3 : nouveaux paquetages kernel (15/02/2021).
De nouveaux paquetages sont disponibles :
  SUSE LE 12 SP3 : kernel 4.4.180-94.138.1

SUSE LE 12 SP3 : nouveaux paquetages kernel (26/09/2018).
De nouveaux paquetages sont disponibles :
  SUSE LE 12 SP3 : kernel 4.4.155-4.16.1

SUSE LE 12 SP3 : nouveaux paquetages kernel-rt.
De nouveaux paquetages sont disponibles :
  SUSE LE 12 SP3 : kernel-rt 4.4.155-3.23.1

SUSE LE 15 : nouveaux paquetages kernel.
De nouveaux paquetages sont disponibles :
  SUSE LE 15 RTM : kernel 4.12.14-25.16.1

Ubuntu : nouveaux paquetages linux-image-3.13.0.
De nouveaux paquetages sont disponibles :
  Ubuntu 12.04 ESM : linux-image-generic-lts-trusty 3.13.0.164.154

Ubuntu : nouveaux paquetages linux-image-4.15.0.
De nouveaux paquetages sont disponibles :
  Ubuntu 18.04 LTS : linux-image-generic 4.15.0.43.45
  Ubuntu 16.04 LTS : linux-image-generic-hwe-16.04 4.15.0.43.64
  Ubuntu 14.04 LTS : linux-image-azure 4.15.0.1036.23

Ubuntu : nouveaux paquetages linux-image-4.4.0.
De nouveaux paquetages sont disponibles :
  Ubuntu 14.04 LTS : linux-image-generic-lts-xenial 4.4.0.137.117
  Ubuntu 16.04 LTS : linux-image-generic 4.4.0.137.143

Wind River Linux : solution (28/11/2018).
La solution est indiquée dans les sources d'information.
Bulletin complet, filtrage par logiciel, emails, correctifs, ... (Demandez votre essai gratuit)

Service de veille sur les vulnérabilités informatiques 

Vigil@nce fournit une veille de vulnérabilité de logiciel. La base de vulnérabilités Vigil@nce contient plusieurs milliers de failles.