L'équipe Vigil@nce veille les vulnérabilités publiques qui affectent votre parc informatique, puis propose des correctifs sécurité, une base de données de vigilance et des outils pour y remédier.

Vulnérabilité de Noyau Linux : corruption de mémoire via ext4_init_block_bitmap

Synthèse de la vulnérabilité 

Un attaquant peut provoquer une corruption de mémoire via ext4_init_block_bitmap() du noyau Linux, afin de mener un déni de service, et éventuellement d'exécuter du code.
Systèmes impactés : Debian, Linux, openSUSE Leap, RHEL, SUSE Linux Enterprise Desktop, SLES, Ubuntu.
Gravité de cette alerte : 2/4.
Date de création : 19/07/2018.
Références de cette alerte : 199865, CERTFR-2018-AVI-408, CERTFR-2018-AVI-419, CERTFR-2018-AVI-456, CERTFR-2018-AVI-460, CERTFR-2018-AVI-480, CERTFR-2019-AVI-035, CERTFR-2019-AVI-041, CERTFR-2019-AVI-188, CVE-2018-10878, DLA-1423-1, DLA-1424-1, DLA-1434-1, DLA-1529-1, openSUSE-SU-2018:2404-1, openSUSE-SU-2018:2407-1, RHSA-2018:2948-01, RHSA-2018:3083-01, RHSA-2018:3096-01, SUSE-SU-2018:2380-1, SUSE-SU-2018:2381-1, SUSE-SU-2018:2596-1, SUSE-SU-2018:2858-1, SUSE-SU-2018:2908-1, SUSE-SU-2018:2908-2, SUSE-SU-2018:3083-1, SUSE-SU-2018:3084-1, USN-3753-1, USN-3753-2, USN-3871-1, USN-3871-2, USN-3871-3, USN-3871-4, USN-3871-5, VIGILANCE-VUL-26789.

Description de la vulnérabilité 

Un attaquant peut provoquer une corruption de mémoire via ext4_init_block_bitmap() du noyau Linux, afin de mener un déni de service, et éventuellement d'exécuter du code.
Bulletin complet, filtrage par logiciel, emails, correctifs, ... (Demandez votre essai gratuit)

Cette alerte sécurité concerne les logiciels ou systèmes comme Debian, Linux, openSUSE Leap, RHEL, SUSE Linux Enterprise Desktop, SLES, Ubuntu.

Notre équipe Vigil@nce a déterminé que la gravité de ce bulletin cybersécurité est moyen.

Le niveau de confiance est de type confirmé par l'éditeur, avec une provenance de shell utilisateur.

Un attaquant avec un niveau de compétence expert peut exploiter cet avis de vulnérabilité informatique.

Solutions pour cette menace 

Noyau Linux : version 4.17.6.
La version 4.17.6 est corrigée :
  https://cdn.kernel.org/pub/linux/kernel/v4.x/

Noyau Linux : version 4.14.55.
La version 4.14.55 est corrigée :
  https://cdn.kernel.org/pub/linux/kernel/v4.x/

Noyau Linux : version 4.9.112.
La version 4.9.112 est corrigée :
  https://cdn.kernel.org/pub/linux/kernel/v4.x/

Noyau Linux : version 4.4.140.
La version 4.4.140 est corrigée :
  https://cdn.kernel.org/pub/linux/kernel/v4.x/

Noyau Linux : version 3.18.124.
La version 3.18.124 est corrigée :
  https://cdn.kernel.org/pub/linux/kernel/v3.x/

Noyau Linux : version 3.16.58.
La version 3.16.58 est corrigée :
  https://cdn.kernel.org/pub/linux/kernel/v3.x/

Noyau Linux : patch pour ext4_init_block_bitmap.
Un patch est indiqué dans les sources d'information.

Debian 8 : nouveaux paquetages linux (05/10/2018).
De nouveaux paquetages sont disponibles :
  Debian 8 : linux 3.16.59-1

Debian 8 : nouveaux paquetages linux-4.9.
De nouveaux paquetages sont disponibles :
  Debian 8 : linux-4.9 4.9.110-1~deb8u1

openSUSE Leap 15.0 : nouveaux paquetages kernel.
De nouveaux paquetages sont disponibles :
  openSUSE Leap 15.0 : kernel 4.12.14-lp150.12.16.1

openSUSE Leap 42.3 : nouveaux paquetages kernel (17/08/2018).
De nouveaux paquetages sont disponibles :
  openSUSE Leap 42.3 : kernel 4.4.143-65.1

RHEL 7 : nouveaux paquetages kernel.
De nouveaux paquetages sont disponibles :
  RHEL 7 : kernel 3.10.0-957.el7

RHEL 7 : nouveaux paquetages kernel-alt (30/10/2018).
De nouveaux paquetages sont disponibles :
  RHEL 7 : kernel-alt 4.14.0-115.el7a

RHEL 7 : nouveaux paquetages kernel-rt.
De nouveaux paquetages sont disponibles :
  RHEL 7 : kernel-rt 3.10.0-957.rt56.910.el7

SUSE LE 12 RTM : nouveaux paquetages kernel.
De nouveaux paquetages sont disponibles :
  SUSE LE 12 RTM : kernel default-3.12.61-52.146.1

SUSE LE 12 SP1 : nouveaux paquetages kernel.
De nouveaux paquetages sont disponibles :
  SUSE LE 12 SP1 : kernel 3.12.74-60.64.104.1

SUSE LE 12 SP2 : nouveaux paquetages kernel.
De nouveaux paquetages sont disponibles :
  SUSE LE 12 SP2 : kernel 4.4.121-92.95.1

SUSE LE 12 SP3 : nouveaux paquetages kernel (26/09/2018).
De nouveaux paquetages sont disponibles :
  SUSE LE 12 SP3 : kernel 4.4.155-4.16.1

SUSE LE 12 SP3 : nouveaux paquetages kernel-rt.
De nouveaux paquetages sont disponibles :
  SUSE LE 12 SP3 :kernel-rt 4.4.147-3.20.1

SUSE LE 15 : nouveaux paquetages kernel.
De nouveaux paquetages sont disponibles :
  SUSE LE 15 RTM : kernel 4.12.14-25.13.1

Ubuntu 18.04 : nouveaux paquetages linux-image-4.15.0.
De nouveaux paquetages sont disponibles :
  Ubuntu 16.04 LTS : linux-image-generic-hwe-16.04 4.15.0.45.66
  Ubuntu 18.04 LTS : linux-image-generic 4.15.0-45.48

Ubuntu : nouveaux paquetages linux-image-4.4.0.
De nouveaux paquetages sont disponibles :
  Ubuntu 14.04 LTS : linux-image-generic-lts-xenial 4.4.0.134.114
  Ubuntu 16.04 LTS : linux-image-generic 4.4.0.134.140

Wind River Linux : solution (16/10/2018).
La solution est indiquée dans les sources d'information.
Bulletin complet, filtrage par logiciel, emails, correctifs, ... (Demandez votre essai gratuit)

Service de veille sur les vulnérabilités informatiques 

Vigil@nce fournit une annonce de vulnérabilités de systèmes. La base de vulnérabilités Vigil@nce contient plusieurs milliers de failles.