L'équipe Vigil@nce veille les vulnérabilités publiques qui affectent votre parc informatique, puis propose des correctifs sécurité, une base de données de vigilance et des outils pour y remédier.

Vulnérabilité de Noyau Linux : corruption de mémoire via perf_mmap_close

Synthèse de la vulnérabilité 

Un attaquant peut provoquer une corruption de mémoire via perf_mmap_close() du noyau Linux, afin de mener un déni de service, et éventuellement d'exécuter du code.
Systèmes impactés : Debian, Linux, openSUSE Leap, RHEL, SUSE Linux Enterprise Desktop, SLES, Ubuntu.
Gravité de cette alerte : 2/4.
Date de création : 04/11/2020.
Références de cette alerte : CERTFR-2020-AVI-711, CERTFR-2020-AVI-741, CERTFR-2020-AVI-750, CERTFR-2020-AVI-764, CERTFR-2020-AVI-769, CERTFR-2020-AVI-776, CERTFR-2020-AVI-784, CERTFR-2020-AVI-786, CERTFR-2020-AVI-834, CERTFR-2021-AVI-122, CERTFR-2021-AVI-158, CERTFR-2021-AVI-184, CERTFR-2021-AVI-201, CERTFR-2021-AVI-234, CERTFR-2021-AVI-265, CVE-2020-14351, DLA-2483-1, DLA-2494-1, openSUSE-SU-2020:1906-1, openSUSE-SU-2020:2112-1, openSUSE-SU-2021:0242-1, RHSA-2021:0537-01, RHSA-2021:0558-01, RHSA-2021:0686-01, RHSA-2021:0765-01, RHSA-2021:0774-01, RHSA-2021:0848-01, RHSA-2021:0856-01, RHSA-2021:0857-01, RHSA-2021:0878-01, RHSA-2021:1028-01, SUSE-SU-2020:3122-1, SUSE-SU-2020:3272-1, SUSE-SU-2020:3281-1, SUSE-SU-2020:3326-1, SUSE-SU-2020:3484-1, SUSE-SU-2020:3491-1, SUSE-SU-2020:3501-1, SUSE-SU-2020:3503-1, SUSE-SU-2020:3512-1, SUSE-SU-2020:3513-1, SUSE-SU-2020:3522-1, SUSE-SU-2020:3532-1, SUSE-SU-2020:3544-1, USN-4657-1, USN-4658-1, USN-4658-2, USN-4659-1, USN-4659-2, USN-4660-1, USN-4660-2, USN-4912-1, VIGILANCE-VUL-33803, ZDI-20-1372.

Description de la vulnérabilité 

Un attaquant peut provoquer une corruption de mémoire via perf_mmap_close() du noyau Linux, afin de mener un déni de service, et éventuellement d'exécuter du code.
Bulletin complet, filtrage par logiciel, emails, correctifs, ... (Demandez votre essai gratuit)

Cette annonce de vulnérabilité informatique concerne les logiciels ou systèmes comme Debian, Linux, openSUSE Leap, RHEL, SUSE Linux Enterprise Desktop, SLES, Ubuntu.

Notre équipe Vigil@nce a déterminé que la gravité de ce bulletin de vulnérabilité est moyen.

Le niveau de confiance est de type confirmé par l'éditeur, avec une provenance de shell utilisateur.

Un attaquant avec un niveau de compétence expert peut exploiter cette vulnérabilité informatique.

Solutions pour cette menace 

Noyau Linux : patch pour perf_mmap_close.
Un patch est indiqué dans les sources d'information.

Debian 9 : nouveaux paquetages linux.
De nouveaux paquetages sont disponibles :
  Debian 9 : linux 4.9.246-2

Debian 9 : nouveaux paquetages linux-4.19 (10/12/2020).
De nouveaux paquetages sont disponibles :
  Debian 9 : linux-4.19 4.19.160-2~deb9u1

openSUSE Leap 15.2 : nouveaux paquetages kernel (13/11/2020).
De nouveaux paquetages sont disponibles :
  openSUSE Leap 15.2 : kernel 5.3.18-lp152.50.1

openSUSE Leap 15.2 : nouveaux paquetages kernel (30/11/2020).
De nouveaux paquetages sont disponibles :
  openSUSE Leap 15.2 : kernel 5.3.18-lp152.50.1.lp152.8.10.1

openSUSE Leap 15.2 : nouveaux paquetages kernel-rt.
De nouveaux paquetages sont disponibles :
  openSUSE Leap 15.2 : kernel-rt 5.3.18-lp152.3.5.1

RHEL 7.3 : nouveaux paquetages kernel.
De nouveaux paquetages sont disponibles :
  RHEL 7.3 : kernel 3.10.0-514.86.1.el7

RHEL 7.6 : nouveaux paquetages kernel.
De nouveaux paquetages sont disponibles :
  RHEL 7.0-7.9 : kernel 3.10.0-957.70.1.el7

RHEL 7.7 : nouveaux paquetages kernel.
De nouveaux paquetages sont disponibles :
  RHEL 7.7 : kernel 3.10.0-1062.46.1.el7

RHEL 7.9 : nouveaux paquetages kernel.
De nouveaux paquetages sont disponibles :
  RHEL 7.9 : kernel 3.10.0-1160.21.1.el7

RHEL 7.9 : nouveaux paquetages kernel-rt.
De nouveaux paquetages sont disponibles :
  RHEL 7.9 : kernel-rt 3.10.0-1160.21.1.rt56.1158.el7

RHEL 8.1 : nouveaux paquetages kernel.
De nouveaux paquetages sont disponibles :
  RHEL 8.1 : kernel 4.18.0-147.43.1.el8_1

RHEL 8.2 : nouveaux paquetages kernel.
De nouveaux paquetages sont disponibles :
  RHEL 8.2 : kernel 4.18.0-193.46.1.el8_2

RHEL 8.2 : nouveaux paquetages kernel-rt.
De nouveaux paquetages sont disponibles :
  RHEL 8.2 : kernel-rt 4.18.0-193.46.1.rt13.96.el8_2

RHEL 8.3 : nouveaux paquetages kernel.
De nouveaux paquetages sont disponibles :
  RHEL 8.3 : kernel 4.18.0-240.15.1.el8_3

RHEL 8.3 : nouveaux paquetages kernel-rt.
De nouveaux paquetages sont disponibles :
  RHEL 8.3 : kernel-rt 4.18.0-240.15.1.rt7.69.el8_3

SUSE LE 12 SP2 : nouveaux paquetages kernel-default.
De nouveaux paquetages sont disponibles :
  SUSE LE 12 SP2 : kernel-default 4.4.121-92.146.1
  SUSE LE 12 SP2 : kernel-default 4.4.121-92.146.1

SUSE LE 12 SP3 : nouveaux paquetages kernel-default.
De nouveaux paquetages sont disponibles :
  SUSE LE 12 SP3 : kernel-default 4.4.180-94.135.1

SUSE LE 12 SP4 : nouveaux paquetages kernel-default.
De nouveaux paquetages sont disponibles :
  SUSE LE 12 SP4 : kernel-default 4.12.14-95.65.1

SUSE LE 12 SP5 : nouveaux paquetages kernel (16/11/2020).
De nouveaux paquetages sont disponibles :
  SUSE LE 12 SP5 : kernel 4.12.14-122.51.2

SUSE LE 12 SP5 : nouveaux paquetages kernel-azure.
De nouveaux paquetages sont disponibles :
  SUSE LE 12 SP5 : kernel-azure 4.12.14-16.34.1

SUSE LE 12 SP5 : nouveaux paquetages kernel-rt.
De nouveaux paquetages sont disponibles :
  SUSE LE 12 SP5 : kernel-rt 4.12.14-10.22.1

SUSE LE 15 : nouveaux paquetages kernel.
De nouveaux paquetages sont disponibles :
  SUSE LE 15 RTM : kernel-default-livepatch 4.12.14-150.63.1, kernel-livepatch 4_12_14-150_63-default-1-1.5.1

SUSE LE 15 SP1 : nouveaux paquetages kernel.
De nouveaux paquetages sont disponibles :
  SUSE LE 15 SP1 : kernel 4.12.14-197.67.1

SUSE LE 15 SP1 : nouveaux paquetages kernel-azure (24/11/2020).
De nouveaux paquetages sont disponibles :
  SUSE LE 15 SP1 : kernel-azure 4.12.14-8.52.1

SUSE LE 15 SP1 : nouveaux paquetages kernel-rt.
De nouveaux paquetages sont disponibles :
  SUSE LE 15 SP1 : kernel-rt 4.12.14-14.41.2

SUSE LE 15 SP2 : nouveaux paquetages kernel.
De nouveaux paquetages sont disponibles :
  SUSE LE 15 SP2 : kernel 5.3.18-24.34.1

SUSE LE 15 SP2 : nouveaux paquetages kernel-azure (24/11/2020).
De nouveaux paquetages sont disponibles :
  SUSE LE 15 SP2 : kernel-azure 5.3.18-18.24.1

SUSE LE 15 SP2 : nouveaux paquetages kernel-rt (26/11/2020).
De nouveaux paquetages sont disponibles :
  SUSE LE 15 SP2 : kernel-rt 5.3.18-16.1

Ubuntu 20.04 : nouveaux paquetages linux-image-oem-20.04.
De nouveaux paquetages sont disponibles :
  Ubuntu 20.04 LTS : linux-image-oem-20.04 5.6.0.1053.49

Ubuntu 20.10 : nouveaux paquetages linux-image-5.8.0.
De nouveaux paquetages sont disponibles :
  Ubuntu 20.10 : linux-image-generic 5.8.0.33.38

Ubuntu : nouveaux paquetages linux-image-4.15.0.
De nouveaux paquetages sont disponibles :
  Ubuntu 14.04 ESM : linux-image-azure 4.15.0.1100.75
  Ubuntu 16.04 LTS : linux-image-generic-hwe-16.04 4.15.0.128.127
  Ubuntu 18.04 LTS : linux-image-generic 4.15.0.128.115

Ubuntu : nouveaux paquetages linux-image-4.4.0 (02/12/2020).
De nouveaux paquetages sont disponibles :
  Ubuntu 14.04 ESM : linux-image-generic-lpae-lts-xenial 4.4.0.197.172
  Ubuntu 16.04 LTS : linux-image-generic 4.4.0.197.203

Ubuntu : nouveaux paquetages linux-image-5.4.0.
De nouveaux paquetages sont disponibles :
  Ubuntu 18.04 LTS : linux-image-generic-hwe-18.04 5.4.0.58.64~18.04.53
  Ubuntu 20.04 LTS : linux-image-generic 5.4.0.58.61
Bulletin complet, filtrage par logiciel, emails, correctifs, ... (Demandez votre essai gratuit)

Service de veille sur les vulnérabilités informatiques 

Vigil@nce fournit des avis de vulnérabilités logicielles. La veille sécurité Vigil@nce publie des bulletins de vulnérabilités pour les failles qui impactent le système d'information.