L'équipe Vigil@nce veille les vulnérabilités publiques qui affectent votre parc informatique, puis propose des correctifs sécurité, une base de données de vigilance et des outils pour y remédier.

Vulnérabilité de Noyau Linux : déni de service via irda_bind

Synthèse de la vulnérabilité 

Un attaquant peut utiliser irda_bind() afin de stopper le noyau.
Systèmes impactés : Debian, Fedora, Linux, openSUSE, SLES.
Gravité de cette alerte : 2/4.
Date de création : 01/09/2010.
Références de cette alerte : 628770, BID-42900, BID-42936, CVE-2010-2954, DSA-2110-1, FEDORA-2010-14235, FEDORA-2010-14832, FEDORA-2010-14878, openSUSE-SU-2010:0634-1, openSUSE-SU-2010:0664-1, openSUSE-SU-2010:0720-1, openSUSE-SU-2010:0895-1, SUSE-SA:2010:041, SUSE-SA:2010:046, SUSE-SA:2010:050, SUSE-SA:2010:054, SUSE-SA:2011:007, VIGILANCE-VUL-9893.

Description de la vulnérabilité 

La fonction irda_bind() du fichier net/irda/af_irda.c associe une socket AF_IRDA à un point de communication.

Lorsque la fonction irda_bind() est appelée, la fonction irda_open_tsap() du fichier net/irda/af_irda.c est utilisée pour ouvrir un point de communication. Cependant, lorsque irda_open_tsap() échoue, irda_bind() libère incorrectement les ressources allouées. Lorsque la socket est détruite plus tard, un pointeur NULL est déréférencé stoppant ainsi le noyau.

Un attaquant peut donc utiliser irda_bind() de nombreuses fois afin de stopper le noyau.
Bulletin complet, filtrage par logiciel, emails, correctifs, ... (Demandez votre essai gratuit)

Cet avis cyber-sécurité concerne les logiciels ou systèmes comme Debian, Fedora, Linux, openSUSE, SLES.

Notre équipe Vigil@nce a déterminé que la gravité de ce bulletin de faille informatique est moyen.

Le niveau de confiance est de type confirmé par l'éditeur, avec une provenance de shell utilisateur.

Un attaquant avec un niveau de compétence expert peut exploiter cette faille.

Solutions pour cette menace 

Noyau Linux : version 2.6.36.
La version 2.6.36 est corrigée :
  http://www.kernel.org/pub/linux/kernel/v2.6/

Noyau Linux : version 2.4.37.10.
La version 2.4.37.10 est corrigée :
  http://www.kernel.org/pub/linux/kernel/v2.4/

Noyau Linux : patch pour irda_bind.
Un patch est disponible dans les sources d'information.

Debian : nouveaux paquetages linux-2.6.
De nouveaux paquetages sont disponibles :
  http://security.debian.org/pool/updates/main/l/linux-2.6/linux-*-2.6.26_2.6.26-25lenny1_*.deb

Fedora 12 : nouveaux paquetages kernel.
De nouveaux paquetages sont disponibles :
  kernel-2.6.32.21-168.fc12

Fedora 13 : nouveaux paquetages kernel.
De nouveaux paquetages sont disponibles :
  kernel-2.6.34.6-54.fc13

Fedora 14 : nouveaux paquetages kernel.
De nouveaux paquetages sont disponibles :
  kernel-2.6.35.4-28.fc14

openSUSE 11.2 : nouveaux paquetages kernel.
De nouveaux paquetages sont disponibles :
  kernel-*-2.6.31.14-0.1.1

openSUSE 11.3 : nouveaux paquetages kernel.
De nouveaux paquetages sont disponibles :
   http://download.opensuse.org/update/11.3/rpm/i586/kernel-*-2.6.34.7-0.2.2.i586.rpm

SLE 11 GA : nouveaux paquetages kernel.
De nouveaux paquetages sont disponibles :
SLE 11 SERVER Unsupported Extras (i586 ia64 ppc64 s390x x86_64):
  kernel-default-extra-2.6.27.54-0.2.1
SLE 11 SERVER Unsupported Extras (i586 x86_64):
  kernel-xen-extra-2.6.27.54-0.2.1
SLE 11 SERVER Unsupported Extras (ppc64):
  kernel-ppc64-extra-2.6.27.54-0.2.1
SLE 11 SERVER Unsupported Extras (i586):
  kernel-pae-extra-2.6.27.54-0.2.1

SUSE LE 11 : nouveaux paquetages kernel.
De nouveaux paquetages sont disponibles, comme indiqué dans les sources d'informations.

SUSE LE RT 11 : nouveaux paquetages kernel-rt.
De nouveaux paquetages sont disponibles :
  SUSE Linux Enterprise Real Time 11 SP1
    http://download.novell.com/patch/finder/?keywords=956b7941659a9a350984b3e4fa8be427

SUSE : nouveaux paquetages kernel.
De nouveaux paquetages sont disponibles, comme indiqué dans les sources d'informations.
Bulletin complet, filtrage par logiciel, emails, correctifs, ... (Demandez votre essai gratuit)

Service de veille sur les vulnérabilités informatiques 

Vigil@nce fournit des avis cyber-sécurité. La base de vulnérabilités Vigil@nce contient plusieurs milliers de failles.