L'équipe Vigil@nce veille les vulnérabilités publiques qui affectent votre parc informatique, puis propose des correctifs sécurité, une base de données de vigilance et des outils pour y remédier.

Vulnérabilité de Noyau Linux : déni de service via release_one_tty

Synthèse de la vulnérabilité 

Un attaquant local peut utiliser des ttys, afin de provoquer une fuite de ressources dans le noyau.
Systèmes impactés : Debian, Fedora, Linux, Mandriva Linux, openSUSE, RHEL, SLES.
Gravité de cette alerte : 1/4.
Date de création : 15/04/2010.
Références de cette alerte : BID-39480, CVE-2010-1162, DSA-2053-1, FEDORA-2010-7779, MDVSA-2010:188, MDVSA-2010:198, openSUSE-SU-2010:0664-1, RHSA-2010:0631-01, SUSE-SA:2010:031, SUSE-SA:2010:046, VIGILANCE-VUL-9593.

Description de la vulnérabilité 

La fonction release_one_tty() du fichier drivers/char/tty_io.c est appelée lorsqu'un tty (interface terminal) est fermé.

Cette fonction appelle free_tty_struct() pour libérer la structure tty, qui contient notamment les champs pgrp (process group id) et session. Cependant, les pid (process id) associés ne sont pas libérés.

Un attaquant local peut donc utiliser des ttys, afin de provoquer une fuite de ressources dans le noyau.
Bulletin complet, filtrage par logiciel, emails, correctifs, ... (Demandez votre essai gratuit)

Ce bulletin cybersécurité concerne les logiciels ou systèmes comme Debian, Fedora, Linux, Mandriva Linux, openSUSE, RHEL, SLES.

Notre équipe Vigil@nce a déterminé que la gravité de ce bulletin sécurité est faible.

Le niveau de confiance est de type confirmé par l'éditeur, avec une provenance de shell utilisateur.

Un attaquant avec un niveau de compétence expert peut exploiter cette menace informatique.

Solutions pour cette menace 

Noyau Linux : version 2.6.34.
La version 2.6.34 est corrigée :
  http://www.kernel.org/pub/linux/kernel/v2.6/

Noyau Linux : version 2.6.33.3.
La version 2.6.33.3 est corrigée :
  http://www.kernel.org/pub/linux/kernel/v2.6/

Noyau Linux : version 2.6.32.12.
La version 2.6.32.12 est corrigée :
  http://www.kernel.org/pub/linux/kernel/v2.6/

Noyau Linux : version 2.6.27.47.
La version 2.6.27.47 est corrigée :
  http://www.kernel.org/pub/linux/kernel/v2.6/

Noyau Linux : patch pour release_one_tty.
Un patch est disponible dans les sources d'information.

Debian : nouveaux paquetages linux-2.6.
De nouveaux paquetages sont disponibles :
  http://security.debian.org/pool/updates/main/l/linux-2.6/linux-*-2.6.26_2.6.26-22lenny1_*.deb

Fedora 12 : nouveaux paquetages kernel (19/05/2010).
De nouveaux paquetages sont disponibles :
  kernel-2.6.32.12-115.fc12

Mandriva 2009.0 : nouveaux paquetages kernel.
De nouveaux paquetages sont disponibles :
  Mandriva Linux 2009.0: kernel-2.6.27.53-1mnb2

Mandriva 2010.1, MES 5 : nouveaux paquetages kernel.
De nouveaux paquetages sont disponibles :
  Mandriva Linux 2010.1: kernel-2.6.33.7-2mnb-1-1mnb2
  Mandriva Enterprise Server 5: kernel-2.6.27.53-1mnb-1-1mnb2

openSUSE 11.2 : nouveaux paquetages kernel.
De nouveaux paquetages sont disponibles :
  kernel-*-2.6.31.14-0.1.1

RHEL 5 MRG : nouveaux paquetages kernel-rt.
De nouveaux paquetages sont disponibles :
  kernel-rt-2.6.24.7-161.el5rt

SUSE : nouveaux paquetages kernel (20/07/2010).
De nouveaux paquetages sont disponibles, comme indiqué dans les sources d'informations.
Bulletin complet, filtrage par logiciel, emails, correctifs, ... (Demandez votre essai gratuit)

Service de veille sur les vulnérabilités informatiques 

Vigil@nce fournit une contre-mesure de sécurité informatique. Chaque administrateur peut personnaliser la liste des produits pour lesquels il souhaite recevoir des alertes de vulnérabilités.