L'équipe Vigil@nce veille les vulnérabilités publiques qui affectent votre parc informatique, puis propose des correctifs sécurité, une base de données de vigilance et des outils pour y remédier.

Vulnérabilité de Noyau Linux : déni de service via sctp_asoc_get_hmac

Synthèse de la vulnérabilité 

Un attaquant peut inviter la victime à se connecter sur un service SCTP illicite, afin de stopper sa machine.
Systèmes vulnérables : Debian, Fedora, Linux, openSUSE, RHEL, SLES.
Gravité de cette menace : 2/4.
Date de création : 04/10/2010.
Références de cette faille : BID-43701, CERTA-2002-AVI-272, CVE-2010-3705, DSA-2126-1, FEDORA-2010-18983, MDVSA-2011:029, openSUSE-SU-2011:0159-1, openSUSE-SU-2011:0346-1, openSUSE-SU-2011:0399-1, openSUSE-SU-2013:0927-1, RHSA-2010:0842-01, RHSA-2010:0958-01, SUSE-SA:2011:012, SUSE-SA:2011:017, SUSE-SA:2011:020, VIGILANCE-VUL-9998.

Description de la vulnérabilité 

Le protocole SCTP (Stream Control Transmission Protocol) permet de faire transiter plusieurs flux dans une même session.

Lorsque /proc/sys/net/sctp/auth_enable est activé, SCTP utilise une authentification basée sur HMAC. Le serveur envoie alors une liste d'identifiants correspondant aux algorithmes supportés :
 - 1 : hmac(sha1)
 - 3 : hmac(sha256)

Cependant, si le dernier identifiant est supérieur à SCTP_AUTH_HMAC_ID_MAX (3), la fonction sctp_asoc_get_hmac() emploie un indice de tableau invalide, correspondant à une zone mémoire non initialisée.

Un attaquant peut donc inviter la victime à se connecter sur un service SCTP illicite, afin de stopper sa machine.
Bulletin complet, filtrage par logiciel, emails, correctifs, ... (Demandez votre essai gratuit)

Cette menace cybersécurité concerne les logiciels ou systèmes comme Debian, Fedora, Linux, openSUSE, RHEL, SLES.

Notre équipe Vigil@nce a déterminé que la gravité de ce bulletin de menace informatique est moyen.

Le niveau de confiance est de type confirmé par l'éditeur, avec une provenance de client intranet.

Un attaquant avec un niveau de compétence expert peut exploiter cette vulnérabilité cybersécurité.

Solutions pour cette menace 

Noyau Linux : version 2.6.36.
La version 2.6.36 est corrigée :
  http://www.kernel.org/pub/linux/kernel/v2.6/

Noyau Linux : version 2.6.34.9.
La version 2.6.34.9 est corrigée :
  http://www.kernel.org/pub/linux/kernel/v2.6/longterm/v2.6.34/

Noyau Linux : version 2.6.33.8.
La version 2.6.33.8 est corrigée :
  http://www.kernel.org/pub/linux/kernel/v2.6/longterm/v2.6.33/

Noyau Linux : version 2.6.27.59.
La version 2.6.27.59 est corrigée :
  http://www.kernel.org/pub/linux/kernel/v2.6/longterm/v2.6.27/

Noyau Linux : patch pour sctp_asoc_get_hmac.
Un patch est disponible dans les sources d'information.

Debian : nouveaux paquetages linux-2.6 (29/11/2010).
De nouveaux paquetages sont disponibles :
  http://security.debian.org/pool/updates/main/l/linux-2.6/linux-*_2.6.26-26lenny1_*.deb

Fedora 13 : nouveaux paquetages kernel (28/12/2010).
De nouveaux paquetages sont disponibles :
  kernel-2.6.34.7-66.fc13

Mandriva ES 5 : nouveaux paquetages kernel.
De nouveaux paquetages sont disponibles :
  Mandriva Enterprise Server 5: kernel-2.6.27.56-2mnb-1-1mnb2

openSUSE 11.2 : nouveaux paquetages kernel (18/04/2011).
De nouveaux paquetages sont disponibles :
  kernel-*-2.6.31.14-0.8.1

openSUSE 11.3 : nouveaux paquetages kernel.
De nouveaux paquetages sont disponibles :
  kernel-*-2.6.34.8-0.2.1

openSUSE 11.4 : nouveaux paquetages kernel-3.0.58 (10/06/2013).
De nouveaux paquetages sont disponibles :
  kernel-3.0.58-30.2

RHEL 5 MRG : nouveaux paquetages kernel-rt.
De nouveaux paquetages sont disponibles :
MRG Realtime for RHEL 5 Server:
  kernel-rt-2.6.33.7-rt29.47.el5rt

RHEL 6 : nouveaux paquetages kernel.
De nouveaux paquetages sont disponibles :
  kernel-2.6.32-71.7.1.el6

SUSE LE 11 : nouveaux paquetages kernel (08/03/2011).
De nouveaux paquetages sont disponibles :
SUSE Linux Enterprise Server 11 SP1
  http://download.novell.com/patch/finder/?keywords=b296065a76246d5eb3b84a54249a6ab9
  http://download.novell.com/patch/finder/?keywords=37a20332a3477c6790648da1bb44afd0
  http://download.novell.com/patch/finder/?keywords=40fa968a3fed1c5ae479db978466dc9b
  http://download.novell.com/patch/finder/?keywords=a980dec7ad0f6081c9c24832e0e59c6f
  http://download.novell.com/patch/finder/?keywords=abeba8d6c807360502c7dfc6ca6f2b4d
SUSE Linux Enterprise Desktop 11 SP1
  http://download.novell.com/patch/finder/?keywords=b296065a76246d5eb3b84a54249a6ab9
  http://download.novell.com/patch/finder/?keywords=abeba8d6c807360502c7dfc6ca6f2b4d
SUSE Linux Enterprise High Availability Extension 11 SP1
  http://download.novell.com/patch/finder/?keywords=b296065a76246d5eb3b84a54249a6ab9
  http://download.novell.com/patch/finder/?keywords=37a20332a3477c6790648da1bb44afd0
  http://download.novell.com/patch/finder/?keywords=40fa968a3fed1c5ae479db978466dc9b
  http://download.novell.com/patch/finder/?keywords=a980dec7ad0f6081c9c24832e0e59c6f
  http://download.novell.com/patch/finder/?keywords=abeba8d6c807360502c7dfc6ca6f2b4d

SUSE LE 11 : nouveaux paquetages kernel-extra (09/03/2011).
De nouveaux paquetages sont disponibles :
SLE 11 SERVER Unsupported Extras:
  kernel-*-extra-2.6.32.29-0.3.1
Bulletin complet, filtrage par logiciel, emails, correctifs, ... (Demandez votre essai gratuit)

Service de veille sur les vulnérabilités informatiques 

Vigil@nce fournit des alertes de vulnérabilité de réseau. Chaque administrateur peut personnaliser la liste des produits pour lesquels il souhaite recevoir des alertes de vulnérabilités.