L'équipe Vigil@nce veille les vulnérabilités publiques qui affectent votre parc informatique, puis propose des correctifs sécurité, une base et des outils pour y remédier.

annonce de faille informatique CVE-2019-15098

Noyau Linux : déréférencement de pointeur NULL via ath6kl_usb_alloc_urb_from_pipe

Synthèse de la vulnérabilité

Un attaquant peut forcer le déréférencement d'un pointeur NULL via ath6kl_usb_alloc_urb_from_pipe() du noyau Linux, afin de mener un déni de service.
Gravité de cette annonce : 1/4.
Date création : 19/08/2019.
Références de cette vulnérabilité informatique : CERTFR-2019-AVI-455, CERTFR-2019-AVI-502, CERTFR-2019-AVI-503, CERTFR-2019-AVI-530, CVE-2019-15098, openSUSE-SU-2019:2173-1, openSUSE-SU-2019:2181-1, SSA:2019-311-01, SUSE-SU-2019:2412-1, SUSE-SU-2019:2424-1, SUSE-SU-2019:2648-1, SUSE-SU-2019:2651-1, SUSE-SU-2019:2658-1, SUSE-SU-2019:2738-1, VIGILANCE-VUL-30079.
Bulletin Vigil@nce complet... (Essai gratuit)

Description de la vulnérabilité

Un attaquant peut forcer le déréférencement d'un pointeur NULL via ath6kl_usb_alloc_urb_from_pipe() du noyau Linux, afin de mener un déni de service.
Bulletin Vigil@nce complet... (Essai gratuit)

Cette annonce de vulnérabilité informatique concerne les logiciels ou systèmes comme Linux, openSUSE Leap, Slackware, SUSE Linux Enterprise Desktop, SLES.

Notre équipe Vigil@nce a déterminé que la gravité de ce bulletin de vulnérabilité est faible.

Le niveau de confiance est de type confirmé par l'éditeur, avec une provenance de shell utilisateur.

Un attaquant avec un niveau de compétence expert peut exploiter cette vulnérabilité informatique.

Solutions pour cette menace

Noyau Linux : version 5.3.9.
La version 5.3.9 est corrigée :
  https://cdn.kernel.org/pub/linux/kernel/v5.x/

Noyau Linux : version 4.19.82.
La version 4.19.82 est corrigée :
  https://cdn.kernel.org/pub/linux/kernel/v4.x/

Noyau Linux : version 4.14.152.
La version 4.14.152 est corrigée :
  https://cdn.kernel.org/pub/linux/kernel/v4.x/

Noyau Linux : version 4.9.199.
La version 4.9.199 est corrigée :
  https://cdn.kernel.org/pub/linux/kernel/v4.x/

Noyau Linux : version 4.4.199.
La version 4.4.199 est corrigée :
  https://cdn.kernel.org/pub/linux/kernel/v4.x/

Noyau Linux : patch pour ath6kl_usb_alloc_urb_from_pipe.
Un patch est indiqué dans les sources d'information.

openSUSE Leap 15 : nouveaux paquetages kernel.
De nouveaux paquetages sont disponibles :
  openSUSE Leap 15.0 : kernel 4.12.14-lp150.12.73.1
  openSUSE Leap 15.1 : kernel 4.12.14-lp151.28.16.1

Slackware 14.2 : nouveaux paquetages kernel.
De nouveaux paquetages sont disponibles :
  Slackware 14.2 : kernel 4.4.199-*-1

SUSE LE 12 SP4 : nouveaux paquetages kernel-azure.
De nouveaux paquetages sont disponibles :
  SUSE LE 12 SP4 : kernel-azure 4.12.14-6.26.1

SUSE LE 12 SP4 : nouveaux paquetages kernel-default.
De nouveaux paquetages sont disponibles :
  SUSE LE 12 SP4 : kernel-default 4.12.14-95.32.1

SUSE LE 15 : nouveaux paquetages kernel-azure.
De nouveaux paquetages sont disponibles :
  SUSE LE 15 RTM : kernel-azure 4.12.14-5.41.1
  SUSE LE 15 SP1 : kernel-azure 4.12.14-8.16.1

SUSE LE 15 SP1 : nouveaux paquetages kernel-default.
De nouveaux paquetages sont disponibles :
  SUSE LE 15 SP1 : kernel-default 4.12.14-197.18.1

SUSE LE 15 SP1 : nouveaux paquetages kernel-rt.
De nouveaux paquetages sont disponibles :
  SUSE LE 15 SP1 : kernel-rt 4.12.14-14.11.1
Bulletin Vigil@nce complet... (Essai gratuit)

Service de veille sur les vulnérabilités informatiques

Vigil@nce fournit une base de vulnérabilité de réseau. Le service de veille sur les vulnérabilités informatiques Vigil@nce alerte vos équipes des failles et des menaces qui concernent votre système d'information. Chaque administrateur peut personnaliser la liste des produits pour lesquels il souhaite recevoir des alertes de vulnérabilités. La base de vulnérabilités Vigil@nce contient plusieurs milliers de failles.