L'équipe Vigil@nce veille les vulnérabilités publiques qui affectent votre parc informatique, puis propose des correctifs sécurité, une base de données de vigilance et des outils pour y remédier.

Vulnérabilité de Noyau Linux : déréférencement de pointeur NULL via inet_autobind

Synthèse de la vulnérabilité 

Un attaquant local peut forcer le déréférencement d'un pointeur NULL dans la fonction inet_autobind() du noyau Linux, afin de mener un déni de service.
Logiciels impactés : Debian, Fedora, NSM Central Manager, NSMXpress, Linux, openSUSE, openSUSE Leap, RHEL, SUSE Linux Enterprise Desktop, SLES, Ubuntu.
Gravité de cette vulnérabilité informatique : 1/4.
Date de création : 14/12/2015.
Références de cette annonce : CERTFR-2015-AVI-554, CERTFR-2015-AVI-561, CERTFR-2016-AVI-004, CERTFR-2016-AVI-044, CERTFR-2016-AVI-069, CERTFR-2016-AVI-073, CERTFR-2016-AVI-110, CVE-2015-8543, DSA-3426-1, DSA-3426-2, DSA-3434-1, FEDORA-2015-c1c2f5e168, FEDORA-2015-c59710b05d, JSA10853, openSUSE-SU-2016:0280-1, openSUSE-SU-2016:0301-1, openSUSE-SU-2016:0318-1, openSUSE-SU-2016:2649-1, RHSA-2016:0855-01, RHSA-2016:2574-02, RHSA-2016:2584-02, SUSE-SU-2016:0168-1, SUSE-SU-2016:0585-1, SUSE-SU-2016:0911-1, SUSE-SU-2016:1102-1, SUSE-SU-2016:1203-1, SUSE-SU-2016:2074-1, USN-2886-1, USN-2886-2, USN-2888-1, USN-2890-1, USN-2890-2, USN-2890-3, USN-2907-1, USN-2907-2, USN-2910-1, USN-2910-2, VIGILANCE-VUL-18508.

Description de la vulnérabilité 

Le noyau Linux supporte les sockets bas niveau de type SOCK_RAW.

Cependant, l'utilisation d'une socket SOCK_RAW, de famille AF_INET6 (IPv6), avec un protocole invalide, force la fonction inet_autobind() à utiliser un pointeur de fonction NULL.

Un attaquant local peut donc forcer le déréférencement d'un pointeur NULL dans la fonction inet_autobind() du noyau Linux, afin de mener un déni de service.
Bulletin complet, filtrage par logiciel, emails, correctifs, ... (Demandez votre essai gratuit)

Cette alerte sécurité concerne les logiciels ou systèmes comme Debian, Fedora, NSM Central Manager, NSMXpress, Linux, openSUSE, openSUSE Leap, RHEL, SUSE Linux Enterprise Desktop, SLES, Ubuntu.

Notre équipe Vigil@nce a déterminé que la gravité de ce bulletin cybersécurité est faible.

Le niveau de confiance est de type confirmé par l'éditeur, avec une provenance de shell privilégié.

Un démonstrateur ou un outil d'attaque est disponible, donc vos équipes doivent traiter cette alerte. Un attaquant avec un niveau de compétence technicien peut exploiter cet avis de vulnérabilité informatique.

Solutions pour cette menace 

Noyau Linux : version 4.3.4.
La version 4.3.4 est corrigée :
  https://cdn.kernel.org/pub/linux/kernel/v4.x/

Noyau Linux : version 4.1.16.
La version 4.1.16 est corrigée :
  https://cdn.kernel.org/pub/linux/kernel/v4.x/linux-4.1.16.tar.xz

Noyau Linux : version 3.18.26.
La version 3.18.26 est corrigée :
  https://cdn.kernel.org/pub/linux/kernel/v3.x/linux-3.18.26.tar.xz

Noyau Linux : version 3.14.59.
La version 3.14.59 est corrigée :
  https://cdn.kernel.org/pub/linux/kernel/v3.x/linux-3.14.59.tar.xz

Noyau Linux : version 3.12.52.
La version 3.12.52 est corrigée :
  https://cdn.kernel.org/pub/linux/kernel/v3.x/

Noyau Linux : version 3.10.95.
La version 3.10.95 est corrigée :
  https://cdn.kernel.org/pub/linux/kernel/v3.x/

Noyau Linux : version 3.4.111.
La version 3.4.111 est corrigée :
  https://cdn.kernel.org/pub/linux/kernel/v3.x/

Noyau Linux : version 3.2.75.
La version 3.2.75 est corrigée :
  https://cdn.kernel.org/pub/linux/kernel/v3.x/

Noyau Linux : version 2.6.32.70.
La version 2.6.32.70 est corrigée :
  https://cdn.kernel.org/pub/linux/kernel/v2.6/longterm/v2.6.32/linux-2.6.32.70.tar.xz

Noyau Linux : patch pour inet_autobind.
Un patch est indiqué dans les sources d'information.

Debian : nouveaux paquetages linux (06/01/2016).
De nouveaux paquetages sont disponibles :
  Debian 7 : linux 3.2.73-2+deb7u2
  Debian 8 : linux 3.16.7-ckt20-1+deb8u2

Debian : nouveaux paquetages linux (18/12/2015).
De nouveaux paquetages sont disponibles :
  Debian 7 : linux 3.2.73-2+deb7u1, ctdb 1.12+git20120201-5
  Debian 8 : linux 3.16.7-ckt20-1+deb8u1, ctdb 2.5.4+debian0-4+deb8u1

Fedora 22 : nouveaux paquetages kernel.
De nouveaux paquetages sont disponibles :
  Fedora 22 : kernel 4.2.8-200.fc22

Fedora 23 : nouveaux paquetages kernel.
De nouveaux paquetages sont disponibles :
  Fedora 23 : kernel 4.2.8-300.fc23

Juniper NSM : solution pour CentOS.
La solution est indiquée dans les sources d'information.

openSUSE 11.4 : nouveaux paquetages kernel.
De nouveaux paquetages sont disponibles :
  openSUSE 11.4 : kernel 3.0.101-105.1

openSUSE 13.1 : nouveaux paquetages kernel (01/02/2016).
De nouveaux paquetages sont disponibles :
  openSUSE 13.1 : kernel 3.11.10-32.1

openSUSE 13.2 : nouveaux paquetages kernel (03/02/2016).
De nouveaux paquetages sont disponibles :
  openSUSE 13.2 : kernel 3.16.7-32.1

openSUSE Leap 42.1 : nouveaux paquetages kernel (29/01/2016).
De nouveaux paquetages sont disponibles :
  openSUSE Leap 42.1 : kernel pae-4.1.15-8.1

RHEL 6 : nouveaux paquetages kernel.
De nouveaux paquetages sont disponibles :
  RHEL 6 : kernel 2.6.32-642.el6

RHEL 7 : nouveaux paquetages kernel.
De nouveaux paquetages sont disponibles :
  RHEL 7 : kernel 3.10.0-514.el7

RHEL 7 : nouveaux paquetages kernel-rt.
De nouveaux paquetages sont disponibles :
  RHEL 7 : kernel-rt 3.10.0-514.rt56.420.el7

SUSE LE 11 : nouveaux paquetages kernel.
De nouveaux paquetages sont disponibles :
  SUSE LE 11 SP4 : kernel 3.0.101-71.2

SUSE LE 11 SP2 : nouveaux paquetages kernel (16/08/2016).
De nouveaux paquetages sont disponibles :
  SUSE LE 11 SP2 : kernel 3.0.101-0.7.40.1

SUSE LE 11 SP3 : nouveaux paquetages kernel (04/05/2016).
De nouveaux paquetages sont disponibles :
  SUSE LE 11 SP3 : kernel 3.0.101-0.47.79.1

SUSE LE 11 SP4 : nouveaux paquetages kernel-rt (20/04/2016).
De nouveaux paquetages sont disponibles :
  SUSE LE 11 SP4 : kernel-rt 3.0.101.rt130-51.1

SUSE LE 12 : nouveaux paquetages kernel.
De nouveaux paquetages sont disponibles :
  SUSE LE 12 RTM : kernel 3.12.51-52.34.1

SUSE LE 12 SP1 : nouveaux paquetages kernel (26/02/2016).
De nouveaux paquetages sont disponibles :
  SUSE LE 12 SP1 : kernel 3.12.53-60.30.1

Ubuntu 14.04 : nouveaux paquetages linux-image-3.19.0-51-generic.
De nouveaux paquetages sont disponibles :
  Ubuntu 14.04 LTS : linux-image-3.19.0-51-generic 3.19.0-51.57~14.04.1

Ubuntu : nouveaux paquetages linux-image-3.13.0-79-generic.
De nouveaux paquetages sont disponibles :
  Ubuntu 12.04 LTS : linux-image-3.13.0-79-generic 3.13.0-79.123~precise1
  Ubuntu 14.04 LTS : linux-image-3.13.0-79-generic 3.13.0-79.123

Ubuntu : nouveaux paquetages linux-image-3.16.0-60-generic.
De nouveaux paquetages sont disponibles :
  Ubuntu 14.04 LTS : linux-image-3.16.0-60-generic 3.16.0-60.80~14.04.1

Ubuntu : nouveaux paquetages linux-image-3.2.0-1476-omap4.
De nouveaux paquetages sont disponibles :
  Ubuntu 12.04 LTS : linux-image-3.2.0-1476-omap4 3.2.0-1476.99

Ubuntu : nouveaux paquetages linux-image-3.2.0-98-generic.
De nouveaux paquetages sont disponibles :
  Ubuntu 12.04 LTS : linux-image-3.2.0-98-generic 3.2.0-98.138

Ubuntu : nouveaux paquetages linux-image-4.2.0-1022-raspi2.
De nouveaux paquetages sont disponibles :
  Ubuntu 15.10 : linux-image-4.2.0-1022-raspi2 4.2.0-1022.29

Ubuntu : nouveaux paquetages linux-image-4.2.0-27-generic.
De nouveaux paquetages sont disponibles :
  Ubuntu 15.10 : linux-image-4.2.0-27-generic 4.2.0-27.32
  Ubuntu 14.04 LTS : linux-image-4.2.0-27-generic 4.2.0-27.32~14.04.1
Bulletin complet, filtrage par logiciel, emails, correctifs, ... (Demandez votre essai gratuit)

Service de veille sur les vulnérabilités informatiques 

Vigil@nce fournit une veille de vulnérabilités logicielles. La veille sécurité Vigil@nce publie des bulletins de vulnérabilités pour les failles qui impactent le système d'information.