L'équipe Vigil@nce veille les vulnérabilités publiques qui affectent votre parc informatique, puis propose des correctifs sécurité, une base de données de vigilance et des outils pour y remédier.

Vulnérabilité de Noyau Linux : déréférencement de pointeur NULL via spk_ttyio_receive_buf2

Synthèse de la vulnérabilité 

Un attaquant peut forcer le déréférencement d'un pointeur NULL via spk_ttyio_receive_buf2() du noyau Linux, afin de mener un déni de service.
Produits impactés : Linux, openSUSE Leap, SLES.
Gravité de ce bulletin : 1/4.
Date de création : 07/12/2020.
Références de cette menace : CERTFR-2021-AVI-021, CERTFR-2021-AVI-035, CVE-2020-27830, SUSE-SU-2021:0096-1, SUSE-SU-2021:0108-1, SUSE-SU-2021:0117-1, VIGILANCE-VUL-34041.

Description de la vulnérabilité 

Un attaquant peut forcer le déréférencement d'un pointeur NULL via spk_ttyio_receive_buf2() du noyau Linux, afin de mener un déni de service.
Bulletin complet, filtrage par logiciel, emails, correctifs, ... (Demandez votre essai gratuit)

Cette alerte sécurité concerne les logiciels ou systèmes comme Linux, openSUSE Leap, SLES.

Notre équipe Vigil@nce a déterminé que la gravité de ce bulletin cybersécurité est faible.

Le niveau de confiance est de type confirmé par l'éditeur, avec une provenance de shell utilisateur.

Un attaquant avec un niveau de compétence expert peut exploiter cet avis de vulnérabilité informatique.

Solutions pour cette menace 

Noyau Linux : version 5.9.14.
La version 5.9.14 est corrigée :
  https://cdn.kernel.org/pub/linux/kernel/v5.x/

Noyau Linux : version 5.4.83.
La version 5.4.83 est corrigée :
  https://cdn.kernel.org/pub/linux/kernel/v5.x/

Noyau Linux : version 4.19.163.
La version 4.19.163 est corrigée :
  https://cdn.kernel.org/pub/linux/kernel/v4.x/

Noyau Linux : version 4.14.212.
La version 4.14.212 est corrigée :
  https://cdn.kernel.org/pub/linux/kernel/v4.x/

Noyau Linux : patch pour spk_ttyio_receive_buf2.
Un patch est indiqué dans les sources d'information.

openSUSE Leap 15.2 : nouveaux paquetages kernel (15/01/2021).
De nouveaux paquetages sont disponibles :
  openSUSE Leap 15.2 : kernel 5.3.18-lp152.60.1

SUSE LE 15 SP2 : nouveaux paquetages kernel (14/01/2021).
De nouveaux paquetages sont disponibles :
  SUSE LE 15 SP2 : kernel 5.3.18-24.46.1

SUSE LE 15 SP2 : nouveaux paquetages kernel-azure.
De nouveaux paquetages sont disponibles :
  SUSE LE 15 SP2 : kernel-azure 5.3.18-18.32.1

SUSE LE 15 SP2 : nouveaux paquetages kernel-rt (13/01/2021).
De nouveaux paquetages sont disponibles :
  SUSE LE 15 SP2 : kernel-rt 5.3.18-22.1
Bulletin complet, filtrage par logiciel, emails, correctifs, ... (Demandez votre essai gratuit)

Service de veille sur les vulnérabilités informatiques 

Vigil@nce fournit une base de vulnérabilité informatique. La veille sécurité Vigil@nce publie des bulletins de vulnérabilités pour les failles qui impactent le système d'information.