L'équipe Vigil@nce veille les vulnérabilités publiques qui affectent votre parc informatique, puis propose des correctifs sécurité, une base et des outils pour y remédier.

Vulnérabilité de Noyau Linux : élévation de privilèges via Userfaultfd Sparse Tmpfs Files Write

Synthèse de la vulnérabilité

Un attaquant peut contourner les restrictions via Userfaultfd Sparse Tmpfs Files Write du noyau Linux, afin d'élever ses privilèges.
Gravité de cette alerte : 2/4.
Date création : 12/12/2018.
Références de cette alerte : 1700, CERTFR-2019-AVI-038, CERTFR-2019-AVI-042, CERTFR-2019-AVI-091, CERTFR-2019-AVI-183, CVE-2018-18397, openSUSE-SU-2019:0065-1, RHSA-2019:0163-01, RHSA-2019:0202-01, RHSA-2019:0324-01, RHSA-2019:0831-01, SUSE-SU-2019:0196-1, SUSE-SU-2019:0222-1, SUSE-SU-2019:0224-1, USN-3901-1, USN-3901-2, USN-3903-1, USN-3903-2, VIGILANCE-VUL-28013.

Description de la vulnérabilité

Un attaquant peut contourner les restrictions via Userfaultfd Sparse Tmpfs Files Write du noyau Linux, afin d'élever ses privilèges.
Bulletin Vigil@nce complet... (Essai gratuit)

Cette annonce de faille concerne les logiciels ou systèmes comme Android OS, Linux, openSUSE Leap, RHEL, SUSE Linux Enterprise Desktop, SLES, Ubuntu.

Notre équipe Vigil@nce a déterminé que la gravité de cette menace cyber-sécurité est moyen.

Le niveau de confiance est de type confirmé par l'éditeur, avec une provenance de shell utilisateur.

Un attaquant avec un niveau de compétence expert peut exploiter cette annonce de vulnérabilité informatique.

Solutions pour cette menace

Noyau Linux : version 4.19.7.
La version 4.19.7 est corrigée :
  https://cdn.kernel.org/pub/linux/kernel/v4.x/

Noyau Linux : version 4.14.87.
La version 4.14.87 est corrigée :
  https://cdn.kernel.org/pub/linux/kernel/v4.x/

Noyau Linux : patch pour Userfaultfd Sparse Tmpfs Files Write.
Un patch est indiqué dans les sources d'information.

Google Android OS : patch 2019-09-05.
Un patch 2019-09-05 est indiqué dans les sources d'information.

openSUSE Leap 15.0 : nouveaux paquetages kernel.
De nouveaux paquetages sont disponibles :
  openSUSE Leap 15.0 : kernel 4.12.14-lp150.12.45.1

RHEL 7.4 : nouveaux paquetages kernel.
De nouveaux paquetages sont disponibles :
  RHEL 7 : kernel 3.10.0-693.44.1.el7

RHEL 7.5 : nouveaux paquetages kernel.
De nouveaux paquetages sont disponibles :
  RHEL 7 : kernel 3.10.0-862.27.1.el7

RHEL 7 : nouveaux paquetages kernel.
De nouveaux paquetages sont disponibles :
  RHEL 7 : kernel 3.10.0-957.5.1.el7

RHEL 7 : nouveaux paquetages kernel-alt.
De nouveaux paquetages sont disponibles :
  RHEL 7 : kernel-alt 4.14.0-115.7.1.el7a

SUSE LE 12 SP4 : nouveaux paquetages kernel (04/02/2019).
De nouveaux paquetages sont disponibles :
  SUSE LE 12 SP4 : kernel 4.12.14-6.6.2

SUSE LE 12 SP4 : nouveaux paquetages kernel (30/01/2019).
De nouveaux paquetages sont disponibles :
  SUSE LE 12 SP4 : kernel 4.12.14-95.6.1

SUSE LE 15 : nouveaux paquetages kernel.
De nouveaux paquetages sont disponibles :
  SUSE LE 15 RTM : kernel 4.12.14-25.28.1

Ubuntu : nouveaux paquetages linux-image-4.15.0.
De nouveaux paquetages sont disponibles :
  Ubuntu 16.04 LTS : linux-image-generic-hwe-16.04 4.15.0.46.67
  Ubuntu 18.04 LTS : linux-image-generic 4.15.0.46.48

Ubuntu : nouveaux paquetages linux-image-4.18.0.
De nouveaux paquetages sont disponibles :
  Ubuntu 18.04 LTS : linux-image-generic-hwe-18.04 4.18.0.16.66
  Ubuntu 18.10 : linux-image-generic 4.18.0.16.17
Bulletin Vigil@nce complet... (Essai gratuit)

Service de veille sur les vulnérabilités informatiques

Vigil@nce fournit une base cyber-sécurité. La base de vulnérabilités Vigil@nce contient plusieurs milliers de failles.