L'équipe Vigil@nce veille les vulnérabilités publiques qui affectent votre parc informatique, puis propose des correctifs sécurité, une base et des outils pour y remédier.

annonce de vulnérabilité CVE-2016-2069

Noyau Linux : élévation de privilèges via la synchronisation des TLB entre processeurs

Synthèse de la vulnérabilité

Un attaquant peut provoquer une erreur de synchronisation des TLB par le noyau Linux, afin d'élever ses privilèges.
Produits concernés : Debian, Linux, openSUSE, openSUSE Leap, SUSE Linux Enterprise Desktop, SLES, Ubuntu.
Gravité : 1/4.
Date création : 25/01/2016.
Références : CERTFR-2016-AVI-069, CERTFR-2016-AVI-070, CERTFR-2016-AVI-073, CERTFR-2016-AVI-082, CERTFR-2016-AVI-099, CERTFR-2016-AVI-103, CERTFR-2016-AVI-110, CERTFR-2016-AVI-159, CERTFR-2016-AVI-186, CERTFR-2016-AVI-199, CVE-2016-2069, DSA-3503-1, openSUSE-SU-2016:0537-1, openSUSE-SU-2016:1008-1, SUSE-SU-2016:0585-1, SUSE-SU-2016:0785-1, SUSE-SU-2016:0911-1, SUSE-SU-2016:1102-1, SUSE-SU-2016:1203-1, USN-2908-1, USN-2908-2, USN-2908-3, USN-2908-4, USN-2908-5, USN-2931-1, USN-2932-1, USN-2967-1, USN-2967-2, USN-2989-1, USN-2998-1, VIGILANCE-VUL-18812.

Description de la vulnérabilité

Les processeurs x86 gèrent un cache de la table des pages, structure qui doit être partagée par tous les processeurs.

Le noyau Linux utilise un protocole particulier pour propager les changements de la table des pages d'un processus donné entre tous les processeurs du système. Cependant, ce protocole est vulnérable a certaines anomalies d'entrelacement qui font qu'il existe peut-être une séquence d'instructions et d'interruptions matérielles qui donnent accès à un processus utilisateur à une zone mémoire qui devrait être inaccessible.

Un attaquant peut donc provoquer une erreur de synchronisation des TLB par le noyau Linux, afin d'élever ses privilèges.
Bulletin Vigil@nce complet.... (Essai gratuit)

Service de veille sur les vulnérabilités informatiques

Vigil@nce fournit des alertes de vulnérabilités logicielles. L'équipe Vigil@nce surveille les vulnérabilités informatiques de systèmes et d'applications. Chaque administrateur peut personnaliser la liste des produits pour lesquels il souhaite recevoir des alertes de vulnérabilités. Le service de veille sur les vulnérabilités informatiques Vigil@nce alerte vos équipes des failles et des menaces qui concernent votre système d'information.