L'équipe Vigil@nce veille les vulnérabilités publiques qui affectent votre parc informatique, puis propose des correctifs sécurité, une base de données de vigilance et des outils pour y remédier.

Vulnérabilité de Noyau Linux : élévation de privilèges via ptrace_link

Synthèse de la vulnérabilité 

Un attaquant peut contourner les restrictions via ptrace_link du noyau Linux, afin d'élever ses privilèges.
Produits vulnérables : Debian, Fedora, Tivoli Storage Manager, Linux, RHEL, SIMATIC, Slackware, SUSE Linux Enterprise Desktop, SLES, Ubuntu.
Gravité de cette faille : 2/4.
Date création : 18/07/2019.
Références de ce bulletin : CERTFR-2019-AVI-375, CERTFR-2019-AVI-391, CERTFR-2019-AVI-419, CERTFR-2019-AVI-451, CERTFR-2019-AVI-561, CERTFR-2019-AVI-575, CVE-2019-13272, DLA-1862-1, DLA-1863-1, DSA-4484-1, FEDORA-2019-a95015e60f, PROJ-ZERO-1903, RHSA-2019:2405-01, RHSA-2019:2411-01, RHSA-2019:2809-01, SSA:2019-202-01, SSB-439005, SUSE-SU-2019:2949-1, SUSE-SU-2019:2984-1, USN-4093-1, USN-4094-1, USN-4095-1, USN-4095-2, USN-4117-1, USN-4118-1, VIGILANCE-VUL-29820.

Description de la vulnérabilité 

Un attaquant peut contourner les restrictions via ptrace_link du noyau Linux, afin d'élever ses privilèges.
Bulletin complet, filtrage par logiciel, emails, correctifs, ... (Demandez votre essai gratuit)

Cette faille informatique concerne les logiciels ou systèmes comme Debian, Fedora, Tivoli Storage Manager, Linux, RHEL, SIMATIC, Slackware, SUSE Linux Enterprise Desktop, SLES, Ubuntu.

Notre équipe Vigil@nce a déterminé que la gravité de cette annonce de vulnérabilité est moyen.

Le niveau de confiance est de type confirmé par l'éditeur, avec une provenance de shell utilisateur.

Un démonstrateur ou un outil d'attaque est disponible, donc vos équipes doivent traiter cette alerte. Un attaquant avec un niveau de compétence spécialiste peut exploiter cet avis de faille informatique.

Solutions pour cette menace 

Noyau Linux : version 5.1.17.
La version 5.1.17 est corrigée :
  https://cdn.kernel.org/pub/linux/kernel/v5.x/

Noyau Linux : version 4.19.59.
La version 4.19.59 est corrigée :
  https://cdn.kernel.org/pub/linux/kernel/v4.x/

Noyau Linux : version 4.14.133.
La version 4.14.133 est corrigée :
  https://cdn.kernel.org/pub/linux/kernel/v4.x/

Noyau Linux : version 4.9.185.
La version 4.9.185 est corrigée :
  https://cdn.kernel.org/pub/linux/kernel/v4.x/

Noyau Linux : version 4.4.185.
La version 4.4.185 est corrigée :
  https://cdn.kernel.org/pub/linux/kernel/v4.x/

Noyau Linux : version 3.16.71.
La version 3.16.71 est corrigée :
  https://cdn.kernel.org/pub/linux/kernel/v3.x/

Noyau Linux : patch pour ptrace_link.
Un patch est indiqué dans les sources d'information.

Debian 8 : nouveaux paquetages linux.
De nouveaux paquetages sont disponibles :
  Debian 8 : linux 3.16.70-1

Debian 8 : nouveaux paquetages linux-4.9.
De nouveaux paquetages sont disponibles :
  Debian 8 : linux-4.9 4.9.168-1+deb9u4~deb8u1

Debian 9/10 : nouveaux paquetages linux.
De nouveaux paquetages sont disponibles :
  Debian 9 : linux 4.9.168-1+deb9u4
  Debian 10 : linux 4.19.37-5+deb10u1

Fedora 29 : nouveaux paquetages kernel.
De nouveaux paquetages sont disponibles :
  Fedora 29 : kernel 5.1.18-200.fc29

Fedora 29 : nouveaux paquetages kernel-headers.
De nouveaux paquetages sont disponibles :
  Fedora 29 : kernel-headers 5.1.18-200.fc29

IBM Spectrum Protect Plus : version 10.1.4.222.
La version 10.1.4.222 est corrigée :
  http://www.ibm.com/support/docview.wss?uid=ibm10880861

RHEL 7 : nouveaux paquetages kernel-alt.
De nouveaux paquetages sont disponibles :
  RHEL 7 : kernel-alt 4.14.0-115.12.1.el7a

RHEL 8.0 : nouveaux paquetages kernel.
De nouveaux paquetages sont disponibles :
  RHEL 8 : kernel 4.18.0-80.7.2.el8_0

RHEL 8.0 : nouveaux paquetages kernel-rt.
De nouveaux paquetages sont disponibles :
  RHEL 8 : kernel-rt 4.18.0-80.7.2.rt9.154.el8_0

SIMATIC S7-1500 CPU 1518 : contre-mesure pour GNU/Linux Vulnerabilities.
Une contre-mesure est indiquée dans la source d'information.

Slackware 14.2 : nouveaux paquetages kernel.
De nouveaux paquetages sont disponibles :
  Slackware 14.2 : linux 4.4.186

SUSE LE 12 SP2 : nouveaux paquetages kernel.
De nouveaux paquetages sont disponibles :
  SUSE LE 12 SP2 : kernel 4.4.121-92.125.1

SUSE LE 12 SP3 : nouveaux paquetages kernel (13/11/2019).
De nouveaux paquetages sont disponibles :
  SUSE LE 12 SP3 : kernel 4.4.180-94.107.1

Ubuntu 16/18 : nouveaux paquetages linux-image-aws.
De nouveaux paquetages sont disponibles :
  Ubuntu 16.04 LTS : linux-image-aws 4.15.0.1047.47
  Ubuntu 18.04 LTS : linux-image-aws 4.15.0.1047.46

Ubuntu 19.04 : nouveaux paquetages linux-image-aws.
De nouveaux paquetages sont disponibles :
  Ubuntu 19.04 : linux-image-aws 5.0.0.1014.15

Ubuntu : nouveaux paquetages linux-image-4.15.0.
De nouveaux paquetages sont disponibles :
  Ubuntu 16.04 LTS : linux-image-generic-hwe-16.04 4.15.0.58.79
  Ubuntu 18.04 LTS : linux-image-generic 4.15.0.58.60

Ubuntu : nouveaux paquetages linux-image-4.4.0.
De nouveaux paquetages sont disponibles :
  Ubuntu 14.04 ESM : linux-image-generic-lts-xenial 4.4.0.159.140
  Ubuntu 16.04 LTS : linux-image-generic 4.4.0.159.167

Ubuntu : nouveaux paquetages linux-image-5.0.0.
De nouveaux paquetages sont disponibles :
  Ubuntu 18.04 LTS : linux-image-generic-hwe-18.04 5.0.0.25.82
  Ubuntu 19.04 : linux-image-generic 5.0.0.25.26
Bulletin complet, filtrage par logiciel, emails, correctifs, ... (Demandez votre essai gratuit)

Service de veille sur les vulnérabilités informatiques 

Vigil@nce fournit une annonce de vulnérabilités applicatives. Le service de veille sur les vulnérabilités informatiques Vigil@nce alerte vos équipes des failles et des menaces qui concernent votre système d'information.