L'équipe Vigil@nce veille les vulnérabilités publiques qui affectent votre parc informatique, puis propose des correctifs sécurité, une base de données de vigilance et des outils pour y remédier.

Vulnérabilité de Noyau Linux : fuite mémoire via video_usercopy

Synthèse de la vulnérabilité 

Un attaquant peut provoquer une fuite mémoire via video_usercopy() du noyau Linux, afin de mener un déni de service.
Systèmes impactés : Linux, openSUSE Leap, SUSE Linux Enterprise Desktop, SLES, Ubuntu.
Gravité de cette alerte : 1/4.
Date de création : 06/04/2021.
Références de cette alerte : CERTFR-2021-AVI-278, CERTFR-2021-AVI-284, CERTFR-2021-AVI-302, CERTFR-2021-AVI-372, CERTFR-2021-AVI-387, CERTFR-2021-AVI-392, CERTFR-2021-AVI-393, CERTFR-2021-AVI-436, CERTFR-2021-AVI-469, CVE-2021-30002, openSUSE-SU-2021:0579-1, openSUSE-SU-2021:0758-1, SUSE-SU-2021:1210-1, SUSE-SU-2021:1211-1, SUSE-SU-2021:1238-1, SUSE-SU-2021:1248-1, SUSE-SU-2021:1266-1, SUSE-SU-2021:1301-1, SUSE-SU-2021:14724-1, SUSE-SU-2021:1573-1, SUSE-SU-2021:1596-1, SUSE-SU-2021:1617-1, SUSE-SU-2021:1623-1, SUSE-SU-2021:1624-1, SUSE-SU-2021:1975-1, SUSE-SU-2021:1977-1, USN-4945-1, USN-4945-2, USN-4946-1, USN-4947-1, USN-4984-1, VIGILANCE-VUL-35009.

Description de la vulnérabilité 

Un attaquant peut provoquer une fuite mémoire via video_usercopy() du noyau Linux, afin de mener un déni de service.
Bulletin complet, filtrage par logiciel, emails, correctifs, ... (Demandez votre essai gratuit)

Cette annonce cyber-sécurité concerne les logiciels ou systèmes comme Linux, openSUSE Leap, SUSE Linux Enterprise Desktop, SLES, Ubuntu.

Notre équipe Vigil@nce a déterminé que la gravité de ce bulletin de faille est faible.

Le niveau de confiance est de type confirmé par l'éditeur, avec une provenance de shell utilisateur.

Un attaquant avec un niveau de compétence expert peut exploiter cette annonce de vulnérabilité.

Solutions pour cette menace 

Noyau Linux : version 5.11.3.
La version 5.11.3 est corrigée :
  https://cdn.kernel.org/pub/linux/kernel/v5.x/

Noyau Linux : version 5.10.21.
La version 5.10.21 est corrigée :
  https://cdn.kernel.org/pub/linux/kernel/v5.x/

Noyau Linux : version 5.4.103.
La version 5.4.103 est corrigée :
  https://cdn.kernel.org/pub/linux/kernel/v5.x/

Noyau Linux : version 4.19.179.
La version 4.19.179 est corrigée :
  https://cdn.kernel.org/pub/linux/kernel/v4.x/

Noyau Linux : version 4.14.224.
La version 4.14.224 est corrigée :
  https://cdn.kernel.org/pub/linux/kernel/v4.x/

Noyau Linux : version 4.9.260.
La version 4.9.260 est corrigée :
  https://cdn.kernel.org/pub/linux/kernel/v4.x/

Noyau Linux : version 4.4.260.
La version 4.4.260 est corrigée :
  https://cdn.kernel.org/pub/linux/kernel/v4.x/

Noyau Linux : patch pour video_usercopy.
Un patch est indiqué dans les sources d'information.

openSUSE Leap 15.2 : nouveaux paquetages kernel.
De nouveaux paquetages sont disponibles :
  openSUSE Leap 15.2 : kernel 5.3.18-lp152.72.1

openSUSE Leap 15.2 : nouveaux paquetages kernel-rt.
De nouveaux paquetages sont disponibles :
  openSUSE Leap 15.2 : kernel-rt 5.3.18-lp152.3.8.1

SUSE LE 11 SP4 : nouveaux paquetages kernel.
De nouveaux paquetages sont disponibles :
  SUSE LE 11 SP4 : kernel 3.0.101-108.126.1

SUSE LE 12 SP2 : nouveaux paquetages kernel.
De nouveaux paquetages sont disponibles :
  SUSE LE 12 SP2 : kernel 4.4.121-92.155.1

SUSE LE 12 SP3 : nouveaux paquetages kernel.
De nouveaux paquetages sont disponibles :
  SUSE LE 12 SP3 : kernel 4.4.180-94.144.1

SUSE LE 12 SP4 : nouveaux paquetages kernel.
De nouveaux paquetages sont disponibles :
  SUSE LE 12 SP4 : kernel 4.12.14-95.74.1

SUSE LE 12 SP5 : nouveaux paquetages kernel (16/04/2021).
De nouveaux paquetages sont disponibles :
  SUSE LE 12 SP5 : kernel 4.12.14-122.66.2

SUSE LE 12 SP5 : nouveaux paquetages kernel-azure.
De nouveaux paquetages sont disponibles :
  SUSE LE 12 SP5 : kernel-azure 4.12.14-16.53.1

SUSE LE 12 SP5 : nouveaux paquetages kernel-rt.
De nouveaux paquetages sont disponibles :
  SUSE LE 12 SP5 : kernel-rt 4.12.14-10.40.1

SUSE LE 15 RTM : nouveaux paquetages kernel.
De nouveaux paquetages sont disponibles :
  SUSE LE 15 RTM : kernel 4.12.14-150.72.1

SUSE LE 15 SP1 : nouveaux paquetages kernel (18/05/2021).
De nouveaux paquetages sont disponibles :
  SUSE LE 15 SP1 : kernel 4.12.14-197.89.2

SUSE LE 15 SP2 : nouveaux paquetages kernel.
De nouveaux paquetages sont disponibles :
  SUSE LE 15 SP2 : kernel 5.3.18-24.61.1

SUSE LE 15 SP2 : nouveaux paquetages kernel-azure.
De nouveaux paquetages sont disponibles :
  SUSE LE 15 SP2 : kernel-azure 5.3.18-18.44.1

SUSE LE 15 SP2 : nouveaux paquetages kernel-rt.
De nouveaux paquetages sont disponibles :
  SUSE LE 15 SP2 : kernel-rt 5.3.18-33.1

SUSE LE 15 SP3 : nouveaux paquetages kernel.
De nouveaux paquetages sont disponibles :
  SUSE LE 15 SP3 : kernel 5.3.18-59.5.2

SUSE LE 15 SP3 : nouveaux paquetages kernel-azure.
De nouveaux paquetages sont disponibles :
  SUSE LE 15 SP3 : kernel-azure 5.3.18-38.3.1

Ubuntu : nouveaux paquetages linux-image-4.15.0.
De nouveaux paquetages sont disponibles, comme indiqué dans les sources d'informations.

Ubuntu : nouveaux paquetages linux-image-5.4.0.
De nouveaux paquetages sont disponibles, comme indiqué dans les sources d'informations.

Ubuntu : nouveaux paquetages linux-image-5.6.0.
De nouveaux paquetages sont disponibles :
  Ubuntu 20.04 LTS : linux-image-5.6.0-1056-oem 5.6.0-1056.60, linux-image-oem-20.04 5.6.0.1056.52

Ubuntu : nouveaux paquetages linux-image-5.8.0.
De nouveaux paquetages sont disponibles :
  Ubuntu 20.10 : linux-image-generic 5.8.0.55.60
  Ubuntu 20.04 LTS : linux-image-generic-hwe-20.04 5.8.0.55.62~20.04.39

Ubuntu : nouveaux paquetages linux-image-raspi.
De nouveaux paquetages sont disponibles :
  Ubuntu 20.04 LTS : linux-image-raspi 5.4.0.1035.70
  Ubuntu 18.04 LTS : linux-image-raspi-hwe-18.04 5.4.0.1035.37
Bulletin complet, filtrage par logiciel, emails, correctifs, ... (Demandez votre essai gratuit)

Service de veille sur les vulnérabilités informatiques 

Vigil@nce fournit une base de vulnérabilité de réseau. La veille sécurité Vigil@nce publie des bulletins de vulnérabilités pour les failles qui impactent le système d'information.