L'équipe Vigil@nce veille les vulnérabilités publiques qui affectent votre parc informatique, puis propose des correctifs sécurité, une base de données et des outils pour y remédier.

Vulnérabilité de Noyau Linux : obtention d'information via drivers/net/can/usb/peak_usb/pcan_usb_pro.c

Synthèse de la vulnérabilité

Un attaquant local peut lire un fragment de la mémoire via drivers/net/can/usb/peak_usb/pcan_usb_pro.c du noyau Linux, afin d'obtenir des informations sensibles.
Gravité de cette alerte : 1/4.
Date création : 04/12/2019.
Références de cette alerte : CERTFR-2019-AVI-639, CERTFR-2019-AVI-652, CERTFR-2019-AVI-655, CERTFR-2020-AVI-029, CVE-2019-19536, DLA-2068-1, openSUSE-SU-2019:2675-1, SUSE-SU-2019:3289-1, SUSE-SU-2019:3316-1, SUSE-SU-2019:3317-1, SUSE-SU-2019:3372-1, SUSE-SU-2019:3379-1, SUSE-SU-2019:3381-1, SUSE-SU-2019:3389-1, SUSE-SU-2020:0093-1, VIGILANCE-VUL-31055.

Description de la vulnérabilité

Un attaquant local peut lire un fragment de la mémoire via drivers/net/can/usb/peak_usb/pcan_usb_pro.c du noyau Linux, afin d'obtenir des informations sensibles.
Bulletin complet, filtrage par logiciel, emails, correctifs, ... (Demandez votre essai gratuit)

Ce bulletin cybersécurité concerne les logiciels ou systèmes comme Debian, Linux, openSUSE Leap, SUSE Linux Enterprise Desktop, SLES.

Notre équipe Vigil@nce a déterminé que la gravité de ce bulletin sécurité est faible.

Le niveau de confiance est de type confirmé par l'éditeur, avec une provenance de shell utilisateur.

Un attaquant avec un niveau de compétence expert peut exploiter cette menace informatique.

Solutions pour cette menace

Noyau Linux : version 5.2.9.
La version 5.2.9 est corrigée :
  https://cdn.kernel.org/pub/linux/kernel/v5.x/

Noyau Linux : version 4.19.67.
La version 4.19.67 est corrigée :
  https://cdn.kernel.org/pub/linux/kernel/v4.x/

Noyau Linux : version 4.14.139.
La version 4.14.139 est corrigée :
  https://cdn.kernel.org/pub/linux/kernel/v4.x/

Noyau Linux : patch pour drivers/net/can/usb/peak_usb/pcan_usb_pro.c.
Un patch est indiqué dans les sources d'information.

Debian 8 : nouveaux paquetages linux.
De nouveaux paquetages sont disponibles :
  Debian 8 : linux 3.16.81-1

openSUSE Leap 15.1 : nouveaux paquetages kernel.
De nouveaux paquetages sont disponibles :
  openSUSE Leap 15.1 : kernel 4.12.14-lp151.28.36.1

SUSE LE 12 SP3 : nouveaux paquetages kernel (23/12/2019).
De nouveaux paquetages sont disponibles :
  SUSE LE 12 SP3 : kernel 4.4.180-94.113.1

SUSE LE 12 SP4 : nouveaux paquetages kernel-azure (18/12/2019).
De nouveaux paquetages sont disponibles :
  SUSE LE 12 SP4 : kernel-azure 4.12.14-6.34.1

SUSE LE 12 SP5 : nouveaux paquetages kernel (30/12/2019).
De nouveaux paquetages sont disponibles :
  SUSE LE 12 SP5 : kernel 4.12.14-122.12.1

SUSE LE 12 SP5 : nouveaux paquetages kernel-azure.
De nouveaux paquetages sont disponibles :
  SUSE LE 12 SP5 : kernel-azure 4.12.14-16.7.1

SUSE LE 15 RTM : nouveaux paquetages kernel (23/12/2019).
De nouveaux paquetages sont disponibles :
  SUSE LE 15 RTM : kernel 4.12.14-150.47.1

SUSE LE 15 RTM : nouveaux paquetages kernel-azure (13/12/2019).
De nouveaux paquetages sont disponibles :
  SUSE LE 15 RTM : kernel-azure 4.12.14-5.47.1

SUSE LE 15 SP1 : nouveaux paquetages kernel (18/12/2019).
De nouveaux paquetages sont disponibles :
  SUSE LE 15 SP1 : kernel 4.12.14-197.29.1

SUSE LE 15 SP1 : nouveaux paquetages kernel-azure (20/12/2019).
De nouveaux paquetages sont disponibles :
  SUSE LE 15 SP1 : kernel-azure 4.12.14-8.22.1
Bulletin complet, filtrage par logiciel, emails, correctifs, ... (Demandez votre essai gratuit)

Service de veille sur les vulnérabilités informatiques

Vigil@nce fournit des annonces de vulnérabilités applicatives. La veille sécurité Vigil@nce publie des bulletins de vulnérabilités pour les failles qui impactent le système d'information.