L'équipe Vigil@nce veille les vulnérabilités publiques qui affectent votre parc informatique, puis propose des correctifs sécurité, une base de données et des outils pour y remédier.

Vulnérabilité de Noyau Linux : obtention d'information via mremap

Synthèse de la vulnérabilité

Un attaquant peut contourner les restrictions d'accès aux données via mremap() du noyau Linux, afin d'obtenir des informations sensibles.
Gravité de cette menace : 2/4.
Date création : 29/10/2018.
Références de cette faille : 1103505, 1695, 1798863, CERTFR-2018-AVI-541, CERTFR-2018-AVI-581, CERTFR-2018-AVI-583, CERTFR-2019-AVI-019, CERTFR-2019-AVI-035, CERTFR-2019-AVI-038, CERTFR-2019-AVI-041, CERTFR-2019-AVI-042, CERTFR-2019-AVI-044, CERTFR-2019-AVI-071, CERTFR-2019-AVI-183, CERTFR-2019-AVI-233, CERTFR-2020-AVI-007, CERTFR-2020-AVI-030, CVE-2018-18281, DLA-1715-1, DLA-1731-1, DLA-1731-2, openSUSE-SU-2018:3817-1, openSUSE-SU-2018:4133-1, RHSA-2019:0831-01, RHSA-2019:2029-01, RHSA-2019:2043-01, RHSA-2020:0036-01, RHSA-2020:0100-01, RHSA-2020:0103-01, SSA:2019-030-01, SUSE-SU-2018:3689-1, SUSE-SU-2018:3746-1, SUSE-SU-2018:3773-1, SUSE-SU-2018:4069-1, SUSE-SU-2019:0095-1, SUSE-SU-2019:0222-1, SUSE-SU-2019:0224-1, SUSE-SU-2019:0439-1, SUSE-SU-2019:1289-1, SUSE-SU-2019:13937-1, USN-3832-1, USN-3835-1, USN-3871-1, USN-3871-2, USN-3871-3, USN-3871-4, USN-3871-5, USN-3880-1, USN-3880-2, VIGILANCE-VUL-27638.

Description de la vulnérabilité

Un attaquant peut contourner les restrictions d'accès aux données via mremap() du noyau Linux, afin d'obtenir des informations sensibles.
Bulletin Vigil@nce complet... (Demandez votre essai gratuit)

Cette menace cybersécurité concerne les logiciels ou systèmes comme Debian, Android OS, QRadar SIEM, Linux, openSUSE Leap, RHEL, Slackware, SUSE Linux Enterprise Desktop, SLES, Ubuntu.

Notre équipe Vigil@nce a déterminé que la gravité de ce bulletin de menace informatique est moyen.

Le niveau de confiance est de type confirmé par l'éditeur, avec une provenance de shell utilisateur.

Un démonstrateur ou un outil d'attaque est disponible, donc vos équipes doivent traiter cette alerte. Un attaquant avec un niveau de compétence technicien peut exploiter cette vulnérabilité cybersécurité.

Solutions pour cette menace

Noyau Linux : version 4.18.16.
La version 4.18.16 est corrigée :
  https://cdn.kernel.org/pub/linux/kernel/v4.x/

Noyau Linux : version 4.14.78.
La version 4.14.78 est corrigée :
  https://cdn.kernel.org/pub/linux/kernel/v4.x/

Noyau Linux : version 4.9.135.
La version 4.9.135 est corrigée :
  https://cdn.kernel.org/pub/linux/kernel/v4.x/

Noyau Linux : version 4.4.163.
La version 4.4.163 est corrigée :
  https://cdn.kernel.org/pub/linux/kernel/v4.x/

Noyau Linux : version 3.18.125.
La version 3.18.125 est corrigée :
  https://cdn.kernel.org/pub/linux/kernel/v3.x/

Noyau Linux : version 3.16.62.
La version 3.16.62 est corrigée :
  https://cdn.kernel.org/pub/linux/kernel/v3.x/

Noyau Linux : patch pour mremap.
Un patch est indiqué dans les sources d'information.

Debian 8 : nouveaux paquetages linux (27/03/2019).
De nouveaux paquetages sont disponibles :
  Debian 8 : linux 3.16.64-2

Debian 8 : nouveaux paquetages linux-4.9.
De nouveaux paquetages sont disponibles :
  Debian 8 : linux-4.9 4.9.144-3.1~deb8u1

Google Android/Pixel : patch pour janvier 2019.
Un patch est indiqué dans les sources d'information.

IBM QRadar SIEM : patch pour Kernel.
Un patch est indiqué dans les sources d'information.

openSUSE Leap 15.0 : nouveaux paquetages kernel.
De nouveaux paquetages sont disponibles :
  openSUSE Leap 15.0 : kernel 4.12.14-lp150.12.28.1

openSUSE Leap 42.3 : nouveaux paquetages kernel.
De nouveaux paquetages sont disponibles :
  openSUSE Leap 42.3 : kernel 4.4.162-78.1

RHEL 6 MRG : nouveaux paquetages kernel-rt.
De nouveaux paquetages sont disponibles :
  RHEL 6.0-6.10 : kernel-rt 3.10.0-693.62.1.rt56.659.el6rt

RHEL 7.4 : nouveaux paquetages kernel.
De nouveaux paquetages sont disponibles :
  RHEL 7.4 : kernel 3.10.0-693.62.1.el7

RHEL 7.5 : nouveaux paquetages kernel.
De nouveaux paquetages sont disponibles :
  RHEL 7.0-7.7 : kernel 3.10.0-862.46.1.el7

RHEL 7 : nouveaux paquetages kernel.
De nouveaux paquetages sont disponibles :
  RHEL 7 : kernel 3.10.0-1062.el7

RHEL 7 : nouveaux paquetages kernel-alt.
De nouveaux paquetages sont disponibles :
  RHEL 7 : kernel-alt 4.14.0-115.7.1.el7a

RHEL 7 : nouveaux paquetages kernel-rt.
De nouveaux paquetages sont disponibles :
  RHEL 7 : kernel-rt 3.10.0-1062.rt56.1022.el7

Slackware : nouveaux paquetages kernel.
De nouveaux paquetages sont disponibles :
  Slackware 14.2 : kernel 4.4.172-i586-1

SUSE LE 11 SP3 : nouveaux paquetages kernel.
De nouveaux paquetages sont disponibles :
  SUSE LE 11 SP3 : kernel 3.0.101-0.47.106.59.1

SUSE LE 11 SP4 : nouveaux paquetages kernel.
De nouveaux paquetages sont disponibles :
  SUSE LE 11 SP4 : kernel 3.0.101-108.81.1

SUSE LE 12 SP1 : nouveaux paquetages kernel.
De nouveaux paquetages sont disponibles :
  SUSE LE 12 SP1 : kernel 3.12.74-60.64.110.1

SUSE LE 12 SP2 : nouveaux paquetages kernel.
De nouveaux paquetages sont disponibles :
  SUSE LE 12 SP2 : kernel 4.4.121-92.101.1

SUSE LE 12 SP3 : nouveaux paquetages kernel.
De nouveaux paquetages sont disponibles :
  SUSE LE 12 SP3 : kernel 4.4.162-94.69.2

SUSE LE 12 SP3 : nouveaux paquetages kernel-azure.
De nouveaux paquetages sont disponibles :
  SUSE LE 12 SP3 : kernel-azure 4.4.162-4.19.2

SUSE LE 12 SP3 : nouveaux paquetages kernel-rt (16/11/2018).
De nouveaux paquetages sont disponibles :
  SUSE LE 12 SP3 : kernel-rt 4.4.162-3.29.1

SUSE LE 12 SP4 : nouveaux paquetages kernel (04/02/2019).
De nouveaux paquetages sont disponibles :
  SUSE LE 12 SP4 : kernel 4.12.14-6.6.2

SUSE LE 12 SP4 : nouveaux paquetages kernel (11/12/2018).
De nouveaux paquetages sont disponibles :
  SUSE LE 12 SP4 : kernel 4.12.14-95.3.1

SUSE LE 15 : nouveaux paquetages kernel.
De nouveaux paquetages sont disponibles :
  SUSE LE 15 RTM : kernel 4.12.14-25.28.1

Ubuntu 18.04 : nouveaux paquetages linux-image-4.15.0.
De nouveaux paquetages sont disponibles :
  Ubuntu 16.04 LTS : linux-image-generic-hwe-16.04 4.15.0.45.66
  Ubuntu 18.04 LTS : linux-image-generic 4.15.0-45.48

Ubuntu 18.10 : nouveaux paquetages linux-image-4.18.0.
De nouveaux paquetages sont disponibles :
  Ubuntu 18.10 : linux-image-generic 4.18.0.12.13

Ubuntu 18.10 : nouveaux paquetages linux-image-aws.
De nouveaux paquetages sont disponibles :
  Ubuntu 18.10 : linux-image-aws 4.18.0.1006.6

Ubuntu : nouveaux paquetages linux-image-3.13.0.
De nouveaux paquetages sont disponibles :
  Ubuntu 12.04 ESM : linux-image-generic-lts-trusty 3.13.0.165.155
  Ubuntu 14.04 LTS : linux-image-generic 3.13.0.165.175

Wind River Linux : solution (28/11/2018).
La solution est indiquée dans les sources d'information.
Bulletin Vigil@nce complet... (Demandez votre essai gratuit)

Service de veille sur les vulnérabilités informatiques

Vigil@nce fournit une base de vulnérabilités informatiques. Chaque administrateur peut personnaliser la liste des produits pour lesquels il souhaite recevoir des alertes de vulnérabilités.