L'équipe Vigil@nce veille les vulnérabilités publiques qui affectent votre parc informatique, puis propose des correctifs sécurité, une base de données de vigilance et des outils pour y remédier.

Vulnérabilité de Noyau Linux : quatre vulnérabilités de ozwpan

Synthèse de la vulnérabilité 

Un attaquant peut employer plusieurs vulnérabilités de ozwpan du noyau Linux.
Produits impactés : Fedora, Linux, openSUSE, Ubuntu.
Gravité de ce bulletin : 2/4.
Nombre de vulnérabilités dans ce bulletin : 4.
Date de création : 18/05/2015.
Références de cette menace : CERTFR-2015-AVI-269, CERTFR-2015-AVI-283, CERTFR-2015-AVI-357, CERTFR-2016-AVI-186, CERTFR-2016-AVI-199, CVE-2015-4001, CVE-2015-4002, CVE-2015-4003, CVE-2015-4004, FEDORA-2015-10677, FEDORA-2015-10678, openSUSE-SU-2015:1382-1, openSUSE-SU-2016:0301-1, USN-2662-1, USN-2663-1, USN-2664-1, USN-2665-1, USN-2666-1, USN-2667-1, USN-2989-1, USN-2998-1, USN-3000-1, USN-3001-1, USN-3002-1, USN-3003-1, USN-3004-1, VIGILANCE-VUL-16911.

Description de la vulnérabilité 

Plusieurs vulnérabilités ont été annoncées dans le noyau Linux.

Un attaquant peut provoquer un débordement d'entier dans oz_hcd_get_desc_cnf, afin de mener un déni de service, et éventuellement d'exécuter du code. [grav:2/4; CVE-2015-4001]

Un attaquant peut provoquer un buffer overflow dans oz_usb_handle_ep_data, afin de mener un déni de service, et éventuellement d'exécuter du code. [grav:2/4; CVE-2015-4002]

Un attaquant peut provoquer une division par zéro dans oz_usb_handle_ep_data(), afin de mener un déni de service. [grav:2/4; CVE-2015-4003]

Un attaquant peut envoyer des paquets anormalement courts afin de recevoir des données provenant de la mémoire non initialisée. [grav:2/4; CVE-2015-4004]
Bulletin complet, filtrage par logiciel, emails, correctifs, ... (Demandez votre essai gratuit)

Cette vulnérabilité cyber-sécurité concerne les logiciels ou systèmes comme Fedora, Linux, openSUSE, Ubuntu.

Notre équipe Vigil@nce a déterminé que la gravité de cette annonce de menace est moyen.

Le niveau de confiance est de type confirmé par l'éditeur, avec une provenance de liaison radio.

Ce bulletin concerne 4 vulnérabilités.

Un démonstrateur ou un outil d'attaque est disponible, donc vos équipes doivent traiter cette alerte. Un attaquant avec un niveau de compétence débutant peut exploiter cet avis de menace.

Solutions pour cette menace 

Noyau Linux : version 4.0.6.
La version 4.0.6 est corrigée :
  https://www.kernel.org/pub/linux/kernel/v4.x/linux-4.0.6.tar.xz

Noyau Linux : version 3.14.45.
La version 3.14.45 est corrigée :
  https://www.kernel.org/pub/linux/kernel/v3.x/linux-3.14.45.tar.xz

Noyau Linux : version 3.12.45.
La version 3.12.45 est corrigée :
  https://www.kernel.org/pub/linux/kernel/v3.x/

Noyau Linux : version 3.10.81.
La version 3.10.81 est corrigée :
  https://www.kernel.org/pub/linux/kernel/v3.x/linux-3.10.81.tar.xz

Noyau Linux : version 3.4.109.
La version 3.4.109 est corrigée :
  https://www.kernel.org/pub/linux/kernel/v3.x/

Noyau Linux : patch pour ozwpan.
Un patch est disponible dans les sources d'information.

Fedora : nouveaux paquetages kernel.
De nouveaux paquetages sont disponibles :
  Fedora 22 : kernel 4.0.6-300.fc22
  Fedora 21 : kernel 4.0.6-200.fc21

openSUSE 13.1 : nouveaux paquetages kernel (01/02/2016).
De nouveaux paquetages sont disponibles :
  openSUSE 13.1 : kernel 3.11.10-32.1

openSUSE 13.2 : nouveaux paquetages kernel (14/08/2015).
De nouveaux paquetages sont disponibles :
  openSUSE 13.2 : kernel 3.16.7-24.1

Ubuntu 12.04 LTS : nouveaux paquetages linux-image-3.13.0-88-generic.
De nouveaux paquetages sont disponibles :
  Ubuntu 12.04 LTS : linux-image-3.13.0-88-generic 3.13.0-88.135~precise1

Ubuntu 14.04 LTS : nouveaux paquetages linux-image-3.16.0-73-generic.
De nouveaux paquetages sont disponibles :
  Ubuntu 14.04 LTS : linux-image-3.16.0-73-generic 3.16.0-73.95~14.04.1

Ubuntu 14.04 : nouveaux paquetages linux-image-3.13.0-87.
De nouveaux paquetages sont disponibles :
  Ubuntu 14.04 LTS : linux-image-3.13.0-87 3.13.0-87.133

Ubuntu 14.04 : nouveaux paquetages linux-image-4.2.0-38.
De nouveaux paquetages sont disponibles :
  Ubuntu 14.04 LTS : linux-image-4.2.0-38 4.2.0-38.45~14.04.1

Ubuntu 15.10 : nouveaux paquetages linux-image-4.2.0-1031-raspi2.
De nouveaux paquetages sont disponibles :
  Ubuntu 15.10 : linux-image-4.2.0-1031-raspi2 4.2.0-1031.41

Ubuntu : nouveaux paquetages linux-image (10/06/2016).
De nouveaux paquetages sont disponibles :
  Ubuntu 15.10 : linux-image-4.2.0-38-generic 4.2.0-38.45
  Ubuntu 14.04 LTS : linux-image-3.19.0-61-generic 3.19.0-61.69~14.04.1

Ubuntu : nouveaux paquetages linux-image-3.13.
De nouveaux paquetages sont disponibles :
  Ubuntu 12.04 LTS : linux-image-3.13.0-57-generic 3.13.0-57.95~precise1
  Ubuntu 14.04 LTS : linux-image-3.13.0-57-generic 3.13.0-57.95

Ubuntu : nouveaux paquetages linux-image-3.16.
De nouveaux paquetages sont disponibles :
  Ubuntu 14.04 LTS : linux-image-3.16.0-43-generic 3.16.0-43.58~14.04.1
  Ubuntu 14.10 : linux-image-3.16.0-43-generic 3.16.0-43.58

Ubuntu : nouveaux paquetages linux-image-3.19.
De nouveaux paquetages sont disponibles :
  Ubuntu 14.04 LTS : linux-image-3.19.0-22-generic 3.19.0-22.22~14.04.1
  Ubuntu 15.04 : linux-image-3.19.0-22-generic 3.19.0-22.22
Bulletin complet, filtrage par logiciel, emails, correctifs, ... (Demandez votre essai gratuit)

Service de veille sur les vulnérabilités informatiques 

Vigil@nce fournit un bulletin de vulnérabilités logicielles. Le service de veille sur les vulnérabilités informatiques Vigil@nce alerte vos équipes des failles et des menaces qui concernent votre système d'information.