L'équipe Vigil@nce veille les vulnérabilités publiques qui affectent votre parc informatique, puis propose des correctifs sécurité, une base et des outils pour y remédier.

alerte cybersécurité CVE-2018-20856

Noyau Linux : utilisation de mémoire libérée via __blk_drain_queue

Synthèse de la vulnérabilité

Un attaquant peut provoquer l'utilisation d'une zone mémoire libérée via __blk_drain_queue() du noyau Linux, afin de mener un déni de service, et éventuellement d'exécuter du code.
Gravité de ce bulletin : 2/4.
Date création : 14/08/2019.
Références de cette menace : CERTFR-2019-AVI-391, CERTFR-2019-AVI-392, CERTFR-2019-AVI-418, CERTFR-2019-AVI-419, CERTFR-2019-AVI-513, CVE-2018-20856, DLA-1885-1, DSA-4497-1, RHSA-2019:3055-01, RHSA-2019:3076-01, RHSA-2019:3089-01, RHSA-2019:3217-01, SSA:2019-226-01, SUSE-SU-2019:2263-1, SUSE-SU-2019:2299-1, USN-4094-1, USN-4116-1, USN-4118-1, VIGILANCE-VUL-30051.
Bulletin Vigil@nce complet... (Essai gratuit)

Description de la vulnérabilité

Un attaquant peut provoquer l'utilisation d'une zone mémoire libérée via __blk_drain_queue() du noyau Linux, afin de mener un déni de service, et éventuellement d'exécuter du code.
Bulletin Vigil@nce complet... (Essai gratuit)

Cet avis de menace concerne les logiciels ou systèmes comme Debian, Linux, RHEL, Slackware, SUSE Linux Enterprise Desktop, SLES, Ubuntu.

Notre équipe Vigil@nce a déterminé que la gravité de cette alerte de vulnérabilité est moyen.

Le niveau de confiance est de type confirmé par l'éditeur, avec une provenance de shell utilisateur.

Un attaquant avec un niveau de compétence expert peut exploiter cet avis de menace informatique.

Solutions pour cette menace

Noyau Linux : version 4.18.7.
La version 4.18.7 est corrigée :
  https://cdn.kernel.org/pub/linux/kernel/v4.x/

Noyau Linux : version 4.9.189.
La version 4.9.189 est corrigée :
  https://cdn.kernel.org/pub/linux/kernel/v4.x/

Noyau Linux : version 4.4.189.
La version 4.4.189 est corrigée :
  https://cdn.kernel.org/pub/linux/kernel/v4.x/

Noyau Linux : patch pour __blk_drain_queue.
Un patch est indiqué dans les sources d'information.

Debian 8 : nouveaux paquetages linux-4.9.
De nouveaux paquetages sont disponibles :
  Debian 8 : linux-4.9 4.9.168-1+deb9u5~deb8u1

Debian 9/10 : nouveaux paquetages linux.
De nouveaux paquetages sont disponibles :
  Debian 9 : linux 4.9.168-1+deb9u5
  Debian 10 : linux 4.19.37-5+deb10u2

RHEL 7 : nouveaux paquetages kernel.
De nouveaux paquetages sont disponibles :
  RHEL 7 : kernel 3.10.0-1062.4.1.el7

RHEL 7 : nouveaux paquetages kernel-alt.
De nouveaux paquetages sont disponibles :
  RHEL 7 : kernel-alt 4.14.0-115.14.1.el7a

RHEL 7 : nouveaux paquetages kernel-rt.
De nouveaux paquetages sont disponibles :
  RHEL 7 : kernel-rt 3.10.0-1062.4.1.rt56.1027.el7

RHEL 7 : nouveaux paquetages kpatch-patch.
De nouveaux paquetages sont disponibles :
  RHEL 7 : kpatch-patch 3_10_0-1062-1-5.el7

Slackware 14.2 : nouveaux paquetages kernel.
De nouveaux paquetages sont disponibles :
  Slackware 14.2 : kernel 4.4.189-*-1

SUSE LE 12 SP2 : nouveaux paquetages kernel.
De nouveaux paquetages sont disponibles :
  SUSE LE 12 SP2 : kernel 4.4.121-92.120.1

SUSE LE 12 SP3 : nouveaux paquetages kernel.
De nouveaux paquetages sont disponibles :
  SUSE LE 12 SP3 : kernel 4.4.180-94.103.1

Ubuntu 16.04 : nouveaux paquetages linux-image-4.4.0.
De nouveaux paquetages sont disponibles :
  Ubuntu 16.04 LTS : linux-image-generic 4.4.0.161.169

Ubuntu 16/18 : nouveaux paquetages linux-image-aws.
De nouveaux paquetages sont disponibles :
  Ubuntu 16.04 LTS : linux-image-aws 4.15.0.1047.47
  Ubuntu 18.04 LTS : linux-image-aws 4.15.0.1047.46

Ubuntu : nouveaux paquetages linux-image-4.15.0.
De nouveaux paquetages sont disponibles :
  Ubuntu 16.04 LTS : linux-image-generic-hwe-16.04 4.15.0.58.79
  Ubuntu 18.04 LTS : linux-image-generic 4.15.0.58.60
Bulletin Vigil@nce complet... (Essai gratuit)

Service de veille sur les vulnérabilités informatiques

Vigil@nce fournit une annonce de vulnérabilité de réseau. La cellule de veille technologique suit les menaces sécurité qui ciblent le parc informatique. L'équipe Vigil@nce surveille les vulnérabilités informatiques de systèmes et d'applications. La base de vulnérabilités Vigil@nce contient plusieurs milliers de failles.