L'équipe Vigil@nce veille les vulnérabilités publiques qui affectent votre parc informatique, puis propose des correctifs sécurité, une base de données de vigilance et des outils pour y remédier.

Vulnérabilité de Noyau Linux : utilisation de mémoire libérée via con_font_op

Synthèse de la vulnérabilité 

Un attaquant peut provoquer l'utilisation d'une zone mémoire libérée via con_font_op() du noyau Linux, afin de mener un déni de service, et éventuellement d'exécuter du code.
Produits impactés : Debian, Linux, openSUSE Leap, SUSE Linux Enterprise Desktop, SLES, Ubuntu.
Gravité de ce bulletin : 2/4.
Date de création : 30/10/2020.
Références de cette menace : CERTFR-2020-AVI-769, CERTFR-2020-AVI-776, CERTFR-2020-AVI-784, CERTFR-2020-AVI-794, CERTFR-2020-AVI-811, CERTFR-2020-AVI-834, CERTFR-2021-AVI-006, CERTFR-2021-AVI-111, CERTFR-2021-AVI-120, CERTFR-2021-AVI-125, CERTFR-2021-AVI-149, CVE-2020-25668, DLA-2483-1, DLA-2494-1, openSUSE-SU-2020:1906-1, openSUSE-SU-2020:2112-1, openSUSE-SU-2020:2260-1, openSUSE-SU-2021:0242-1, SUSE-SU-2020:3484-1, SUSE-SU-2020:3503-1, SUSE-SU-2020:3507-1, SUSE-SU-2020:3512-1, SUSE-SU-2020:3513-1, SUSE-SU-2020:3522-1, SUSE-SU-2020:3532-1, SUSE-SU-2020:3544-1, SUSE-SU-2020:3713-1, SUSE-SU-2020:3715-1, SUSE-SU-2020:3717-1, SUSE-SU-2020:3748-1, SUSE-SU-2021:0437-1, SUSE-SU-2021:14630-1, USN-4679-1, USN-4680-1, USN-4681-1, USN-4751-1, VIGILANCE-VUL-33747.

Description de la vulnérabilité 

Un attaquant peut provoquer l'utilisation d'une zone mémoire libérée via con_font_op() du noyau Linux, afin de mener un déni de service, et éventuellement d'exécuter du code.
Bulletin complet, filtrage par logiciel, emails, correctifs, ... (Demandez votre essai gratuit)

Cette alerte sécurité concerne les logiciels ou systèmes comme Debian, Linux, openSUSE Leap, SUSE Linux Enterprise Desktop, SLES, Ubuntu.

Notre équipe Vigil@nce a déterminé que la gravité de ce bulletin cybersécurité est moyen.

Le niveau de confiance est de type confirmé par l'éditeur, avec une provenance de shell utilisateur.

Un attaquant avec un niveau de compétence expert peut exploiter cet avis de vulnérabilité informatique.

Solutions pour cette menace 

Noyau Linux : version 5.9.5.
La version 5.9.5 est corrigée :
  https://cdn.kernel.org/pub/linux/kernel/v5.x/

Noyau Linux : version 5.4.75.
La version 5.4.75 est corrigée :
  https://cdn.kernel.org/pub/linux/kernel/v5.x/

Noyau Linux : version 4.19.155.
La version 4.19.155 est corrigée :
  https://cdn.kernel.org/pub/linux/kernel/v4.x/

Noyau Linux : version 4.14.204.
La version 4.14.204 est corrigée :
  https://cdn.kernel.org/pub/linux/kernel/v4.x/

Noyau Linux : version 4.9.242.
La version 4.9.242 est corrigée :
  https://cdn.kernel.org/pub/linux/kernel/v4.x/

Noyau Linux : version 4.4.242.
La version 4.4.242 est corrigée :
  https://cdn.kernel.org/pub/linux/kernel/v4.x/

Noyau Linux : patch pour con_font_op.
Un patch est indiqué dans les sources d'information.

Debian 9 : nouveaux paquetages linux.
De nouveaux paquetages sont disponibles :
  Debian 9 : linux 4.9.246-2

Debian 9 : nouveaux paquetages linux-4.19 (10/12/2020).
De nouveaux paquetages sont disponibles :
  Debian 9 : linux-4.19 4.19.160-2~deb9u1

openSUSE Leap 15.2 : nouveaux paquetages kernel (13/11/2020).
De nouveaux paquetages sont disponibles :
  openSUSE Leap 15.2 : kernel 5.3.18-lp152.50.1

openSUSE Leap 15.2 : nouveaux paquetages kernel (15/12/2020).
De nouveaux paquetages sont disponibles :
  openSUSE Leap 15.2 : kernel 5.3.18-lp152.57.1.lp152.8.17.1

openSUSE Leap 15.2 : nouveaux paquetages kernel (30/11/2020).
De nouveaux paquetages sont disponibles :
  openSUSE Leap 15.2 : kernel 5.3.18-lp152.50.1.lp152.8.10.1

openSUSE Leap 15.2 : nouveaux paquetages kernel-rt.
De nouveaux paquetages sont disponibles :
  openSUSE Leap 15.2 : kernel-rt 5.3.18-lp152.3.5.1

SUSE LE 11 SP4 : nouveaux paquetages kernel.
De nouveaux paquetages sont disponibles :
  SUSE LE 11 SP4 : kernel 3.0.101-108.120.1

SUSE LE 12 SP2 : nouveaux paquetages kernel (11/02/2021).
De nouveaux paquetages sont disponibles :
  SUSE LE 12 SP2 : kernel 4.4.121-92.149.1

SUSE LE 12 SP3 : nouveaux paquetages kernel-default.
De nouveaux paquetages sont disponibles :
  SUSE LE 12 SP3 : kernel-default 4.4.180-94.135.1

SUSE LE 12 SP4 : nouveaux paquetages kernel-default.
De nouveaux paquetages sont disponibles :
  SUSE LE 12 SP4 : kernel-default 4.12.14-95.65.1

SUSE LE 12 SP5 : nouveaux paquetages kernel (09/12/2020).
De nouveaux paquetages sont disponibles :
  SUSE LE 12 SP5 : kernel 4.12.14-122.54.1

SUSE LE 12 SP5 : nouveaux paquetages kernel-azure (09/12/2020).
De nouveaux paquetages sont disponibles :
  SUSE LE 12 SP5 : kernel-azure 4.12.14-16.38.1

SUSE LE 12 SP5 : nouveaux paquetages kernel-rt.
De nouveaux paquetages sont disponibles :
  SUSE LE 12 SP5 : kernel-rt 4.12.14-10.22.1

SUSE LE 15 : nouveaux paquetages kernel.
De nouveaux paquetages sont disponibles :
  SUSE LE 15 RTM : kernel-default-livepatch 4.12.14-150.63.1, kernel-livepatch 4_12_14-150_63-default-1-1.5.1

SUSE LE 15 SP1 : nouveaux paquetages kernel-azure (24/11/2020).
De nouveaux paquetages sont disponibles :
  SUSE LE 15 SP1 : kernel-azure 4.12.14-8.52.1

SUSE LE 15 SP1 : nouveaux paquetages kernel-default-livepatch.
De nouveaux paquetages sont disponibles :
  SUSE LE 15 SP1 : kernel-default-livepatch 4.12.14-197.72.1

SUSE LE 15 SP1 : nouveaux paquetages kernel-rt.
De nouveaux paquetages sont disponibles :
  SUSE LE 15 SP1 : kernel-rt 4.12.14-14.41.2

SUSE LE 15 SP2 : nouveaux paquetages kernel (11/12/2020).
De nouveaux paquetages sont disponibles :
  SUSE LE 15 SP2 : kernel 5.3.18-24.43.2

SUSE LE 15 SP2 : nouveaux paquetages kernel-azure.
De nouveaux paquetages sont disponibles :
  SUSE LE 15 SP2 : kernel-azure 5.3.18-18.29.1

SUSE LE 15 SP2 : nouveaux paquetages kernel-rt (26/11/2020).
De nouveaux paquetages sont disponibles :
  SUSE LE 15 SP2 : kernel-rt 5.3.18-16.1

Ubuntu 20 : nouveaux paquetages linux-image-5.8.0.
De nouveaux paquetages sont disponibles :
  Ubuntu 20.04 LTS : linux-image-generic-hwe-20.04 5.8.0.44.50~20.04.30
  Ubuntu 20.10 : linux-image-generic 5.8.0.44.49

Ubuntu : nouveaux paquetages linux-image-4.15.0.
De nouveaux paquetages sont disponibles :
  Ubuntu 14.04 ESM : linux-image-azure 4.15.0.1103.78
  Ubuntu 16.04 LTS : linux-image-generic-hwe-16.04 4.15.0.129.128
  Ubuntu 18.04 LTS : linux-image-generic 4.15.0.129.116

Ubuntu : nouveaux paquetages linux-image-4.4.0 (06/01/2021).
De nouveaux paquetages sont disponibles :
  Ubuntu 14.04 ESM : linux-image-generic-lts-xenial 4.4.0.198.173
  Ubuntu 16.04 LTS : linux-image-generic 4.4.0.198.204

Ubuntu : nouveaux paquetages linux-image-5.4.0.
De nouveaux paquetages sont disponibles :
  Ubuntu 18.04 LTS : linux-image-generic-hwe-18.04 5.4.0.59.65~18.04.54
  Ubuntu 20.04 LTS : linux-image-generic 5.4.0.59.62
Bulletin complet, filtrage par logiciel, emails, correctifs, ... (Demandez votre essai gratuit)

Service de veille sur les vulnérabilités informatiques 

Vigil@nce fournit des alertes de vulnérabilités applicatives. Chaque administrateur peut personnaliser la liste des produits pour lesquels il souhaite recevoir des alertes de vulnérabilités.