L'équipe Vigil@nce veille les vulnérabilités publiques qui affectent votre parc informatique, puis propose des correctifs sécurité, une base de données de vigilance et des outils pour y remédier.

Vulnérabilité de Noyau Linux : utilisation de mémoire libérée via fs/xfs/xfs_super.c

Synthèse de la vulnérabilité 

Un attaquant peut provoquer l'utilisation d'une zone mémoire libérée via fs/xfs/xfs_super.c du noyau Linux, afin de mener un déni de service, et éventuellement d'exécuter du code.
Logiciels impactés : Debian, Linux, openSUSE Leap, RHEL, RSA Authentication Manager, Slackware, SUSE Linux Enterprise Desktop, SLES, Ubuntu.
Gravité de cette vulnérabilité informatique : 1/4.
Date de création : 25/09/2019.
Références de cette annonce : CERTFR-2019-AVI-455, CERTFR-2019-AVI-478, CERTFR-2019-AVI-502, CERTFR-2019-AVI-503, CERTFR-2019-AVI-530, CERTFR-2019-AVI-561, CERTFR-2019-AVI-575, CERTFR-2020-AVI-051, CERTFR-2020-AVI-095, CERTFR-2020-AVI-114, CERTFR-2020-AVI-123, CERTFR-2020-AVI-125, CVE-2018-20976, DLA-1930-1, DLA-2114-1, DSA-2019-189, openSUSE-SU-2019:2173-1, openSUSE-SU-2019:2181-1, RHSA-2020:0178-01, RHSA-2020:0543-01, RHSA-2020:0592-01, RHSA-2020:0609-01, RHSA-2020:0661-01, SSA:2019-311-01, SUSE-SU-2019:14218-1, SUSE-SU-2019:2412-1, SUSE-SU-2019:2424-1, SUSE-SU-2019:2648-1, SUSE-SU-2019:2651-1, SUSE-SU-2019:2658-1, SUSE-SU-2019:2738-1, SUSE-SU-2019:2949-1, SUSE-SU-2019:2950-1, SUSE-SU-2019:2984-1, USN-4144-1, USN-4145-1, VIGILANCE-VUL-30400.

Description de la vulnérabilité 

Un attaquant peut provoquer l'utilisation d'une zone mémoire libérée via fs/xfs/xfs_super.c du noyau Linux, afin de mener un déni de service, et éventuellement d'exécuter du code.
Bulletin complet, filtrage par logiciel, emails, correctifs, ... (Demandez votre essai gratuit)

Cette menace concerne les logiciels ou systèmes comme Debian, Linux, openSUSE Leap, RHEL, RSA Authentication Manager, Slackware, SUSE Linux Enterprise Desktop, SLES, Ubuntu.

Notre équipe Vigil@nce a déterminé que la gravité de cette annonce cyber-sécurité est faible.

Le niveau de confiance est de type confirmé par l'éditeur, avec une provenance de shell utilisateur.

Un attaquant avec un niveau de compétence expert peut exploiter cette faille informatique.

Solutions pour cette menace 

Noyau Linux : version 4.18.
La version 4.18 est corrigée :
  https://cdn.kernel.org/pub/linux/kernel/v4.x/

Noyau Linux : version 4.14.150.
La version 4.14.150 est corrigée :
  https://cdn.kernel.org/pub/linux/kernel/v4.x/

Noyau Linux : version 4.9.197.
La version 4.9.197 est corrigée :
  https://cdn.kernel.org/pub/linux/kernel/v4.x/

Noyau Linux : version 4.4.197.
La version 4.4.197 est corrigée :
  https://cdn.kernel.org/pub/linux/kernel/v4.x/

Debian 8 : nouveaux paquetages linux.
De nouveaux paquetages sont disponibles :
  Debian 8 : linux 3.16.74-1

Debian 8 : nouveaux paquetages linux-4.9.
De nouveaux paquetages sont disponibles :
  Debian 8 : linux-4.9 4.9.210-1~deb8u1

openSUSE Leap 15 : nouveaux paquetages kernel.
De nouveaux paquetages sont disponibles :
  openSUSE Leap 15.0 : kernel 4.12.14-lp150.12.73.1
  openSUSE Leap 15.1 : kernel 4.12.14-lp151.28.16.1

RHEL 6 MRG : nouveaux paquetages kernel-rt.
De nouveaux paquetages sont disponibles :
  RHEL 6.0-6.10 : kernel-rt 3.10.0-693.64.1.rt56.662.el6rt

RHEL 7.2 : nouveaux paquetages kernel.
De nouveaux paquetages sont disponibles :
  RHEL 7.2 : kernel 3.10.0-327.85.1.el7

RHEL 7.3 : nouveaux paquetages kernel.
De nouveaux paquetages sont disponibles :
  RHEL 7.3 : kernel 3.10.0-514.72.1.el7

RHEL 7.4 : nouveaux paquetages kernel.
De nouveaux paquetages sont disponibles :
  RHEL 7.0-7.7 : kernel 3.10.0-693.64.1.el7

RHEL 7.5 : nouveaux paquetages kernel.
De nouveaux paquetages sont disponibles :
  RHEL 7.0-7.7 : kernel 3.10.0-862.48.1.el7

RSA Authentication Manager : version 8.4 Patch 9.
La version 8.4 Patch 9 est corrigée :
  https://www.dell.com/support/

Slackware 14.2 : nouveaux paquetages kernel.
De nouveaux paquetages sont disponibles :
  Slackware 14.2 : kernel 4.4.199-*-1

SUSE LE 11 SP4 : nouveaux paquetages kernel.
De nouveaux paquetages sont disponibles :
  SUSE LE 11 SP4 : kernel 3.0.101-108.108.1

SUSE LE 12 SP1 : nouveaux paquetages kernel (13/11/2019).
De nouveaux paquetages sont disponibles :
  SUSE LE 12 SP1 : kernel 3.12.74-60.64.124.1

SUSE LE 12 SP2 : nouveaux paquetages kernel.
De nouveaux paquetages sont disponibles :
  SUSE LE 12 SP2 : kernel 4.4.121-92.125.1

SUSE LE 12 SP3 : nouveaux paquetages kernel (13/11/2019).
De nouveaux paquetages sont disponibles :
  SUSE LE 12 SP3 : kernel 4.4.180-94.107.1

SUSE LE 12 SP4 : nouveaux paquetages kernel-azure.
De nouveaux paquetages sont disponibles :
  SUSE LE 12 SP4 : kernel-azure 4.12.14-6.26.1

SUSE LE 12 SP4 : nouveaux paquetages kernel-default.
De nouveaux paquetages sont disponibles :
  SUSE LE 12 SP4 : kernel-default 4.12.14-95.32.1

SUSE LE 15 : nouveaux paquetages kernel-azure.
De nouveaux paquetages sont disponibles :
  SUSE LE 15 RTM : kernel-azure 4.12.14-5.41.1
  SUSE LE 15 SP1 : kernel-azure 4.12.14-8.16.1

SUSE LE 15 SP1 : nouveaux paquetages kernel-default.
De nouveaux paquetages sont disponibles :
  SUSE LE 15 SP1 : kernel-default 4.12.14-197.18.1

SUSE LE 15 SP1 : nouveaux paquetages kernel-rt.
De nouveaux paquetages sont disponibles :
  SUSE LE 15 SP1 : kernel-rt 4.12.14-14.11.1

Ubuntu : nouveaux paquetages linux-image-4.15.0.
De nouveaux paquetages sont disponibles :
  Ubuntu 18.04 LTS : linux-image-generic 4.15.0.65.67
  Ubuntu 16.04 LTS : linux-image-generic-hwe-16.04 4.15.0.65.85

Ubuntu : nouveaux paquetages linux-image-4.4.0.
De nouveaux paquetages sont disponibles :
  Ubuntu 16.04 LTS : linux-image-generic 4.4.0.165.173

Wind River Linux : version 10.17.41.19.
La version 10.17.41.19 est corrigée.
Bulletin complet, filtrage par logiciel, emails, correctifs, ... (Demandez votre essai gratuit)

Service de veille sur les vulnérabilités informatiques 

Vigil@nce fournit une analyse cybersécurité. La cellule de veille technologique suit les menaces sécurité qui ciblent le parc informatique.