L'équipe Vigil@nce veille les vulnérabilités publiques qui affectent votre parc informatique, puis propose des correctifs sécurité, une base de données de vigilance et des outils pour y remédier.

Vulnérabilité de Noyau Linux : utilisation de mémoire libérée via packet_set_ring

Synthèse de la vulnérabilité 

Un attaquant local avec la capacité CAP_NET_RAW peut provoquer l'utilisation d'une zone mémoire libérée via packet_set_ring() sur le noyau Linux, afin de mener un déni de service, et éventuellement d'exécuter du code.
Logiciels vulnérables : Brocade vTM, Debian, Fedora, Android OS, Junos Space, Linux, openSUSE, openSUSE Leap, RHEL, Slackware, SUSE Linux Enterprise Desktop, SLES, Synology DSM, Synology DS***, Synology RS***, Ubuntu.
Gravité de cette annonce : 1/4.
Date de création : 06/12/2016.
Références de cette vulnérabilité informatique : BSA-2016-204, BSA-2016-207, BSA-2016-216, BSA-2016-234, CERTFR-2016-AVI-395, CERTFR-2016-AVI-401, CERTFR-2016-AVI-404, CERTFR-2017-AVI-042, CVE-2016-8655, DLA-772-1, FEDORA-2016-107f03cc00, FEDORA-2016-5aff4a6bbc, FEDORA-2016-5cb5b4082d, JSA10838, openSUSE-SU-2016:3050-1, openSUSE-SU-2016:3058-1, openSUSE-SU-2016:3061-1, openSUSE-SU-2016:3077-1, RHSA-2017:0386-01, RHSA-2017:0387-01, SSA:2016-347-01, SUSE-SU-2016:3039-1, SUSE-SU-2016:3049-1, SUSE-SU-2016:3063-1, SUSE-SU-2017:0407-1, USN-3149-1, USN-3149-2, USN-3150-1, USN-3150-2, USN-3151-1, USN-3151-2, USN-3151-3, USN-3151-4, USN-3152-1, USN-3152-2, VIGILANCE-VUL-21271.

Description de la vulnérabilité 

Un attaquant local avec la capacité CAP_NET_RAW peut provoquer l'utilisation d'une zone mémoire libérée via packet_set_ring() sur le noyau Linux, afin de mener un déni de service, et éventuellement d'exécuter du code.
Bulletin complet, filtrage par logiciel, emails, correctifs, ... (Demandez votre essai gratuit)

Ce bulletin de menace informatique concerne les logiciels ou systèmes comme Brocade vTM, Debian, Fedora, Android OS, Junos Space, Linux, openSUSE, openSUSE Leap, RHEL, Slackware, SUSE Linux Enterprise Desktop, SLES, Synology DSM, Synology DS***, Synology RS***, Ubuntu.

Notre équipe Vigil@nce a déterminé que la gravité de ce bulletin de vulnérabilité informatique est faible.

Le niveau de confiance est de type confirmé par l'éditeur, avec une provenance de shell privilégié.

Un démonstrateur ou un outil d'attaque est disponible, donc vos équipes doivent traiter cette alerte. Un attaquant avec un niveau de compétence technicien peut exploiter cette menace sécurité.

Solutions pour cette menace 

Noyau Linux : version 4.8.14.
La version 4.8.14 est corrigée :
  https://cdn.kernel.org/pub/linux/kernel/v4.x/

Noyau Linux : version 4.4.38.
La version 4.4.38 est corrigée :
  https://cdn.kernel.org/pub/linux/kernel/v4.x/

Noyau Linux : version 4.1.37.
La version 4.1.37 est corrigée :
  https://cdn.kernel.org/pub/linux/kernel/v4.x/

Noyau Linux : version 3.18.46.
La version 3.18.46 est corrigée :
  https://cdn.kernel.org/pub/linux/kernel/v3.x/

Noyau Linux : version 3.16.40.
La version 3.16.40 est corrigée :
  https://cdn.kernel.org/pub/linux/kernel/v3.x/

Noyau Linux : version 3.12.69.
La version 3.12.69 est corrigée :
  https://cdn.kernel.org/pub/linux/kernel/v3.x/

Noyau Linux : version 3.10.106.
La version 3.10.106 est corrigée :
  https://cdn.kernel.org/pub/linux/kernel/v3.x/linux-3.10.106.tar.xz

Noyau Linux : version 3.2.85.
La version 3.2.85 est corrigée :
  https://cdn.kernel.org/pub/linux/kernel/v3.x/

Noyau Linux : patch pour packet_set_ring.
Un patch est indiqué dans les sources d'information.

Android OS : patch 2017-03-01 et 2017-03-05.
Un patch est indiqué dans les sources d'information.

Brocade Virtual Traffic Manager : version 17.1.
La version 17.1 est corrigée.

Debian 7 : nouveaux paquetages linux.
De nouveaux paquetages sont disponibles :
  Debian 7 : linux 3.2.84-1

Fedora : nouveaux paquetages kernel.
De nouveaux paquetages sont disponibles :
  Fedora 23 : kernel 4.8.13-100.fc23
  Fedora 24 : kernel 4.8.13-200.fc24
  Fedora 25 : kernel 4.8.13-300.fc25

Junos Space : versions corrigées.
Les versions corrigées sont indiquées dans les sources d'information.

openSUSE 13.1 : nouveaux paquetages kernel.
De nouveaux paquetages sont disponibles :
  openSUSE 13.1 : kernel 3.12.67-61.1

openSUSE 13.2 : nouveaux paquetages kernel.
De nouveaux paquetages sont disponibles :
  openSUSE 13.2 : kernel 3.16.7-53.1

openSUSE Leap 42.1 : nouveaux paquetages kernel.
De nouveaux paquetages sont disponibles :
  openSUSE Leap 42.1 : kernel 4.1.36-38.1

openSUSE Leap 42.2 : nouveaux paquetages kernel.
De nouveaux paquetages sont disponibles :
  openSUSE Leap 42.2 : kernel 4.4.36-5.1

RHEL 7 : nouveaux paquetages kernel.
De nouveaux paquetages sont disponibles :
  RHEL 7 : kernel 3.10.0-514.10.2.el7

RHEL 7 : nouveaux paquetages kernel-rt.
De nouveaux paquetages sont disponibles :
  RHEL 7 : kernel-rt 3.10.0-514.10.2.rt56.435.el7

Slackware : nouveaux paquetages kernel.
De nouveaux paquetages sont disponibles :
  Slackware 14.2 : linux 20161211git-noarch-1

SUSE LE 12 : nouveaux paquetages kernel.
De nouveaux paquetages sont disponibles :
  SUSE LE 12 SP1 : kernel 3.12.67-60.64.21.1
  SUSE LE 12 SP2 : kernel 4.4.21-84.1

SUSE LE 12 RTM : nouveaux paquetages kernel.
De nouveaux paquetages sont disponibles :
  SUSE LE 12 RTM : kernel 3.12.60-52.60.1

SUSE LE 12 SP1 : nouveaux paquetages kernel-rt.
De nouveaux paquetages sont disponibles :
  SUSE LE 12 SP1 : kernel-rt 3.12.69-60.30.1

Synology : version 6.0.2-8451-6.
La version 6.0.2-8451-6 est corrigée :
  https://www.synology.com/

Ubuntu : nouveaux paquetages linux-image-3.13.0.
De nouveaux paquetages sont disponibles :
  Ubuntu 12.04 LTS : linux-image-3.13.0-105-generic 3.13.0-105.152~precise1
  Ubuntu 14.04 LTS : linux-image-3.13.0-105-generic 3.13.0-105.152

Ubuntu : nouveaux paquetages linux-image-3.2.0.
De nouveaux paquetages sont disponibles :
  Ubuntu 12.04 LTS : linux-image-3.2.0-118-generic 3.2.0-118.161, linux-image-3.2.0-1496-omap4 3.2.0-1496.123

Ubuntu : nouveaux paquetages linux-image-4.4.0.
De nouveaux paquetages sont disponibles :
  Ubuntu 14.04 LTS : linux-image-4.4.0-53-generic 4.4.0-53.74~14.04.1
  Ubuntu 16.04 LTS : linux-image-4.4.0-53-generic 4.4.0-53.74, linux-image-4.4.0-1039-snapdragon 4.4.0-1039.43, linux-image-4.4.0-1034-raspi2 4.4.0-1034.41

Ubuntu : nouveaux paquetages linux-image-4.8.0.
De nouveaux paquetages sont disponibles :
  Ubuntu 16.10 : linux-image-4.8.0-30-generic 4.8.0-30.32, linux-image-4.8.0-1020-raspi2 4.8.0-1020.23
Bulletin complet, filtrage par logiciel, emails, correctifs, ... (Demandez votre essai gratuit)

Service de veille sur les vulnérabilités informatiques 

Vigil@nce fournit des alertes de vulnérabilité informatique. Chaque administrateur peut personnaliser la liste des produits pour lesquels il souhaite recevoir des alertes de vulnérabilités.