L'équipe Vigil@nce veille les vulnérabilités publiques qui affectent votre parc informatique, puis propose des correctifs sécurité, une base de données de vigilance et des outils pour y remédier.

Vulnérabilité de Noyau Linux : utilisation de mémoire libérée via vt_do_kdgkb_ioctl

Synthèse de la vulnérabilité 

Un attaquant peut provoquer l'utilisation d'une zone mémoire libérée via vt_do_kdgkb_ioctl() du noyau Linux, afin de mener un déni de service, et éventuellement d'exécuter du code.
Systèmes impactés : Debian, Fedora, Linux, openSUSE Leap, SUSE Linux Enterprise Desktop, SLES, Ubuntu.
Gravité de cette alerte : 2/4.
Date de création : 16/10/2020.
Références de cette alerte : 1177766, CERTFR-2020-AVI-741, CERTFR-2020-AVI-750, CERTFR-2020-AVI-764, CERTFR-2020-AVI-769, CERTFR-2020-AVI-776, CERTFR-2020-AVI-784, CERTFR-2020-AVI-834, CERTFR-2021-AVI-006, CVE-2020-25656, DLA-2483-1, DLA-2494-1, FEDORA-2020-98ccae320c, FEDORA-2020-e211716d08, openSUSE-SU-2020:1906-1, openSUSE-SU-2020:2112-1, SUSE-SU-2020:3272-1, SUSE-SU-2020:3273-1, SUSE-SU-2020:3281-1, SUSE-SU-2020:3326-1, SUSE-SU-2020:3484-1, SUSE-SU-2020:3491-1, SUSE-SU-2020:3501-1, SUSE-SU-2020:3503-1, SUSE-SU-2020:3512-1, SUSE-SU-2020:3513-1, SUSE-SU-2020:3522-1, SUSE-SU-2020:3532-1, SUSE-SU-2020:3544-1, USN-4679-1, USN-4680-1, USN-4681-1, VIGILANCE-VUL-33611.

Description de la vulnérabilité 

Un attaquant peut provoquer l'utilisation d'une zone mémoire libérée via vt_do_kdgkb_ioctl() du noyau Linux, afin de mener un déni de service, et éventuellement d'exécuter du code.
Bulletin complet, filtrage par logiciel, emails, correctifs, ... (Demandez votre essai gratuit)

Cette menace informatique concerne les logiciels ou systèmes comme Debian, Fedora, Linux, openSUSE Leap, SUSE Linux Enterprise Desktop, SLES, Ubuntu.

Notre équipe Vigil@nce a déterminé que la gravité de cette alerte de menace informatique est moyen.

Le niveau de confiance est de type confirmé par l'éditeur, avec une provenance de document.

Un attaquant avec un niveau de compétence expert peut exploiter ce bulletin de menace informatique.

Solutions pour cette menace 

Noyau Linux : patch pour vt_do_kdgkb_ioctl.
Un patch est indiqué dans les sources d'information.

Debian 9 : nouveaux paquetages linux.
De nouveaux paquetages sont disponibles :
  Debian 9 : linux 4.9.246-2

Debian 9 : nouveaux paquetages linux-4.19 (10/12/2020).
De nouveaux paquetages sont disponibles :
  Debian 9 : linux-4.19 4.19.160-2~deb9u1

Fedora 32-33 : nouveaux paquetages kernel.
De nouveaux paquetages sont disponibles :
  Fedora 32 : kernel 5.9.8-100.fc32
  Fedora 33 : kernel 5.9.8-200.fc33

Fedora 32-33 : nouveaux paquetages kernel-headers.
De nouveaux paquetages sont disponibles :
  Fedora 32 : kernel-headers 5.9.7-100.fc32
  Fedora 33 : kernel-headers 5.9.7-200.fc33

Fedora 32-33 : nouveaux paquetages kernel-tools.
De nouveaux paquetages sont disponibles :
  Fedora 32 : kernel-tools 5.9.7-100.fc32
  Fedora 33 : kernel-tools 5.9.7-200.fc33

openSUSE Leap 15.2 : nouveaux paquetages kernel (13/11/2020).
De nouveaux paquetages sont disponibles :
  openSUSE Leap 15.2 : kernel 5.3.18-lp152.50.1

openSUSE Leap 15.2 : nouveaux paquetages kernel (30/11/2020).
De nouveaux paquetages sont disponibles :
  openSUSE Leap 15.2 : kernel 5.3.18-lp152.50.1.lp152.8.10.1

SUSE LE 12 SP2 : nouveaux paquetages kernel-default.
De nouveaux paquetages sont disponibles :
  SUSE LE 12 SP2 : kernel-default 4.4.121-92.146.1
  SUSE LE 12 SP2 : kernel-default 4.4.121-92.146.1

SUSE LE 12 SP3 : nouveaux paquetages kernel-default.
De nouveaux paquetages sont disponibles :
  SUSE LE 12 SP3 : kernel-default 4.4.180-94.135.1

SUSE LE 12 SP4 : nouveaux paquetages kernel-default.
De nouveaux paquetages sont disponibles :
  SUSE LE 12 SP4 : kernel-default 4.12.14-95.65.1

SUSE LE 12 SP5 : nouveaux paquetages kernel (16/11/2020).
De nouveaux paquetages sont disponibles :
  SUSE LE 12 SP5 : kernel 4.12.14-122.51.2

SUSE LE 12 SP5 : nouveaux paquetages kernel-azure.
De nouveaux paquetages sont disponibles :
  SUSE LE 12 SP5 : kernel-azure 4.12.14-16.34.1

SUSE LE 12 SP5 : nouveaux paquetages kernel-rt.
De nouveaux paquetages sont disponibles :
  SUSE LE 12 SP5 : kernel-rt 4.12.14-10.22.1

SUSE LE 15 : nouveaux paquetages kernel.
De nouveaux paquetages sont disponibles :
  SUSE LE 15 RTM : kernel-default-livepatch 4.12.14-150.63.1, kernel-livepatch 4_12_14-150_63-default-1-1.5.1

SUSE LE 15 SP1 : nouveaux paquetages kernel.
De nouveaux paquetages sont disponibles :
  SUSE LE 15 SP1 : kernel 4.12.14-197.67.1

SUSE LE 15 SP1 : nouveaux paquetages kernel-azure (24/11/2020).
De nouveaux paquetages sont disponibles :
  SUSE LE 15 SP1 : kernel-azure 4.12.14-8.52.1

SUSE LE 15 SP1 : nouveaux paquetages kernel-rt.
De nouveaux paquetages sont disponibles :
  SUSE LE 15 SP1 : kernel-rt 4.12.14-14.41.2

SUSE LE 15 SP2 : nouveaux paquetages kernel.
De nouveaux paquetages sont disponibles :
  SUSE LE 15 SP2 : kernel 5.3.18-24.37.1

SUSE LE 15 SP2 : nouveaux paquetages kernel-azure (24/11/2020).
De nouveaux paquetages sont disponibles :
  SUSE LE 15 SP2 : kernel-azure 5.3.18-18.24.1

SUSE LE 15 SP2 : nouveaux paquetages kernel-rt (26/11/2020).
De nouveaux paquetages sont disponibles :
  SUSE LE 15 SP2 : kernel-rt 5.3.18-16.1

Ubuntu : nouveaux paquetages linux-image-4.15.0.
De nouveaux paquetages sont disponibles :
  Ubuntu 14.04 ESM : linux-image-azure 4.15.0.1103.78
  Ubuntu 16.04 LTS : linux-image-generic-hwe-16.04 4.15.0.129.128
  Ubuntu 18.04 LTS : linux-image-generic 4.15.0.129.116

Ubuntu : nouveaux paquetages linux-image-4.4.0 (06/01/2021).
De nouveaux paquetages sont disponibles :
  Ubuntu 14.04 ESM : linux-image-generic-lts-xenial 4.4.0.198.173
  Ubuntu 16.04 LTS : linux-image-generic 4.4.0.198.204

Ubuntu : nouveaux paquetages linux-image-5.4.0.
De nouveaux paquetages sont disponibles :
  Ubuntu 18.04 LTS : linux-image-generic-hwe-18.04 5.4.0.59.65~18.04.54
  Ubuntu 20.04 LTS : linux-image-generic 5.4.0.59.62
Bulletin complet, filtrage par logiciel, emails, correctifs, ... (Demandez votre essai gratuit)

Service de veille sur les vulnérabilités informatiques 

Vigil@nce fournit une alerte de vulnérabilités informatiques. Le service de veille sur les vulnérabilités informatiques Vigil@nce alerte vos équipes des failles et des menaces qui concernent votre système d'information.