L'équipe Vigil@nce veille les vulnérabilités publiques qui affectent votre parc informatique, puis propose des correctifs sécurité, une base de données de vigilance et des outils pour y remédier.

Vulnérabilité de OpenJPEG : lecture de mémoire hors plage prévue via opj_t2_encode_packet

Synthèse de la vulnérabilité 

Un attaquant peut forcer la lecture à une adresse invalide via opj_t2_encode_packet() de OpenJPEG, afin de mener un déni de service, ou d'obtenir des informations sensibles.
Systèmes vulnérables : Fedora, Ubuntu.
Gravité de cette menace : 2/4.
Date de création : 22/12/2020.
Références de cette faille : CVE-2020-27843, FEDORA-2020-3e00413763, FEDORA-2020-d32853a28d, USN-4685-1, USN-4686-1, VIGILANCE-VUL-34190.

Description de la vulnérabilité 

Un attaquant peut forcer la lecture à une adresse invalide via opj_t2_encode_packet() de OpenJPEG, afin de mener un déni de service, ou d'obtenir des informations sensibles.
Bulletin complet, filtrage par logiciel, emails, correctifs, ... (Demandez votre essai gratuit)

Cette menace cyber-sécurité concerne les logiciels ou systèmes comme Fedora, Ubuntu.

Notre équipe Vigil@nce a déterminé que la gravité de cette vulnérabilité est moyen.

Le niveau de confiance est de type confirmé par l'éditeur, avec une provenance de document.

Un attaquant avec un niveau de compétence expert peut exploiter ce bulletin de vulnérabilité.

Solutions pour cette menace 

Fedora 32 : nouveaux paquetages mingw-openjpeg2.
De nouveaux paquetages sont disponibles :
  Fedora 32 : mingw-openjpeg2 2.3.1-11.fc32

Fedora 32 : nouveaux paquetages openjpeg2.
De nouveaux paquetages sont disponibles :
  Fedora 32 : openjpeg2 2.3.1-10.fc32

Fedora 33 : nouveaux paquetages mingw-openjpeg2.
De nouveaux paquetages sont disponibles :
  Fedora 33 : mingw-openjpeg2 2.3.1-11.fc33

Fedora 33 : nouveaux paquetages openjpeg2.
De nouveaux paquetages sont disponibles :
  Fedora 33 : openjpeg2 2.3.1-10.fc33

Ubuntu : nouveaux paquetages ghostscript.
De nouveaux paquetages sont disponibles :
  Ubuntu 18.04 LTS : ghostscript 9.26~dfsg+0-0ubuntu0.18.04.14
  Ubuntu 16.04 LTS : ghostscript 9.26~dfsg+0-0ubuntu0.16.04.14

Ubuntu : nouveaux paquetages libopenjp.
De nouveaux paquetages sont disponibles :
  Ubuntu 20.10 : libopenjp 2.3.1-1ubuntu4.20.10.1
  Ubuntu 20.04 LTS : libopenjp 2.3.1-1ubuntu4.20.04.1
Bulletin complet, filtrage par logiciel, emails, correctifs, ... (Demandez votre essai gratuit)

Service de veille sur les vulnérabilités informatiques 

Vigil@nce fournit une veille de vulnérabilité de logiciel. La veille sécurité Vigil@nce publie des bulletins de vulnérabilités pour les failles qui impactent le système d'information.