L'équipe Vigil@nce veille les vulnérabilités publiques qui affectent votre parc informatique, puis propose des correctifs sécurité, une base de données de vigilance et des outils pour y remédier.

Vulnérabilité de OpenLDAP : déni de service via les filtres de recherches

Synthèse de la vulnérabilité 

Un attaquant peut provoquer une erreur fatale via les filtres de recherche dans OpenLDAP, afin de mener un déni de service.
Produits vulnérables : Debian, OpenLDAP, openSUSE Leap, Solaris, SUSE Linux Enterprise Desktop, SLES, Ubuntu.
Gravité de cette faille : 2/4.
Date de création : 29/04/2020.
Date de révision : 29/04/2020.
Références de ce bulletin : CVE-2020-12243, DLA-2199-1, DSA-4666-1, openSUSE-SU-2020:0647-1, SUSE-SU-2020:1193-1, SUSE-SU-2020:1210-1, SUSE-SU-2020:1219-1, SUSE-SU-2020:14358-1, USN-4352-1, USN-4352-2, VIGILANCE-VUL-32124.

Description de la vulnérabilité 

Un attaquant peut provoquer une surconsommation de mémoire via les filtres de recherche dans OpenLDAP, afin de mener un déni de service.

Voir aussi VIGILANCE-VUL-32119.
Bulletin complet, filtrage par logiciel, emails, correctifs, ... (Demandez votre essai gratuit)

Cet avis cybersécurité concerne les logiciels ou systèmes comme Debian, OpenLDAP, openSUSE Leap, Solaris, SUSE Linux Enterprise Desktop, SLES, Ubuntu.

Notre équipe Vigil@nce a déterminé que la gravité de cet avis sécurité est moyen.

Le niveau de confiance est de type confirmé par l'éditeur, avec une provenance de client intranet.

Un attaquant avec un niveau de compétence expert peut exploiter cette menace cyber-sécurité.

Solutions pour cette menace 

OpenLDAP : version 2.4.50.
La version 2.4.50 est corrigée :
  https://www.openldap.org/software/download/

Debian 8 : nouveaux paquetages openldap.
De nouveaux paquetages sont disponibles :
  Debian 8 : openldap 2.4.40+dfsg-1+deb8u6

Debian 9, 10 : nouveaux paquetages openldap.
De nouveaux paquetages sont disponibles :
  Debian 9 : openldap 2.4.44+dfsg-5+deb9u4
  Debian 10 : openldap 2.4.47+dfsg-3+deb10u2

openSUSE Leap 15.1 : nouveaux paquetages openldap2.
De nouveaux paquetages sont disponibles :
  openSUSE Leap 15.1 : openldap2 2.4.46-lp151.10.9.1

Oracle Solaris : patch pour logiciels tiers de avril 2020 v3.
Un patch est disponible :
  https://support.oracle.com/rs?type=doc&id=1448883.1

SUSE LE 11, 12 : nouveaux paquetages openldap2.
De nouveaux paquetages sont disponibles :
  SUSE LE 12 SP5 : openldap2 2.4.41-18.68.1
  SUSE LE 12 SP4 : openldap2 2.4.41-18.68.1
  SUSE LE 12 SP3 : openldap2 2.4.41-18.68.1
  SUSE LE 12 SP2 : openldap2 2.4.41-18.68.1
  SUSE LE 11 SP4 : openldap2 2.4.26-0.74.9.1
  SUSE LE 11 RTM-SP4 : openldap2-openssl1 2.4.26-0.74.9.1

SUSE LE 11 SP3/4 : nouveaux paquetages openldap2.
De nouveaux paquetages sont disponibles :
  SUSE LE 11 SP3 : openldap2 2.4.26-0.74.9.1
  SUSE LE 11 SP4 : openldap2 2.4.26-0.74.9.1

SUSE LE 12 SP1 : nouveaux paquetages openldap2.
De nouveaux paquetages sont disponibles :
  SUSE LE 12 SP1 : openldap2 2.4.41-18.24.17.1

SUSE LE 15 : nouveaux paquetages openldap2.
De nouveaux paquetages sont disponibles :
  SUSE LE 15 RTM : openldap2 2.4.46-9.28.2
  SUSE LE 15 SP1 : openldap2 2.4.46-9.28.2

Ubuntu : nouveaux paquetages slapd.
De nouveaux paquetages sont disponibles :
  Ubuntu 20.04 LTS : slapd 2.4.49+dfsg-2ubuntu1.2
  Ubuntu 19.10 : slapd 2.4.48+dfsg-1ubuntu1.1
  Ubuntu 18.04 LTS : slapd 2.4.45+dfsg-1ubuntu1.5
  Ubuntu 16.04 LTS : slapd 2.4.42+dfsg-2ubuntu3.8
  Ubuntu 14.04 ESM : slapd 2.4.31-1+nmu2ubuntu8.5+esm2
  Ubuntu 12.04 ESM : slapd 2.4.28-1.1ubuntu4.10

Wind River Linux : version 10.18.44.17.
La version 10.18.44.17 est corrigée :
  https://support2.windriver.com/

Wind River Linux : version 10.19.45.8.
La version 10.19.45.8 est corrigée.
Bulletin complet, filtrage par logiciel, emails, correctifs, ... (Demandez votre essai gratuit)

Service de veille sur les vulnérabilités informatiques 

Vigil@nce fournit une analyse de vulnérabilités applicatives. La cellule de veille technologique suit les menaces sécurité qui ciblent le parc informatique.