L'équipe Vigil@nce veille les vulnérabilités publiques qui affectent votre parc informatique, puis propose des correctifs sécurité, une base de données de vigilance et des outils pour y remédier.

Vulnérabilité de OpenSLP : buffer overflow

Synthèse de la vulnérabilité 

Un attaquant peut provoquer un buffer overflow de OpenSLP, afin de mener un déni de service, et éventuellement d'exécuter du code.
Produits impactés : Debian, Fedora, RHEL, Ubuntu, ESXi, vSphere Hypervisor.
Gravité de ce bulletin : 3/4.
Date de création : 06/12/2019.
Références de cette menace : CERTFR-2019-AVI-610, CVE-2019-5544, DLA-2025-1, FEDORA-2019-1e5ae33e87, FEDORA-2019-86bceb61b3, RHSA-2019:4240-01, RHSA-2020:0199-01, USN-4919-1, VIGILANCE-VUL-31083, VMSA-2019-0022.

Description de la vulnérabilité 

Le produit OpenSLP dispose d'un service web.

Cependant, si la taille des données est supérieure à la taille du tableau de stockage, un débordement se produit.

Un attaquant peut donc provoquer un buffer overflow de OpenSLP, afin de mener un déni de service, et éventuellement d'exécuter du code.
Bulletin complet, filtrage par logiciel, emails, correctifs, ... (Demandez votre essai gratuit)

Cette alerte de vulnérabilité concerne les logiciels ou systèmes comme Debian, Fedora, RHEL, Ubuntu, ESXi, vSphere Hypervisor.

Notre équipe Vigil@nce a déterminé que la gravité de cette menace est important.

Le niveau de confiance est de type confirmé par l'éditeur, avec une provenance de client intranet.

Un attaquant avec un niveau de compétence expert peut exploiter ce bulletin cyber-sécurité.

Solutions pour cette menace 

Debian 8 : nouveaux paquetages openslp-dfsg.
De nouveaux paquetages sont disponibles :
  Debian 8 : openslp-dfsg 1.2.1-10+deb8u2

Fedora : nouveaux paquetages openslp.
De nouveaux paquetages sont disponibles :
  Fedora 30 : openslp 2.0.0-22.fc30
  Fedora 31 : openslp 2.0.0-23.fc31

RHEL 6.10 : nouveaux paquetages openslp.
De nouveaux paquetages sont disponibles :
  RHEL 6.10 : openslp 2.0.0-4.el6_10

RHEL 7.7 : nouveaux paquetages openslp.
De nouveaux paquetages sont disponibles :
  RHEL 7.7 : openslp 2.0.0-8.el7_7

Ubuntu : nouveaux paquetages libslp1.
De nouveaux paquetages sont disponibles :
  Ubuntu 16.04 LTS : libslp1 1.2.1-11ubuntu0.16.04.2
  Ubuntu 14.04 ESM : libslp1 1.2.1-9ubuntu0.3+esm1

VMware ESXi : patch pour OpenSLP.
Un patch est indiqué dans les sources d'information.
Bulletin complet, filtrage par logiciel, emails, correctifs, ... (Demandez votre essai gratuit)

Service de veille sur les vulnérabilités informatiques 

Vigil@nce fournit des avis de vulnérabilités logicielles. La base de vulnérabilités Vigil@nce contient plusieurs milliers de failles.