L'équipe Vigil@nce veille les vulnérabilités publiques qui affectent votre parc informatique, puis propose des correctifs sécurité, une base de données de vigilance et des outils pour y remédier.

Vulnérabilité de OpenSSL : obtention d'information via ChaCha20-Poly1305 Long Nonces

Synthèse de la vulnérabilité 

Un attaquant peut contourner les restrictions d'accès aux données via ChaCha20-Poly1305 Long Nonces de OpenSSL, afin d'obtenir des informations sensibles.
Systèmes vulnérables : Debian, IBM i, Juniper SBR, OpenSSL, openSUSE Leap, VirtualBox, RHEL, SUSE Linux Enterprise Desktop, SLES.
Gravité de cette menace : 1/4.
Date de création : 06/03/2019.
Références de cette faille : cpujul2019, CVE-2019-1543, DSA-4475-1, ibm10967487, JSA11074, openSUSE-SU-2019:1147-1, openSUSE-SU-2019:1814-1, RHSA-2019:3700-01, SUSE-SU-2019:0678-1, SUSE-SU-2019:0787-1, VIGILANCE-VUL-28682.

Description de la vulnérabilité 

Un attaquant peut contourner les restrictions d'accès aux données via ChaCha20-Poly1305 Long Nonces de OpenSSL, afin d'obtenir des informations sensibles.
Bulletin complet, filtrage par logiciel, emails, correctifs, ... (Demandez votre essai gratuit)

Cette alerte de vulnérabilité concerne les logiciels ou systèmes comme Debian, IBM i, Juniper SBR, OpenSSL, openSUSE Leap, VirtualBox, RHEL, SUSE Linux Enterprise Desktop, SLES.

Notre équipe Vigil@nce a déterminé que la gravité de cette menace est faible.

Le niveau de confiance est de type confirmé par l'éditeur, avec une provenance de client internet.

Un attaquant avec un niveau de compétence expert peut exploiter ce bulletin cyber-sécurité.

Solutions pour cette menace 

OpenSSL : version 1.1.1c.
La version 1.1.1c est corrigée :
  https://www.openssl.org/source/mirror.html

OpenSSL : version 1.1.0k.
La version 1.1.0k est corrigée :
  https://www.openssl.org/source/openssl-1.1.0k.tar.gz

OpenSSL : patch pour ChaCha20-Poly1305 Long Nonces.
Un patch est disponible :
  OpenSSL 1.1.0 : https://github.com/openssl/openssl/commit/ee22257b14
  OpenSSL 1.1.1 : https://github.com/openssl/openssl/commit/f426625b6a

Debian 9 : nouveaux paquetages openssl.
De nouveaux paquetages sont disponibles :
  Debian 9 : openssl 1.1.0k-1~deb9u1

IBM i : patch pour OpenSSL.
Un patch est indiqué dans les sources d'information.

Juniper Networks SBR Carrier : versions corrigées pour Third-party Software.
Les versions corrigées sont indiquées dans les sources d'information.

openSUSE Leap 15.0 : nouveaux paquetages openssl-1_1.
De nouveaux paquetages sont disponibles :
  openSUSE Leap 15.0 : openssl-1_1 1.1.0i-lp150.3.22.3

openSUSE Leap : nouveaux paquetages virtualbox.
De nouveaux paquetages sont disponibles :
  openSUSE Leap 15.0 : virtualbox 6.0.10-lp150.4.36.1
  openSUSE Leap 15.1 : virtualbox 6.0.10-lp151.2.6.1

Oracle VM VirtualBox : version 5.2.32.
La version 5.2.32 est corrigée :
  https://www.virtualbox.org/

Oracle VM VirtualBox : version 6.0.10.
La version 6.0.10 est corrigée :
  https://www.virtualbox.org/

RHEL 8 : nouveaux paquetages openssl.
De nouveaux paquetages sont disponibles :
  RHEL 8 : openssl 1.1.1c-2.el8

SUSE LE 12 SP4 : nouveaux paquetages openssl-1_1.
De nouveaux paquetages sont disponibles :
  SUSE LE 12 SP4 : openssl-1_1 1.1.1-2.9.1

SUSE LE 15 : nouveaux paquetages openssl-1_1.
De nouveaux paquetages sont disponibles :
  SUSE LE 15 RTM : openssl-1_1 1.1.0i-4.21.1

Wind River Linux : solution (21/05/2019).
La solution est indiquée dans les sources d'information.
Bulletin complet, filtrage par logiciel, emails, correctifs, ... (Demandez votre essai gratuit)

Service de veille sur les vulnérabilités informatiques 

Vigil@nce fournit des annonces de vulnérabilité applicative. L'équipe Vigil@nce surveille les vulnérabilités informatiques de systèmes et d'applications.