L'équipe Vigil@nce veille les vulnérabilités publiques qui affectent votre parc informatique, puis propose des correctifs sécurité, une base de données de vigilance et des outils pour y remédier.

Vulnérabilité de OpenSSL : obtention d'information via PKCS7/CMS Padding Oracle

Synthèse de la vulnérabilité 

Un attaquant peut contourner les restrictions d'accès aux données via PKCS7/CMS Padding Oracle de OpenSSL, afin d'obtenir des informations sensibles.
Systèmes impactés : SNS, Debian, Avamar, NetWorker, Unisphere EMC, AIX, IBM i, Rational ClearCase, Tivoli Storage Manager, WebSphere MQ, Data ONTAP 7-Mode, OpenSSL, openSUSE Leap, Solaris, VirtualBox, Slackware, SUSE Linux Enterprise Desktop, SLES, WinSCP, X2GoClient.
Gravité de cette alerte : 2/4.
Date de création : 11/09/2019.
Références de cette alerte : 1137844, 1172266, 1172278, 3456663, 5695611, 5695629, 5695653, CERTFR-2019-AVI-444, cpuoct2019, CVE-2019-1563, DLA-1932-1, DSA-2019-201, DSA-2020-062, DSA-4539-1, DSA-4539-2, DSA-4539-3, DSA-4540-1, NTAP-20190919-0002, openSUSE-SU-2019:2158-1, openSUSE-SU-2019:2189-1, openSUSE-SU-2019:2268-1, openSUSE-SU-2019:2269-1, SSA:2019-254-03, STORM-2019-018, SUSE-SU-2019:14171-1, SUSE-SU-2019:14174-1, SUSE-SU-2019:2397-1, SUSE-SU-2019:2403-1, SUSE-SU-2019:2410-1, SUSE-SU-2019:2413-1, SUSE-SU-2019:2504-1, SUSE-SU-2019:2558-1, SUSE-SU-2019:2561-1, SUSE-SU-2020:0099-1, VIGILANCE-VUL-30293.

Description de la vulnérabilité 

Un attaquant peut contourner les restrictions d'accès aux données via PKCS7/CMS Padding Oracle de OpenSSL, afin d'obtenir des informations sensibles.
Bulletin complet, filtrage par logiciel, emails, correctifs, ... (Demandez votre essai gratuit)

Cette alerte cybersécurité concerne les logiciels ou systèmes comme SNS, Debian, Avamar, NetWorker, Unisphere EMC, AIX, IBM i, Rational ClearCase, Tivoli Storage Manager, WebSphere MQ, Data ONTAP 7-Mode, OpenSSL, openSUSE Leap, Solaris, VirtualBox, Slackware, SUSE Linux Enterprise Desktop, SLES, WinSCP, X2GoClient.

Notre équipe Vigil@nce a déterminé que la gravité de cet avis de menace est moyen.

Le niveau de confiance est de type confirmé par l'éditeur, avec une provenance de client internet.

Un attaquant avec un niveau de compétence expert peut exploiter cette annonce de menace informatique.

Solutions pour cette menace 

OpenSSL : version 1.1.1d.
La version 1.1.1d est corrigée :
  https://www.openssl.org/

OpenSSL : version 1.1.0l.
La version 1.1.0l est corrigée :
  https://www.openssl.org/

OpenSSL : version 1.0.2t.
La version 1.0.2t est corrigée :
  https://www.openssl.org/

AIX : patch pour OpenSSL.
Un patch est disponible :
  https://www-01.ibm.com/marketing/iwm/iwm/web/pickUrxNew.do?source=aixbp&S_PKG=openssl

Debian 8 : nouveaux paquetages openssl.
De nouveaux paquetages sont disponibles :
  Debian 8 : openssl 1.0.1t-1+deb8u12

Debian 9/10 : nouveaux paquetages openssl.
De nouveaux paquetages sont disponibles :
  Debian 9 : openssl 1.1.0l-1~deb9u1
  Debian 10 : openssl 1.1.1d-0+deb10u2

Debian 9 : nouveaux paquetages openssl1.0.
De nouveaux paquetages sont disponibles :
  Debian 9 : openssl1.0 1.0.2t-1~deb9u1

Dell EMC Avamar, NetWorker : solution.
La solution est indiquée dans les sources d'information.

Dell EMC Unisphere for PowerMax : solution.
La solution est indiquée dans les sources d'information.

IBM i : patch pour OpenSSL.
Un patch est indiqué dans les sources d'information.

IBM Rational ClearCase : patch pour OpenSSL.
Un patch est indiqué dans les sources d'information.

IBM Spectrum Protect Backup-Archive Client : versions corrigées.
Les versions corrigées sont indiquées dans les sources d'information.

IBM WebSphere MQ for HP NonStop Server : version 5.3.1.16.
La version 5.3.1.16 est corrigée :
  https://www-945.ibm.com/support/fixcentral/swg/selectFixes?parent=ibm%7EWebSphere&product=ibm/WebSphere/WebSphere+MQ&release=5.3.1.16&platform=HP+NonStop&function=all&useReleaseAsTarget=true

openSUSE Leap 15 : nouveaux paquetages openssl-1_0_0.
De nouveaux paquetages sont disponibles :
  openSUSE Leap 15.0 : openssl-1_0_0 1.0.2p-lp150.2.19.1
  openSUSE Leap 15.1 : openssl-1_0_0 1.0.2p-lp151.5.10.1

openSUSE Leap 15 : nouveaux paquetages openssl-1_1.
De nouveaux paquetages sont disponibles :
  openSUSE Leap 15.1 : openssl-1_1 1.1.0i-lp151.8.3.1
  openSUSE Leap 15.0 : openssl-1_1 1.1.0i-lp150.3.25.1

Oracle Solaris : patch pour logiciels tiers de octobre 2019 v3.
Un patch est disponible :
  https://support.oracle.com/rs?type=doc&id=1448883.1

Oracle VM VirtualBox : version 5.2.34.
La version 5.2.34 est corrigée :
  https://support.oracle.com/rs?type=doc&id=2592169.1
  https://www.virtualbox.org/wiki/Downloads

Oracle VM VirtualBox : version 6.0.14.
La version 6.0.14 est corrigée :
  https://support.oracle.com/rs?type=doc&id=2592169.1
  https://www.virtualbox.org/wiki/Downloads

Slackware : nouveaux paquetages openssl.
De nouveaux paquetages sont disponibles :
  Slackware 14.2 : openssl 1.0.2t-*-1_slack14.2

Stormshield Network Security : versions 3.7.8 et 3.9.2.
Les versions 3.7.8 et 3.9.2 sont corrigées :
  https://www.stormshield.eu/

SUSE LE 11 : nouveaux paquetages openssl1.
De nouveaux paquetages sont disponibles :
  SUSE LE 11 RTM-SP4 : openssl1 1.0.1g-0.58.21.1

SUSE LE 11 SP3, SP4 : nouveaux paquetages openssl.
De nouveaux paquetages sont disponibles :
  SUSE LE 11 SP4 : openssl 0.9.8j-0.106.25.1
  SUSE LE 11 SP3 : openssl 0.9.8j-0.106.25.1

SUSE LE 12 : nouveaux paquetages compat-openssl098.
De nouveaux paquetages sont disponibles :
  SUSE LE 12 SP4 : compat-openssl098 0.9.8j-106.15.1
  SUSE LE 12 SP3 : compat-openssl098 0.9.8j-106.15.1
  SUSE LE 12 SP2 : compat-openssl098 0.9.8j-106.15.1
  SUSE LE 12 SP1 : compat-openssl098 0.9.8j-106.15.1

SUSE LE 12 SP1 : nouveaux paquetages openssl.
De nouveaux paquetages sont disponibles :
  SUSE LE 12 SP1 : openssl 1.0.1i-54.29.1

SUSE LE 12 SP2, SP3 : nouveaux paquetages openssl.
De nouveaux paquetages sont disponibles :
  SUSE LE 12 SP2 : openssl 1.0.2j-60.55.1
  SUSE LE 12 SP3 : openssl 1.0.2j-60.55.1

SUSE LE 12 SP4/5 : nouveaux paquetages openssl-1_1.
De nouveaux paquetages sont disponibles :
  SUSE LE 12 SP4 : openssl-1_1 1.1.1d-2.20.1
  SUSE LE 12 SP5 : openssl-1_1 1.1.1d-2.20.1

SUSE LE 12 SP4 : nouveaux paquetages openssl-1_0_0.
De nouveaux paquetages sont disponibles :
  SUSE LE 12 SP4 : openssl-1_0_0 1.0.2p-3.11.1

SUSE LE 15 : nouveaux paquetages openssl-1_0_0.
De nouveaux paquetages sont disponibles :
  SUSE LE 15 RTM : openssl-1_0_0 1.0.2p-3.22.1
  SUSE LE 15 SP1 : openssl-1_0_0 1.0.2p-3.22.1

SUSE LE 15 RTM : nouveaux paquetages openssl-1_1.
De nouveaux paquetages sont disponibles :
  SUSE LE 15 RTM : openssl-1_1 1.1.0i-4.24.1

SUSE LE 15 SP1 : nouveaux paquetages openssl-1_1.
De nouveaux paquetages sont disponibles :
  SUSE LE 15 SP1 : openssl-1_1 1.1.0i-14.3.1

Wind River Linux : version 10.18.44.11.
La version 10.18.44.11 est corrigée :
  https://support2.windriver.com/

WinSCP : version 5.15.4.
La version 5.15.4 est corrigée :
  https://sourceforge.net/projects/winscp/files/WinSCP/5.15.4/

X2Go Client for Windows : version 4.1.2.2-2020.02.13.
La version 4.1.2.2-2020.02.13 est corrigée :
  http://wiki.x2go.org/doku.php/doc:release-notes-mswin:x2goclient-4.1.2.2
Bulletin complet, filtrage par logiciel, emails, correctifs, ... (Demandez votre essai gratuit)

Service de veille sur les vulnérabilités informatiques 

Vigil@nce fournit des avis cyber-sécurité. La base de vulnérabilités Vigil@nce contient plusieurs milliers de failles.