L'équipe Vigil@nce veille les vulnérabilités publiques qui affectent votre parc informatique, puis propose des correctifs sécurité, une base de données de vigilance et des outils pour y remédier.

Vulnérabilité de OpenSSL : obtention d'information via SSL_read/SSL_write After Error

Synthèse de la vulnérabilité 

Un attaquant peut contourner les restrictions d'accès aux données via SSL_read/SSL_write After Error de OpenSSL, afin d'obtenir des informations sensibles.
Logiciels vulnérables : ProxySG par Blue Coat, SGOS par Blue Coat, ProxySG par Symantec, SGOS par Symantec, Debian, Unisphere EMC, FreeBSD, hMailServer, AIX, Db2 UDB, QRadar SIEM, Tivoli Storage Manager, Juniper J-Series, Junos OS, Junos Space, NSM Central Manager, NSMXpress, SRX-Series, MariaDB ~ précis, MySQL Community, MySQL Enterprise, OpenSSL, openSUSE Leap, Oracle Communications, Oracle Fusion Middleware, Solaris, Tuxedo, VirtualBox, WebLogic, Percona Server, pfSense, RHEL, SIMATIC, Slackware, Synology DSM, Synology DS***, Synology RS***, Ubuntu, WinSCP, X2GoClient.
Gravité de cette annonce : 1/4.
Date de création : 07/12/2017.
Références de cette vulnérabilité informatique : 2014324, bulletinapr2018, bulletinjan2018, CERTFR-2017-AVI-452, CERTFR-2018-AVI-376, cpuapr2018, cpujan2018, cpujul2018, cpujul2019, CVE-2017-3737, DSA-2020-062, DSA-4065-1, FreeBSD-SA-17:12.openssl, ibm10715641, ibm10716907, ibm10717405, ibm10717409, ibm10719113, ibm10738249, JSA10851, JSA10873, openSUSE-SU-2017:3345-1, openSUSE-SU-2018:0223-1, openSUSE-SU-2018:1057-1, RHSA-2018:0998-01, SA159, SSA-179516, SSA:2017-342-01, swg21647054, USN-3512-1, VIGILANCE-VUL-24697.

Description de la vulnérabilité 

Un attaquant peut contourner les restrictions d'accès aux données via SSL_read/SSL_write After Error de OpenSSL, afin d'obtenir des informations sensibles.
Bulletin complet, filtrage par logiciel, emails, correctifs, ... (Demandez votre essai gratuit)

Cette vulnérabilité informatique concerne les logiciels ou systèmes comme ProxySG par Blue Coat, SGOS par Blue Coat, ProxySG par Symantec, SGOS par Symantec, Debian, Unisphere EMC, FreeBSD, hMailServer, AIX, Db2 UDB, QRadar SIEM, Tivoli Storage Manager, Juniper J-Series, Junos OS, Junos Space, NSM Central Manager, NSMXpress, SRX-Series, MariaDB ~ précis, MySQL Community, MySQL Enterprise, OpenSSL, openSUSE Leap, Oracle Communications, Oracle Fusion Middleware, Solaris, Tuxedo, VirtualBox, WebLogic, Percona Server, pfSense, RHEL, SIMATIC, Slackware, Synology DSM, Synology DS***, Synology RS***, Ubuntu, WinSCP, X2GoClient.

Notre équipe Vigil@nce a déterminé que la gravité de cette annonce cybersécurité est faible.

Le niveau de confiance est de type confirmé par l'éditeur, avec une provenance de client internet.

Un attaquant avec un niveau de compétence expert peut exploiter cette annonce de menace.

Solutions pour cette menace 

OpenSSL : version 1.0.2n.
La version 1.0.2n est corrigée :
  https://www.openssl.org/

Debian 9 : nouveaux paquetages openssl1.0.
De nouveaux paquetages sont disponibles :
  Debian 9 : openssl1.0 1.0.2l-2+deb9u2

Dell EMC Unisphere for PowerMax : solution.
La solution est indiquée dans les sources d'information.

FreeBSD : patch pour OpenSSL.
Un patch est disponible :
  https://security.FreeBSD.org/patches/SA-17:12/openssl-10.patch
  https://security.FreeBSD.org/patches/SA-17:12/openssl-11.patch

hMailServer : version 5.6.7.
La version 5.6.7 est corrigée :
  https://www.hmailserver.com/download_getfile/?performdownload=1&downloadid=262

IBM AIX : patch pour OpenSSL.
Un patch est disponible :
  https://aix.software.ibm.com/aix/efixes/security/openssl_fix25.tar

IBM Cognos Analytics : version 11.0.13.0.
La version 11.0.13.0 est corrigée :
  https://www-01.ibm.com/support/docview.wss?uid=ibm10718809

IBM Cognos Business Intelligence : patch.
Un patch est indiqué dans les sources d'information.

IBM DB2 : solution pour OpenSSL.
La solution est indiquée dans les sources d'information.

IBM DB2 : version 10.5 Fix Pack 10.
La version 10.5 Fix Pack 10 est corrigée :
  http://www-01.ibm.com/support/docview.wss?uid=swg24045012

IBM QRadar SIEM : patch pour OpenSSL.
Un patch est indiqué dans les sources d'information.

IBM Spectrum Protect : solution pour OpenSSL.
La solution est indiquée dans les sources d'information.

IBM Tivoli Storage Manager : patch pour OpenSSL.
Un patch est indiqué dans les sources d'information.

Junos, NSM : solution pour OpenSSL.
La solution est indiquée dans les sources d'information.

Junos Space : solution.
La solution est indiquée dans les sources d'information.

MariaDB : version 10.0.34.
La version 10.0.34 est corrigée :
  https://mariadb.com/downloads/mariadb-tx

MySQL : version 5.5.59.
La version 5.5.59 est corrigée :
  https://support.oracle.com/rs?type=doc&id=2336646.1
  https://dev.mysql.com/downloads/mysql/

MySQL : version 5.6.39.
La version 5.6.39 est corrigée :
  https://support.oracle.com/rs?type=doc&id=2336646.1
  https://dev.mysql.com/downloads/mysql/

MySQL : version 5.7.21.
La version 5.7.21 est corrigée :
  https://support.oracle.com/rs?type=doc&id=2336646.1
  https://dev.mysql.com/downloads/mysql/

openSUSE Leap 42.3 : nouveaux paquetages virtualbox.
De nouveaux paquetages sont disponibles :
  openSUSE Leap 42.3 : virtualbox 5.1.36-50.1

openSUSE Leap : nouveaux paquetages mysql-community-server.
De nouveaux paquetages sont disponibles :
  openSUSE Leap 42.3 : mysql-community-server 5.6.39-33.1
  openSUSE Leap 42.2 : mysql-community-server 5.6.39-24.15.1

openSUSE Leap : nouveaux paquetages openssl.
De nouveaux paquetages sont disponibles :
  openSUSE Leap 42.2 : openssl 1.0.2j-6.9.1
  openSUSE Leap 42.3 : openssl 1.0.2j-16.1

Oracle Communications : CPU de juillet 2019.
Un Critical Patch Update est disponible :
  https://support.oracle.com/rs?type=doc&id=2559239.1
  https://support.oracle.com/rs?type=doc&id=2563691.1
  https://support.oracle.com/rs?type=doc&id=2559240.1
  https://support.oracle.com/rs?type=doc&id=2559722.1
  https://support.oracle.com/rs?type=doc&id=2559225.1
  https://support.oracle.com/rs?type=doc&id=2559721.1
  https://support.oracle.com/rs?type=doc&id=2559256.1
  https://support.oracle.com/rs?type=doc&id=2559242.1
  https://support.oracle.com/rs?type=doc&id=2559243.1
  https://support.oracle.com/rs?type=doc&id=2559648.1

Oracle Fusion Middleware : CPU de avril 2018.
Un Critical Patch Update est disponible :
  https://support.oracle.com/rs?type=doc&id=2353306.1

Oracle MySQL : version 5.5.60.
La version 5.5.60 est corrigée :
  https://support.oracle.com/rs?type=doc&id=2375344.1
  https://dev.mysql.com/downloads/mysql/

Oracle MySQL : version 5.5.61.
La version 5.5.61 est corrigée :
  https://support.oracle.com/rs?type=doc&id=2417138.1
  https://dev.mysql.com/downloads/mysql/

Oracle MySQL : version 5.6.40.
La version 5.6.40 est corrigée :
  https://support.oracle.com/rs?type=doc&id=2375344.1
  https://dev.mysql.com/downloads/mysql/

Oracle MySQL : version 5.6.41.
La version 5.6.41 est corrigée :
  https://support.oracle.com/rs?type=doc&id=2417138.1
  https://dev.mysql.com/downloads/mysql/

Oracle MySQL : version 5.7.22.
La version 5.7.22 est corrigée :
  https://support.oracle.com/rs?type=doc&id=2375344.1
  https://dev.mysql.com/downloads/mysql/

Oracle MySQL : version 5.7.23.
La version 5.7.23 est corrigée :
  https://support.oracle.com/rs?type=doc&id=2417138.1
  https://dev.mysql.com/downloads/mysql/

Oracle MySQL : version 8.0.12.
La version 8.0.12 est corrigée :
  https://support.oracle.com/rs?type=doc&id=2417138.1
  https://dev.mysql.com/downloads/mysql/

Oracle Solaris : patch pour logiciels tiers de avril 2018 v1.
Un patch est disponible :
  https://support.oracle.com/rs?type=doc&id=1448883.1

Oracle Solaris : patch pour logiciels tiers de janvier 2018 v1.
Un patch est disponible :
  https://support.oracle.com/rs?type=doc&id=1448883.1

Oracle VM VirtualBox : version 5.1.36.
La version 5.1.36 est corrigée :
  https://www.virtualbox.org/

Oracle VM VirtualBox : version 5.2.10.
La version 5.2.10 est corrigée :
  https://www.virtualbox.org/

Percona Server for MySQL : version 5.5.59-38.11.
La version 5.5.59-38.11 est corrigée :
  https://www.percona.com/

Percona Server for MySQL : version 5.5.60-38.12.
La version 5.5.60-38.12 est corrigée :
  https://www.percona.com/

Percona Server for MySQL : versions 5.6.39-83.1 et 5.7.21-20.
Les versions 5.6.39-83.1 et 5.7.21-20 sont corrigées.

Percona Server : version 5.7.22-22.
La version 5.7.22-22 est corrigée :
  https://www.percona.com/doc/percona-server/5.7/installation.html

Percona XtraDB Cluster : version 5.7.22-29.26.
La version 5.7.22-29.26 est corrigée :
  http://www.percona.com/downloads/Percona-XtraDB-Cluster-57/

pfSense : version 2.3.5-p1.
La version 2.3.5-p1 est corrigée :
  https://www.pfsense.org/download/

pfSense : version 2.4.2-p1.
La version 2.4.2-p1 est corrigée :
  https://www.pfsense.org/download/

ProxySG : solution pour OpenSSL.
La solution est indiquée dans les sources d'information.

RHEL 7 : nouveaux paquetages openssl.
De nouveaux paquetages sont disponibles :
  RHEL 7 : openssl 1.0.2k-12.el7

Siemens SIMATIC : versions corrigées pour OpenSSL.
Les versions corrigées sont indiquées dans les sources d'information.

Slackware : nouveaux paquetages openssl.
De nouveaux paquetages sont disponibles :
  Slackware 13.0 : openssl 0.9.8zh-*-2_slack13.0
  Slackware 13.1 : openssl 0.9.8zh-*-2_slack13.1
  Slackware 13.37 : openssl 0.9.8zh-*-2_slack13.37
  Slackware 14.0 : openssl 1.0.1u-*-1_slack14.0
  Slackware 14.1 : openssl 1.0.1u-*-1_slack14.1
  Slackware 14.2 : openssl 1.0.2n-*-1_slack14.2

Synology DS/RS : version 6.1.4-15217-3.
La version 6.1.4-15217-3 est corrigée :
  https://www.synology.com/

Ubuntu : nouveaux paquetages libssl1.0.0.
De nouveaux paquetages sont disponibles :
  Ubuntu 17.10 : libssl1.0.0 1.0.2g-1ubuntu13.3
  Ubuntu 17.04 : libssl1.0.0 1.0.2g-1ubuntu11.4
  Ubuntu 16.04 LTS : libssl1.0.0 1.0.2g-1ubuntu4.10

WinSCP : version 5.11.3.
La version 5.11.3 est corrigée :
  https://sourceforge.net/p/winscp/

X2Go Client : version 4.1.2.0.
La version 4.1.2.0 est corrigée :
  https://wiki.x2go.org/doku.php
Bulletin complet, filtrage par logiciel, emails, correctifs, ... (Demandez votre essai gratuit)

Service de veille sur les vulnérabilités informatiques 

Vigil@nce fournit une alerte de vulnérabilité informatique. L'équipe Vigil@nce surveille les vulnérabilités informatiques de systèmes et d'applications.