L'équipe Vigil@nce veille les vulnérabilités publiques qui affectent votre parc informatique, puis propose des correctifs sécurité, une base de données de vigilance et des outils pour y remédier.

Vulnérabilité de OpenSSL : obtention d'information via Side-channel Based Padding

Synthèse de la vulnérabilité 

Un attaquant peut contourner les restrictions d'accès aux données via Side-channel Based Padding de OpenSSL, afin d'obtenir des informations sensibles.
Systèmes vulnérables : Nodejs Core, OpenSSL, openSUSE Leap, SUSE Linux Enterprise Desktop, SLES, X2GoClient.
Gravité de cette menace : 1/4.
Date de création : 02/05/2019.
Références de cette faille : 1117951, 7739, openSUSE-SU-2019:1373-1, SUSE-SU-2019:1124-1, SUSE-SU-2019:1136-1, SUSE-SU-2019:1141-1, SUSE-SU-2020:0516-1, SUSE-SU-2020:0576-1, SUSE-SU-2020:14291-1, SUSE-SU-2020:14295-1, VIGILANCE-VUL-29174.

Description de la vulnérabilité 

Un attaquant peut contourner les restrictions d'accès aux données via Side-channel Based Padding de OpenSSL, afin d'obtenir des informations sensibles.
Bulletin complet, filtrage par logiciel, emails, correctifs, ... (Demandez votre essai gratuit)

Cette annonce de menace informatique concerne les logiciels ou systèmes comme Nodejs Core, OpenSSL, openSUSE Leap, SUSE Linux Enterprise Desktop, SLES, X2GoClient.

Notre équipe Vigil@nce a déterminé que la gravité de cet avis de menace informatique est faible.

Le niveau de confiance est de type confirmé par l'éditeur, avec une provenance de client internet.

Un attaquant avec un niveau de compétence expert peut exploiter cette alerte de vulnérabilité informatique.

Solutions pour cette menace 

OpenSSL : version 1.1.1b.
La version 1.1.1b est corrigée :
  https://www.openssl.org/

OpenSSL 1.1.0 : patch pour Side-channel Based Padding.
Un patch est indiqué dans les sources d'information.

OpenSSL : version 1.0.2r.
La version 1.0.2r est corrigée :
  https://www.openssl.org/

Node Core : version 10.16.0.
La version 10.16.0 est corrigée :
  https://nodejs.org/en/download/

openSUSE Leap 42.3 : nouveaux paquetages openssl.
De nouveaux paquetages sont disponibles :
  openSUSE Leap 42.3 : openssl 1.0.2j-38.1

SUSE LE 11 : nouveaux paquetages openssl1.
De nouveaux paquetages sont disponibles :
  SUSE LE 11 RTM-SP4 : openssl1 1.0.1g-0.58.24.1

SUSE LE 11 SP3/4 : nouveaux paquetages openssl.
De nouveaux paquetages sont disponibles :
  SUSE LE 11 SP3 : openssl 0.9.8j-0.106.31.1
  SUSE LE 11 SP4 : openssl 0.9.8j-0.106.31.1

SUSE LE 12 : nouveaux paquetages compat-openssl098.
De nouveaux paquetages sont disponibles :
  SUSE LE 12 SP1 : compat-openssl098 0.9.8j-106.18.1
  SUSE LE 12 SP2 : compat-openssl098 0.9.8j-106.18.1
  SUSE LE 12 SP3 : compat-openssl098 0.9.8j-106.18.1
  SUSE LE 12 SP4 : compat-openssl098 0.9.8j-106.18.1
  SUSE LE 12 SP5 : compat-openssl098 0.9.8j-106.18.1

SUSE LE 12 : nouveaux paquetages openssl.
De nouveaux paquetages sont disponibles :
  SUSE LE 12 SP1 : openssl 1.0.1i-54.23.1
  SUSE LE 12 SP2 : openssl 1.0.2j-60.52.1
  SUSE LE 12 SP3 : openssl 1.0.2j-60.52.1
  SUSE LE 12 SP4 : openssl 1_1-1.1.1b-2.12.2

SUSE LE 12 SP1 : nouveaux paquetages openssl.
De nouveaux paquetages sont disponibles :
  SUSE LE 12 SP1 : openssl 1.0.1i-54.32.1

X2Go Client for Windows : version 4.1.2.2-2020.02.13.
La version 4.1.2.2-2020.02.13 est corrigée :
  http://wiki.x2go.org/doku.php/doc:release-notes-mswin:x2goclient-4.1.2.2
Bulletin complet, filtrage par logiciel, emails, correctifs, ... (Demandez votre essai gratuit)

Service de veille sur les vulnérabilités informatiques 

Vigil@nce fournit un bulletin de vulnérabilités informatiques. Chaque administrateur peut personnaliser la liste des produits pour lesquels il souhaite recevoir des alertes de vulnérabilités.