L'équipe Vigil@nce veille les vulnérabilités publiques qui affectent votre parc informatique, puis propose des correctifs sécurité, une base de données de vigilance et des outils pour y remédier.

Vulnérabilité de OpenSSL : signature ECDSA en temps non constant

Synthèse de la vulnérabilité 

Un attaquant peut chronométrer un processus en cours de signature DSA avec OpenSSL, afin de potentiellement obtenir des informations sur la clé secrète.
Logiciels impactés : Mac OS X, Debian, VNX Operating Environment, VNX Series, BIG-IP Hardware, TMOS, Android OS, OpenBSD, OpenSSL, openSUSE Leap, SUSE Linux Enterprise Desktop, SLES, Ubuntu.
Gravité de cette vulnérabilité informatique : 2/4.
Date de création : 11/01/2017.
Références de cette annonce : CVE-2016-7056, DLA-814-1, DSA-2019-197, DSA-2020-030, DSA-3773-1, HT207615, K32743437, openSUSE-SU-2017:0409-1, openSUSE-SU-2017:0487-1, openSUSE-SU-2017:1211-1, openSUSE-SU-2017:1212-1, openSUSE-SU-2018:0458-1, SUSE-SU-2018:0112-1, USN-3181-1, VIGILANCE-VUL-21550.

Description de la vulnérabilité 

Un attaquant peut donc chronométrer un processus en cours de signature ECDSA avec OpenSSL, afin de potentiellement obtenir des informations sur la clé secrète.

Cette vulnérabilité est la même que celle décrite dans VIGILANCE-VUL-19820 mais cette fois pour la variante de DSA basée sur les courbes elliptiques.
Bulletin complet, filtrage par logiciel, emails, correctifs, ... (Demandez votre essai gratuit)

Cette annonce de faille informatique concerne les logiciels ou systèmes comme Mac OS X, Debian, VNX Operating Environment, VNX Series, BIG-IP Hardware, TMOS, Android OS, OpenBSD, OpenSSL, openSUSE Leap, SUSE Linux Enterprise Desktop, SLES, Ubuntu.

Notre équipe Vigil@nce a déterminé que la gravité de cette annonce de vulnérabilité informatique est moyen.

Le niveau de confiance est de type confirmé par l'éditeur, avec une provenance de shell utilisateur.

Un attaquant avec un niveau de compétence expert peut exploiter ce bulletin de faille informatique.

Solutions pour cette menace 

OpenSSL : patch pour ECDSA.
Un patch est disponible en annexe de l'article détaillant l'analyse :
  http://eprint.iacr.org/eprint-bin/getfile.pl?entry=2016/1195&version=20170101:154002&file=1195.pdf

Android OS : patch 2017-05-01 et 2017-05-05.
Un patch est indiqué dans les sources d'information.

Apple Mac OS X : version 10.12.4.
La version 10.12.4 est corrigée.

Debian : nouveaux paquetages openssl.
De nouveaux paquetages sont disponibles :
  Debian 7 : openssl 1.0.1t-1+deb7u2
  Debian 8 : openssl 1.0.1t-1+deb8u6

Dell EMC VNXe3200 : version 3.1.11.10003441.
La version 3.1.11.10003441 est corrigée :
  https://www.dell.com/support/

Dell EMC VNXe : version MR4 Service Pack 5.
La version MR4 Service Pack 5 est corrigée :
  https://www.dell.com/support/
Ce bulletin corrige plus de 100 vulnérabilités, mais uniquement les 100 dernières ont été liées à ce bulletin.

F5 BIG-IP : solution pour OpenSSL.
La solution est indiquée dans les sources d'information.

OpenBSD : patch pour ECDSA.
Un patch est indiqué dans les sources d'information.

openSUSE Leap 42.1 : nouveaux paquetages openssl.
De nouveaux paquetages sont disponibles :
  openSUSE Leap 42.1 : openssl 1.0.1i-21.1

openSUSE Leap 42 : nouveaux paquetages libressl.
De nouveaux paquetages sont disponibles :
  openSUSE Leap 42.1 : libressl 2.5.3-13.1
  openSUSE Leap 42.2 : libressl 2.5.3-5.3.1

openSUSE Leap : nouveaux paquetages libressl.
De nouveaux paquetages sont disponibles :
  openSUSE Leap 42.1 : libressl 2.3.0-10.1
  openSUSE Leap 42.2 : libressl 2.3.4-3.1

openSUSE Leap : nouveaux paquetages openssl-steam.
De nouveaux paquetages sont disponibles :
  openSUSE Leap 42.3 : libopenssl1_0_0-steam 1.0.2k-4.3.1

SUSE LE 12 RTM : nouveaux paquetages openssl (17/01/2018).
De nouveaux paquetages sont disponibles :
  SUSE LE 12 RTM : openssl 1.0.1i-27.28.1

Ubuntu : nouveaux paquetages libssl1.0.0.
De nouveaux paquetages sont disponibles :
  Ubuntu 16.10 : libssl1.0.0 1.0.2g-1ubuntu9.1
  Ubuntu 16.04 LTS : libssl1.0.0 1.0.2g-1ubuntu4.6
  Ubuntu 14.04 LTS : libssl1.0.0 1.0.1f-1ubuntu2.22
  Ubuntu 12.04 LTS : libssl1.0.0 1.0.1-4ubuntu5.39
Bulletin complet, filtrage par logiciel, emails, correctifs, ... (Demandez votre essai gratuit)

Service de veille sur les vulnérabilités informatiques 

Vigil@nce fournit des avis de vulnérabilité de logiciel. La base de vulnérabilités Vigil@nce contient plusieurs milliers de failles.