L'équipe Vigil@nce veille les vulnérabilités publiques qui affectent votre parc informatique, puis propose des correctifs sécurité, une base de données de vigilance et des outils pour y remédier.

Vulnérabilité de Oracle MySQL : vulnérabilités de janvier 2017

Synthèse de la vulnérabilité 

Un attaquant peut employer plusieurs vulnérabilités de Oracle MySQL.
Produits vulnérables : Debian, Fedora, MariaDB ~ précis, MySQL Community, MySQL Enterprise, openSUSE Leap, Solaris, Percona Server, RHEL, Slackware, SUSE Linux Enterprise Desktop, SLES, Ubuntu.
Gravité de cette faille : 3/4.
Nombre de vulnérabilités dans ce bulletin : 22.
Date de création : 18/01/2017.
Références de ce bulletin : bulletinapr2017, CERTFR-2017-AVI-018, cpujan2017, CVE-2016-5541, CVE-2016-8318, CVE-2016-8327, CVE-2017-3238, CVE-2017-3243, CVE-2017-3244, CVE-2017-3251, CVE-2017-3256, CVE-2017-3257, CVE-2017-3258, CVE-2017-3265, CVE-2017-3273, CVE-2017-3291, CVE-2017-3312, CVE-2017-3313, CVE-2017-3317, CVE-2017-3318, CVE-2017-3319, CVE-2017-3320, CVE-2017-3321, CVE-2017-3322, CVE-2017-3323, DLA-797-1, DSA-3767-1, DSA-3770-1, DSA-3809-1, FEDORA-2017-09dd8907da, FEDORA-2017-0f44f2b8c8, FEDORA-2017-2c0609b92a, FEDORA-2017-801e01d1ed, FEDORA-2017-8425f676f2, openSUSE-SU-2017:0479-1, openSUSE-SU-2017:0486-1, openSUSE-SU-2017:0618-1, openSUSE-SU-2017:1475-1, RHSA-2017:2192-01, RHSA-2017:2787-01, RHSA-2017:2886-01, RHSA-2018:0574-01, SSA:2017-018-01, SSA:2017-087-01, SUSE-SU-2017:0408-1, SUSE-SU-2017:0411-1, SUSE-SU-2017:0412-1, SUSE-SU-2017:1311-1, SUSE-SU-2017:1315-1, USN-3174-1, VIGILANCE-VUL-21612.

Description de la vulnérabilité 

Un attaquant peut employer plusieurs vulnérabilités de Oracle MySQL.

Un attaquant peut employer une vulnérabilité via Server: Security: Encryption, afin de mener un déni de service. [grav:3/4; CVE-2016-8318]

Un attaquant peut employer une vulnérabilité via Server: Packaging, afin d'obtenir des informations, d'altérer des informations, ou de mener un déni de service. [grav:3/4; CVE-2017-3312]

Un attaquant peut employer une vulnérabilité via Server: DDL, afin de mener un déni de service. [grav:2/4; CVE-2017-3258]

Un attaquant peut employer une vulnérabilité via Server: DDL, afin de mener un déni de service. [grav:2/4; CVE-2017-3273]

Un attaquant peut employer une vulnérabilité via Server: DML, afin de mener un déni de service. [grav:2/4; CVE-2017-3244]

Un attaquant peut employer une vulnérabilité via Server: InnoDB, afin de mener un déni de service. [grav:2/4; CVE-2017-3257]

Un attaquant peut employer une vulnérabilité via Server: Optimizer, afin de mener un déni de service. [grav:2/4; CVE-2017-3238]

Un attaquant peut employer une vulnérabilité via Server: Replication, afin de mener un déni de service. [grav:2/4; CVE-2017-3256]

Un attaquant peut employer une vulnérabilité via Server: Packaging, afin d'obtenir des informations, d'altérer des informations, ou de mener un déni de service. [grav:2/4; CVE-2017-3291]

Un attaquant peut employer une vulnérabilité via Server: Packaging, afin d'obtenir des informations, ou de mener un déni de service. [grav:2/4; CVE-2017-3265]

Un attaquant peut employer une vulnérabilité via Server: Optimizer, afin de mener un déni de service. [grav:2/4; CVE-2017-3251]

Un attaquant peut employer une vulnérabilité via Cluster: NDBAPI, afin d'altérer des informations, ou de mener un déni de service. [grav:2/4; CVE-2016-5541]

Un attaquant peut employer une vulnérabilité via Server: Charsets, afin de mener un déni de service. [grav:2/4; CVE-2017-3313]

Un attaquant peut employer une vulnérabilité via Server: Charsets, afin de mener un déni de service. [grav:2/4; CVE-2017-3243]

Un attaquant peut employer une vulnérabilité via Server: Replication, afin de mener un déni de service. [grav:2/4; CVE-2016-8327]

Un attaquant peut employer une vulnérabilité via Logging, afin de mener un déni de service. [grav:2/4; CVE-2017-3317]

Un attaquant peut employer une vulnérabilité via Server: Error Handling, afin d'obtenir des informations. [grav:2/4; CVE-2017-3318]

Un attaquant peut employer une vulnérabilité via Cluster: General, afin de mener un déni de service. [grav:2/4; CVE-2017-3321]

Un attaquant peut employer une vulnérabilité via Cluster: General, afin de mener un déni de service. [grav:2/4; CVE-2017-3323]

Un attaquant peut employer une vulnérabilité via Cluster: NDBAPI, afin de mener un déni de service. [grav:2/4; CVE-2017-3322]

Un attaquant peut employer une vulnérabilité via Server: X Plugin, afin d'obtenir des informations. [grav:1/4; CVE-2017-3319]

Un attaquant peut employer une vulnérabilité via Server: Security: Encryption, afin d'obtenir des informations. [grav:1/4; CVE-2017-3320]
Bulletin complet, filtrage par logiciel, emails, correctifs, ... (Demandez votre essai gratuit)

Cette faille concerne les logiciels ou systèmes comme Debian, Fedora, MariaDB ~ précis, MySQL Community, MySQL Enterprise, openSUSE Leap, Solaris, Percona Server, RHEL, Slackware, SUSE Linux Enterprise Desktop, SLES, Ubuntu.

Notre équipe Vigil@nce a déterminé que la gravité de cette vulnérabilité cyber-sécurité est important.

Le niveau de confiance est de type confirmé par l'éditeur, avec une provenance de client intranet.

Ce bulletin concerne 22 vulnérabilités.

Un attaquant avec un niveau de compétence expert peut exploiter cette alerte cybersécurité.

Solutions pour cette menace 

Oracle MySQL : version 5.7.17.
La version 5.7.17 est corrigée :
  https://support.oracle.com/rs?type=doc&id=2219938.1

Oracle MySQL : version 5.6.35.
La version 5.6.35 est corrigée :
  https://support.oracle.com/rs?type=doc&id=2219938.1

Oracle MySQL : version 5.5.54.
La version 5.5.54 est corrigée :
  https://support.oracle.com/rs?type=doc&id=2219938.1

MariaDB : version 10.1.22.
La version 10.1.22 est corrigée :
  http://downloads.mariadb.org/mariadb/10.1.22

MariaDB : version 10.0.30.
La version 10.0.30 est corrigée :
  http://downloads.mariadb.org/mariadb/10.0.30

Percona Server for MySQL : version 5.7.17-11.
La version 5.7.17-11 est corrigée :
  https://www.percona.com/

Percona Server : version 5.6.35-80.0.
La version 5.6.35-80.0 est corrigée :
  https://www.percona.com/

Percona Server for MySQL : version 5.5.54-38.6.
La version 5.5.54-38.6 est corrigée :
  https://www.percona.com/

Debian 8 : nouveaux paquetages mariadb-10.0 (15/03/2017).
De nouveaux paquetages sont disponibles :
  Debian 8 : mariadb-10.0 10.0.30-0+deb8u1

Debian 8 : nouveaux paquetages mariadb-10.0 (23/01/2017).
De nouveaux paquetages sont disponibles :
  Debian 8 : mariadb-10.0 10.0.29-0+deb8u1

Debian : nouveaux paquetages mysql-5.5.
De nouveaux paquetages sont disponibles :
  Debian 7 : mysql-5.5 5.5.54-0+deb7u1
  Debian 8 : mysql-5.5 5.5.54-0+deb8u1

Fedora : nouveaux paquetages mariadb.
De nouveaux paquetages sont disponibles :
  Fedora 24 : mariadb 10.1.24-3.fc24
  Fedora 25 : mariadb 10.1.24-3.fc25
  Fedora 26 : mariadb 10.1.24-3.fc26

MariaDB : version 5.5.55.
La version 5.5.55 est corrigée :
  https://mariadb.com/

openSUSE Leap 42.2 : nouveaux paquetages mariadb.
De nouveaux paquetages sont disponibles :
  openSUSE Leap 42.2 : libmysqlclient18 10.0.30-20.4.1, mariadb 10.0.30-20.4.1

openSUSE Leap 42 : nouveaux paquetages mysql-community-server.
De nouveaux paquetages sont disponibles :
  openSUSE Leap 42.1 : mysql-community-server 5.6.35-22.1
  openSUSE Leap 42.2 : mysql-community-server 5.6.35-22.1

openSUSE Leap : nouveaux paquetages mariadb.
De nouveaux paquetages sont disponibles :
  openSUSE Leap 42.1 : mariadb 10.0.29-18.1
  openSUSE Leap 42.2 : mariadb 10.0.29-18.1

Oracle Solaris : patch pour logiciels tiers de avril 2017 v1.
Un patch est disponible :
  https://support.oracle.com/rs?type=doc&id=1448883.1

RHEL 7 : nouveaux paquetages mariadb (02/08/2017).
De nouveaux paquetages sont disponibles :
  RHEL 7 : mariadb 5.5.56-2.el7

RHEL : nouveaux paquetages rh-mariadb101-mariadb.
De nouveaux paquetages sont disponibles :
  RHEL 6 : rh-mariadb101-mariadb 10.1.29-3.el6
  RHEL 7 : rh-mariadb101-mariadb 10.1.29-3.el7

RHEL : nouveaux paquetages rh-mysql56-mysql.
De nouveaux paquetages sont disponibles :
  RHEL 6 : rh-mysql56-mysql 5.6.37-5.el6
  RHEL 7 : rh-mysql56-mysql 5.6.37-5.el7

RHEL : nouveaux paquetages rh-mysql57-mysql.
De nouveaux paquetages sont disponibles :
  RHEL 6 : rh-mysql57-mysql 5.7.19-6.el6
  RHEL 7 : rh-mysql57-mysql 5.7.19-6.el7

Slackware : nouveaux paquetages mariadb (19/01/2017).
De nouveaux paquetages sont disponibles :
  Slackware 14.1 : mariadb 5.5.54-*-1_slack14.1
  Slackware 14.2 : mariadb 10.0.29-*-1_slack14.2

Slackware : nouveaux paquetages mariadb (29/03/2017).
De nouveaux paquetages sont disponibles :
  Slackware 14.2 : mariadb 10.0.30-*-1_slack14.2

SUSE LE 11 : nouveaux paquetages mysql.
De nouveaux paquetages sont disponibles :
  SUSE LE 11 SP4 : mysql 5.5.54-0.35.1

SUSE LE 12 : nouveaux paquetages mariadb (08/02/2017).
De nouveaux paquetages sont disponibles :
  SUSE LE 12 RTM : mariadb 10.0.29-20.23.1
  SUSE LE 12 SP1 : mariadb 10.0.29-22.1
  SUSE LE 12 SP2 : mariadb 10.0.29-22.1

SUSE LE 12 : nouveaux paquetages mariadb (17/05/2017).
De nouveaux paquetages sont disponibles
  SUSE LE 12 RTM : mariadb 10.0.30-20.26.1
  SUSE LE 12 SP1 : mariadb 10.0.30-25.1
  SUSE LE 12 SP2 : mariadb 10.0.30-25.1

Ubuntu : nouveaux paquetages mysql-server-5.x.
De nouveaux paquetages sont disponibles :
  Ubuntu 16.10 : mysql-server-5.7 5.7.17-0ubuntu0.16.10.1
  Ubuntu 16.04 LTS : mysql-server-5.7 5.7.17-0ubuntu0.16.04.1
  Ubuntu 14.04 LTS : mysql-server-5.5 5.5.54-0ubuntu0.14.04.1
  Ubuntu 12.04 LTS : mysql-server-5.5 5.5.54-0ubuntu0.12.04.1
Bulletin complet, filtrage par logiciel, emails, correctifs, ... (Demandez votre essai gratuit)

Service de veille sur les vulnérabilités informatiques 

Vigil@nce fournit des avis de vulnérabilité informatique. La base de vulnérabilités Vigil@nce contient plusieurs milliers de failles.