L'équipe Vigil@nce veille les vulnérabilités publiques qui affectent votre parc informatique, puis propose des correctifs sécurité, une base de données de vigilance et des outils pour y remédier.

Vulnérabilité de Oracle MySQL : vulnérabilités de octobre 2019

Synthèse de la vulnérabilité 

Plusieurs vulnérabilités ont été annoncées dans les produits Oracle.
Produits vulnérables : Fedora, IBM API Connect, MariaDB ~ précis, MySQL Community, MySQL Enterprise, SnapCenter Backup Management, openSUSE Leap, Solaris, Percona Server, RHEL, SUSE Linux Enterprise Desktop, SLES, Ubuntu.
Gravité de cette faille : 3/4.
Nombre de vulnérabilités dans ce bulletin : 28.
Date de création : 16/10/2019.
Références de ce bulletin : 1172926, CERTFR-2019-AVI-509, cpuoct2019, CVE-2019-2910, CVE-2019-2911, CVE-2019-2914, CVE-2019-2922, CVE-2019-2923, CVE-2019-2924, CVE-2019-2938, CVE-2019-2946, CVE-2019-2948, CVE-2019-2950, CVE-2019-2957, CVE-2019-2960, CVE-2019-2963, CVE-2019-2966, CVE-2019-2967, CVE-2019-2968, CVE-2019-2969, CVE-2019-2974, CVE-2019-2982, CVE-2019-2991, CVE-2019-2993, CVE-2019-2997, CVE-2019-2998, CVE-2019-3003, CVE-2019-3004, CVE-2019-3009, CVE-2019-3011, CVE-2019-3018, FEDORA-2019-08c700185f, FEDORA-2019-40ed49f449, FEDORA-2019-48a0a07033, FEDORA-2019-d40df38271, NTAP-20191017-0002, openSUSE-SU-2019:2698-1, RHSA-2020:3518-01, RHSA-2020:3732-01, RHSA-2020:3755-01, RHSA-2020:3757-01, SUSE-SU-2019:3306-1, SUSE-SU-2019:3369-1, SUSE-SU-2019:3370-1, SUSE-SU-2020:0050-1, USN-4195-1, USN-4195-2, VIGILANCE-VUL-30636.

Description de la vulnérabilité 

Plusieurs vulnérabilités ont été annoncées dans les produits Oracle.
Bulletin complet, filtrage par logiciel, emails, correctifs, ... (Demandez votre essai gratuit)

Cette alerte cybersécurité concerne les logiciels ou systèmes comme Fedora, IBM API Connect, MariaDB ~ précis, MySQL Community, MySQL Enterprise, SnapCenter Backup Management, openSUSE Leap, Solaris, Percona Server, RHEL, SUSE Linux Enterprise Desktop, SLES, Ubuntu.

Notre équipe Vigil@nce a déterminé que la gravité de cet avis de menace est important.

Le niveau de confiance est de type confirmé par l'éditeur, avec une provenance de compte utilisateur.

Ce bulletin concerne 28 vulnérabilités.

Un attaquant avec un niveau de compétence expert peut exploiter cette annonce de menace informatique.

Solutions pour cette menace 

Oracle MySQL : version 8.0.18.
La version 8.0.18 est corrigée :
  https://support.oracle.com/rs?type=doc&id=2593658.1
  https://www.mysql.com/fr/downloads/

Oracle MySQL : version 5.7.28.
La version 5.7.28 est corrigée :
  https://support.oracle.com/rs?type=doc&id=2593658.1
  https://www.mysql.com/fr/downloads/

Oracle MySQL : version 5.6.46.
La version 5.6.46 est corrigée :
  https://support.oracle.com/rs?type=doc&id=2593658.1
  https://www.mysql.com/fr/downloads/

Cloud Foundry : versions corrigées pour Percona XtraDB Cluster.
Les versions corrigées sont indiquées dans les sources d'information.

Fedora : nouveaux paquetages community-mysql (09/12/2019).
De nouveaux paquetages sont disponibles :
  Fedora 30 : community-mysql 8.0.18-4.fc30
  Fedora 31 : community-mysql 8.0.18-4.fc31

Fedora : nouveaux paquetages community-mysql (12/11/2019).
De nouveaux paquetages sont disponibles :
  Fedora 30 : community-mysql 8.0.18-1.fc30
  Fedora 31 : community-mysql 8.0.18-1.fc31

IBM API Connect : patch pour MySQL.
Un patch est indiqué dans les sources d'information.

MariaDB : versions 10.4.9, 10.3.19, 10.2.28, 10.1.42 et 5.5.66.
Les versions 10.4.9, 10.3.19, 10.2.28, 10.1.42 et 5.5.66 sont corrigées :
  https://mariadb.org/download/

openSUSE Leap 15.1 : nouveaux paquetages mariadb.
De nouveaux paquetages sont disponibles :
  openSUSE Leap 15.1 : mariadb 10.2.29-lp151.2.9.1

Oracle Solaris : patch pour logiciels tiers de janvier 2020 v1.
Un patch est disponible :
  https://support.oracle.com/rs?type=doc&id=1448883.1

Percona Server : versions 5.6.46-86.2, 5.7.28-31 et 8.0.18-9.
Les versions 5.6.46-86.2, 5.7.28-31 et 8.0.18-9 sont corrigées :
  https://www.percona.com/

Percona XtraDB Cluster : version 5.6.46-28.38 et 5.7.28-31.41.
La version 5.6.46-28.38 et 5.7.28-31.41 est corrigée :
  https://www.percona.com/

RHEL 7 : nouveaux paquetages rh-mysql80-mysql.
De nouveaux paquetages sont disponibles :
  RHEL 7.0-7.8 : rh-mysql80-mysql 8.0.21-1.el7

RHEL 8.0-8.1 : nouveau module mysql-8.0.
Le module suivant est mis à jour :
  RHEL 8.0 Module : mysql:8.0
  RHEL 8.1 Module : mysql:8.0

RHEL 8.0 : nouveau module mysql-8.0.
Le module suivant est mis à jour :
  RHEL 8.0 Module : mysql:8.0

SnapCenter : solution pour MySQL.
La solution est indiquée dans les sources d'information.

SUSE LE 12 SP1/3 : nouveaux paquetages mariadb.
De nouveaux paquetages sont disponibles :
  SUSE LE 12 SP1 : mariadb 10.0.40.2-29.35.1
  SUSE LE 12 SP2 : mariadb 10.0.40.2-29.35.1
  SUSE LE 12 SP3 : mariadb 10.0.40.2-29.35.1

SUSE LE 12 SP4/5 : nouveaux paquetages mariadb.
De nouveaux paquetages sont disponibles :
  SUSE LE 12 SP4 : mariadb 10.2.29-3.22.1
  SUSE LE 12 SP5 : mariadb 10.2.29-3.22.1

SUSE LE 12 SP4/5 : nouveaux paquetages mariadb-100.
De nouveaux paquetages sont disponibles :
  SUSE LE 12 SP4 : mariadb-100 10.0.40.2-2.12.2
  SUSE LE 12 SP5 : mariadb-100 10.0.40.2-2.12.2

SUSE LE 15 : nouveaux paquetages mariadb.
De nouveaux paquetages sont disponibles :
  SUSE LE 15 RTM : mariadb 10.2.29-3.23.1
  SUSE LE 15 SP1 : mariadb 10.2.29-3.23.1

Ubuntu : nouveaux paquetages mariadb.
De nouveaux paquetages sont disponibles :
  Ubuntu 19.10 : mariadb 1:10.3.20-0ubuntu0.19.10.1
  Ubuntu 19.04 : mariadb 1:10.3.20-0ubuntu0.19.04.1
  Ubuntu 18.04 LTS : mariadb 1:10.1.43-0ubuntu0.18.04.1

Ubuntu : nouveaux paquetages mysql-server.
De nouveaux paquetages sont disponibles :
  Ubuntu 19.10 : mysql-server-8.0 8.0.18-0ubuntu0.19.10.1
  Ubuntu 19.04 : mysql-server-5.7 5.7.28-0ubuntu0.19.04.2
  Ubuntu 18.04 LTS : mysql-server-5.7 5.7.28-0ubuntu0.18.04.4
  Ubuntu 16.04 LTS : mysql-server-5.7 5.7.28-0ubuntu0.16.04.2

VMware Tanzu Application Service : versions corrigées pour MySQL cpuoct2019.
Les versions corrigées sont indiquées dans les sources d'information.

Wind River Linux : version 10.17.41.19.
La version 10.17.41.19 est corrigée.
Bulletin complet, filtrage par logiciel, emails, correctifs, ... (Demandez votre essai gratuit)

Service de veille sur les vulnérabilités informatiques 

Vigil@nce fournit un patch de vulnérabilité de réseau. L'équipe Vigil@nce surveille les vulnérabilités informatiques de systèmes et d'applications.