L'équipe Vigil@nce veille les vulnérabilités publiques qui affectent votre parc informatique, puis propose des correctifs sécurité, une base de données de vigilance et des outils pour y remédier.

Vulnérabilité de PCRE : buffer overflow de pcre_compile2

Synthèse de la vulnérabilité 

Un attaquant peut provoquer un buffer overflow dans pcre_compile2 de PCRE, afin de mener un déni de service, et éventuellement d'exécuter du code.
Logiciels vulnérables : BIG-IP Hardware, TMOS, Fedora, openSUSE, openSUSE Leap, Solaris, RHEL, Slackware, Ubuntu.
Gravité de cette annonce : 2/4.
Date de création : 15/07/2015.
Références de cette vulnérabilité informatique : bulletinjul2015, CVE-2015-3210, FEDORA-2015-11019, FEDORA-2015-11027, FEDORA-2016-f59a8ff5d0, FEDORA-2016-fd1199dbe2, openSUSE-SU-2016:2805-1, openSUSE-SU-2016:3099-1, RHSA-2016:1132-01, RHSA-2016:2750-01, SOL17235, SSA:2015-328-01, USN-2694-1, USN-2943-1, VIGILANCE-VUL-17389.

Description de la vulnérabilité 

Un attaquant peut provoquer un buffer overflow dans pcre_compile2 de PCRE, afin de mener un déni de service, et éventuellement d'exécuter du code.
Bulletin complet, filtrage par logiciel, emails, correctifs, ... (Demandez votre essai gratuit)

Cet avis de vulnérabilité informatique concerne les logiciels ou systèmes comme BIG-IP Hardware, TMOS, Fedora, openSUSE, openSUSE Leap, Solaris, RHEL, Slackware, Ubuntu.

Notre équipe Vigil@nce a déterminé que la gravité de cette menace informatique est moyen.

Le niveau de confiance est de type confirmé par l'éditeur, avec une provenance de document.

Un attaquant avec un niveau de compétence expert peut exploiter cette menace cybersécurité.

Solutions pour cette menace 

F5 BIG-IP : versions corrigées pour PCRE.
Les versions corrigées sont indiquées dans les sources d'information.

Fedora : nouveaux paquetages mingw-pcre.
De nouveaux paquetages sont disponibles :
  Fedora 22 : mingw-pcre 8.38-1.fc22
  Fedora 23 : mingw-pcre 8.38-1.fc23

Fedora : nouveaux paquetages pcre.
De nouveaux paquetages sont disponibles :
  Fedora 21 : pcre 8.35-12.fc21
  Fedora 22 : pcre 8.37-2.fc22

openSUSE 13.2 : nouveaux paquetages pcre.
De nouveaux paquetages sont disponibles :
  openSUSE 13.2 : pcre 8.39-3.8.1

openSUSE Leap : nouveaux paquetages pcre.
De nouveaux paquetages sont disponibles :
  openSUSE Leap 42.2 : libpcre1 8.39-6.1
  openSUSE Leap 42.1 : libpcre1 8.39-5.1

RHEL : nouveaux paquetages rh-mariadb100-mariadb.
De nouveaux paquetages sont disponibles :
  RHEL 6 : rh-mariadb100-mariadb 10.0.25-4.el6
  RHEL 7 : rh-mariadb100-mariadb 10.0.25-4.el7

RHEL : nouveaux paquetages rh-php56.
De nouveaux paquetages sont disponibles :
  RHEL 6 : rh-php56 2.3-1.el6
  RHEL 7 : rh-php56 2.3-1.el7

Slackware : nouveaux paquetages pcre.
De nouveaux paquetages sont disponibles :
  Slackware 14.1 : pcre 8.38-*-1_slack14.1

Solaris : patch pour Third Party (08/2015).
Un patch est disponible :
  https://support.oracle.com/rs?type=doc&id=1448883.1

Ubuntu : nouveaux paquetages libpcre3 (30/03/2016).
De nouveaux paquetages sont disponibles :
  Ubuntu 15.10 : libpcre3 2:8.35-7.1ubuntu1.3
  Ubuntu 14.04 LTS : libpcre3 1:8.31-2ubuntu2.2
  Ubuntu 12.04 LTS : libpcre3 8.12-4ubuntu0.2

Ubuntu : nouveaux paquetages libpcre3 (30/07/2015).
De nouveaux paquetages sont disponibles :
  Ubuntu 15.04 : libpcre3 2:8.35-3.3ubuntu1.1
  Ubuntu 14.04 LTS : libpcre3 1:8.31-2ubuntu2.1
  Ubuntu 12.04 LTS : libpcre3 8.12-4ubuntu0.1
Bulletin complet, filtrage par logiciel, emails, correctifs, ... (Demandez votre essai gratuit)

Service de veille sur les vulnérabilités informatiques 

Vigil@nce fournit une veille de sécurité informatique. L'équipe Vigil@nce surveille les vulnérabilités informatiques de systèmes et d'applications.