L'équipe Vigil@nce veille les vulnérabilités publiques qui affectent votre parc informatique, puis propose des correctifs sécurité, une base de données de vigilance et des outils pour y remédier.

Vulnérabilité de PHP : corruption de mémoire via phar_parse_tarfile

Synthèse de la vulnérabilité 

Un attaquant peut provoquer une corruption de mémoire dans phar_parse_tarfile() de PHP, afin de mener un déni de service, et éventuellement d'exécuter du code.
Systèmes impactés : Debian, Fedora, openSUSE, Solaris, PHP, RHEL, Slackware, SUSE Linux Enterprise Desktop, SLES, Synology DSM, Synology DS***, Synology RS***, Ubuntu.
Gravité de cette alerte : 2/4.
Date de création : 18/05/2015.
Références de cette alerte : 69453, bulletinjul2017, CERTFR-2015-AVI-234, CVE-2015-4021, DSA-3280-1, FEDORA-2015-8370, FEDORA-2015-8383, openSUSE-SU-2015:0993-1, RHSA-2015:1135-01, RHSA-2015:1186-01, RHSA-2015:1187-01, RHSA-2015:1218-01, RHSA-2015:1219-01, SSA:2015-162-02, SUSE-SU-2015:1253-1, SUSE-SU-2015:1253-2, SUSE-SU-2016:1638-1, USN-2658-1, VIGILANCE-VUL-16913.

Description de la vulnérabilité 

Le produit PHP utilise l'extension Phar, pour manipuler les archives PHP.

Cependant, lorsque le nom d'un fichier commence par le caractère '\0' la fonction phar_parse_tarfile() écrit un octet nul avant le tableau de stockage.

Un attaquant peut donc provoquer une corruption de mémoire dans phar_parse_tarfile() de PHP, afin de mener un déni de service, et éventuellement d'exécuter du code.
Bulletin complet, filtrage par logiciel, emails, correctifs, ... (Demandez votre essai gratuit)

Ce bulletin de vulnérabilité informatique concerne les logiciels ou systèmes comme Debian, Fedora, openSUSE, Solaris, PHP, RHEL, Slackware, SUSE Linux Enterprise Desktop, SLES, Synology DSM, Synology DS***, Synology RS***, Ubuntu.

Notre équipe Vigil@nce a déterminé que la gravité de cette alerte cybersécurité est moyen.

Le niveau de confiance est de type confirmé par l'éditeur, avec une provenance de document.

Un attaquant avec un niveau de compétence expert peut exploiter cet avis de faille.

Solutions pour cette menace 

PHP : version 5.6.9.
La version 5.6.9 est corrigée :
  http://php.net/downloads.php#v5.6.9

PHP : version 5.5.25.
La version 5.5.25 est corrigée :
  http://php.net/downloads.php

PHP : version 5.4.41.
La version 5.4.41 est corrigée :
  http://php.net/downloads.php

PHP : patch pour phar_parse_tarfile.
Un patch est disponible dans les sources d'information.

Debian : nouveaux paquetages php5.
De nouveaux paquetages sont disponibles :
  Debian 8 : php5 5.6.9+dfsg-0+deb8u1
  Debian 7 : php5 5.4.41-0+deb7u1

Fedora : nouveaux paquetages php.
De nouveaux paquetages sont disponibles :
  Fedora 20 : php 5.5.25-1.fc20
  Fedora 21 : php 5.6.9-1.fc21

openSUSE : nouveaux paquetages php5.
De nouveaux paquetages sont disponibles :
  openSUSE 13.1 : apache2-mod_php5 5.4.20-55.2, php5 5.4.20-55.2
  openSUSE 13.2 : apache2-mod_php5 5.6.1-24.2, php5 5.6.1-24.2

Oracle Solaris : patch pour logiciels tiers de juillet 2017 v1.
Un patch est disponible :
  https://support.oracle.com/rs?type=doc&id=1448883.1

Red Hat Software Collections : nouveaux paquetages php54.
De nouveaux paquetages sont disponibles :
  RHEL 6 : php54 php-5.4.40-3.el6
  RHEL 7 : php54 php-5.4.40-3.el7

Red Hat Software Collections : nouveaux paquetages php55-php.
De nouveaux paquetages sont disponibles :
  RHEL 6 : php55-php 5.5.21-4.el6
  RHEL 7 : php55-php 5.5.21-4.el7

Red Hat Software Collections : nouveaux paquetages php56-php.
De nouveaux paquetages sont disponibles :
  RHEL 6 : rh-php56-php 5.6.5-7.el6
  RHEL 7 : rh-php56-php 5.6.5-7.el7

RHEL 6.6 : nouveaux paquetages php.
De nouveaux paquetages sont disponibles :
  RHEL 6 : php 5.3.3-46.el6_6

RHEL 7.1 : nouveaux paquetages php.
De nouveaux paquetages sont disponibles :
  RHEL 7 : php 5.4.16-36.el7_1

Slackware : nouveaux paquetages php (12/06/2015).
De nouveaux paquetages sont disponibles :
  Slackware 14.0 : php 5.4.41-*-1_slack14.0
  Slackware 14.1 : php 5.4.41-*-1_slack14.1

SUSE LE 11 SP2 : nouveaux paquetages php53 (21/06/2016).
De nouveaux paquetages sont disponibles :
  SUSE LE 11 SP2 : apache2-mod_php53 5.3.17-47.1, php53 5.3.17-47.1

SUSE LE 12 : nouveaux paquetages php5.
De nouveaux paquetages sont disponibles :
  SUSE LE 12 : php5 5.5.14-30.1

Synology DiskStation Manager, DS, RS : version 5.2-5565 Update 1.
La version 5.2-5565 Update 1 est corrigée :
  https://www.synology.com/

Ubuntu : nouveaux paquetages php5 (06/07/2015).
De nouveaux paquetages sont disponibles :
  Ubuntu 15.04 : libapache2-mod-php5 5.6.4+dfsg-4ubuntu6.2
  Ubuntu 14.10 : libapache2-mod-php5 5.5.12+dfsg-2ubuntu4.6
  Ubuntu 14.04 LTS : libapache2-mod-php5 5.5.9+dfsg-1ubuntu4.11
  Ubuntu 12.04 LTS : libapache2-mod-php5 5.3.10-1ubuntu3.19
Bulletin complet, filtrage par logiciel, emails, correctifs, ... (Demandez votre essai gratuit)

Service de veille sur les vulnérabilités informatiques 

Vigil@nce fournit des annonces de sécurité informatique. La veille sécurité Vigil@nce publie des bulletins de vulnérabilités pour les failles qui impactent le système d'information.