L'équipe Vigil@nce veille les vulnérabilités publiques qui affectent votre parc informatique, puis propose des correctifs sécurité, une base de données de vigilance et des outils pour y remédier.

Vulnérabilité de PHP : déréférencement de pointeur NULL via SoapClient

Synthèse de la vulnérabilité 

Un attaquant peut forcer le déréférencement d'un pointeur NULL via SoapClient de PHP, afin de mener un déni de service.
Produits vulnérables : Debian, Fedora, openSUSE Leap, Solaris, PHP, SUSE Linux Enterprise Desktop, SLES.
Gravité de cette faille : 2/4.
Date de création : 04/02/2021.
Références de ce bulletin : 80672, CERTFR-2021-AVI-084, CVE-2021-21702, DSA-4856-1, FEDORA-2021-6edfd606d3, FEDORA-2021-ae5a54ba78, openSUSE-SU-2021:0305-1, SUSE-SU-2021:0494-1, SUSE-SU-2021:0498-1, SUSE-SU-2021:0522-1, SUSE-SU-2021:0584-1, SUSE-SU-2021:14668-1, VIGILANCE-VUL-34488.

Description de la vulnérabilité 

Un attaquant peut forcer le déréférencement d'un pointeur NULL via SoapClient de PHP, afin de mener un déni de service.
Bulletin complet, filtrage par logiciel, emails, correctifs, ... (Demandez votre essai gratuit)

Ce bulletin sécurité concerne les logiciels ou systèmes comme Debian, Fedora, openSUSE Leap, Solaris, PHP, SUSE Linux Enterprise Desktop, SLES.

Notre équipe Vigil@nce a déterminé que la gravité de cet avis cyber-sécurité est moyen.

Le niveau de confiance est de type confirmé par l'éditeur, avec une provenance de document.

Un attaquant avec un niveau de compétence expert peut exploiter cette alerte de menace informatique.

Solutions pour cette menace 

PHP : version 8.0.2.
La version 8.0.2 est corrigée :
  https://www.php.net/downloads

PHP : version 7.4.15.
La version 7.4.15 est corrigée :
  https://www.php.net/downloads

PHP : version 7.3.27.
La version 7.3.27 est corrigée :
  https://www.php.net/downloads

Debian 10 : nouveaux paquetages php7.3.
De nouveaux paquetages sont disponibles :
  Debian 10 : php7.3 7.3.27-1~deb10u1

Fedora 32 : nouveaux paquetages php.
De nouveaux paquetages sont disponibles :
  Fedora 32 : php 7.4.15-1.fc32

Fedora 33 : nouveaux paquetages php.
De nouveaux paquetages sont disponibles :
  Fedora 33 : php 7.4.15-1.fc33

openSUSE Leap 15.2 : nouveaux paquetages php7.
De nouveaux paquetages sont disponibles :
  openSUSE Leap 15.2 : apache2-mod_php7 7.4.6-lp152.2.15.1, php7 7.4.6-lp152.2.15.1

Oracle Solaris : patch pour logiciels tiers de janvier 2021 v4.
Un patch est disponible :
  https://support.oracle.com/rs?type=doc&id=1448883.1

SUSE LE 11 SP3-4 : nouveaux paquetages php53.
De nouveaux paquetages sont disponibles :
  SUSE LE 11 SP3 : apache2-mod_php53 5.3.17-112.99.2, php53 5.3.17-112.99.2
  SUSE LE 11 SP4 : apache2-mod_php53 5.3.17-112.99.2, php53 5.3.17-112.99.2

SUSE LE 12 : nouveaux paquetages php72.
De nouveaux paquetages sont disponibles :
  SUSE LE 12 RTM-SP5 : apache2-mod_php72 7.2.5-1.60.1, php72 7.2.5-1.60.1

SUSE LE 12 : nouveaux paquetages php74.
De nouveaux paquetages sont disponibles :
  SUSE LE 12 RTM : apache2-mod_php74 7.4.6-1.19.1, php74 7.4.6-1.19.1

SUSE LE 15 RTM-SP1 : nouveaux paquetages php7.
De nouveaux paquetages sont disponibles :
  SUSE LE 15 RTM : apache2-mod_php7 7.2.5-4.73.1, php7 7.2.5-4.73.1
  SUSE LE 15 SP1 : apache2-mod_php7 7.2.5-4.73.1, php7 7.2.5-4.73.1

SUSE LE 15 SP2 : nouveaux paquetages php7.
De nouveaux paquetages sont disponibles :
  SUSE LE 15 SP2 : apache2-mod_php7 7.4.6-3.17.1, php7 7.4.6-3.17.1
Bulletin complet, filtrage par logiciel, emails, correctifs, ... (Demandez votre essai gratuit)

Service de veille sur les vulnérabilités informatiques 

Vigil@nce fournit une veille de vulnérabilités logicielles. La base de vulnérabilités Vigil@nce contient plusieurs milliers de failles.