L'équipe Vigil@nce veille les vulnérabilités publiques qui affectent votre parc informatique, puis propose des correctifs sécurité, une base de données de vigilance et des outils pour y remédier.

Vulnérabilité de PHP : multiples vulnérabilités

Synthèse de la vulnérabilité 

Un attaquant peut employer plusieurs vulnérabilités de PHP.
Systèmes impactés : Mac OS X, Debian, openSUSE Leap, Solaris, PHP, RHEL, Slackware, SUSE Linux Enterprise Desktop, SLES, Ubuntu.
Gravité de cette alerte : 3/4.
Nombre de vulnérabilités dans ce bulletin : 16.
Date de création : 19/01/2017.
Références de cette alerte : 46103, 69425, 70513, 72731, 73092, 73549, 73612, 73737, 73764, 73768, 73773, 73825, 73831, 73832, 73868, 73869, bulletinapr2018, CVE-2016-10158, CVE-2016-10159, CVE-2016-10160, CVE-2016-10161, CVE-2016-10162, CVE-2017-11147, CVE-2017-5340, DLA-1034-1, DLA-818-1, DSA-3783-1, HT207615, openSUSE-SU-2017:0588-1, openSUSE-SU-2017:2337-1, openSUSE-SU-2017:2366-1, RHSA-2018:1296-01, SSA:2017-041-03, SUSE-SU-2017:0534-1, SUSE-SU-2017:0556-1, SUSE-SU-2017:0568-1, SUSE-SU-2017:2303-1, USN-3196-1, USN-3211-1, USN-3211-2, USN-3382-1, USN-3382-2, VIGILANCE-VUL-21635.

Description de la vulnérabilité 

Plusieurs vulnérabilités ont été annoncées dans PHP.

Un attaquant peut forcer le déréférencement d'un pointeur NULL via unserialize, afin de mener un déni de service. [grav:1/4; 73831, CVE-2016-10162]

Un attaquant peut provoquer l'utilisation d'une zone mémoire libérée via unserialize, afin de mener un déni de service, et éventuellement d'exécuter du code (VIGILANCE-VUL-21565). [grav:3/4; 73832, CVE-2017-5340]

Un attaquant peut provoquer l'utilisation d'une zone mémoire libérée via Resizing Object Properties, afin de mener un déni de service, et éventuellement d'exécuter du code. [grav:3/4; 73092]

Un attaquant peut provoquer l'utilisation d'une zone mémoire libérée via unserialize, afin de mener un déni de service, et éventuellement d'exécuter du code. [grav:3/4; 69425]

Un attaquant peut provoquer une corruption de mémoire via Object Deserialization, afin de mener un déni de service, et éventuellement d'exécuter du code. [grav:3/4; 72731]

Un attaquant peut provoquer un débordement d'entier via gd_io.c, afin de mener un déni de service, et éventuellement d'exécuter du code. [grav:3/4; 73869]

Un attaquant peut provoquer une erreur fatale via gdImageCreateFromGd2Ctx(), afin de mener un déni de service. [grav:1/4; 73868]

Un attaquant peut provoquer une corruption de mémoire via GMP Deserialization, afin de mener un déni de service, et éventuellement d'exécuter du code. [grav:3/4; 70513]

Un attaquant peut provoquer une fuite mémoire via preg_*(), afin de mener un déni de service. [grav:1/4; 73612]

Un attaquant peut provoquer une corruption de mémoire via phar, afin de mener un déni de service, et éventuellement d'exécuter du code. [grav:3/4; 73768, CVE-2016-10160]

Un attaquant peut provoquer une fuite mémoire via ReflectionObject, afin de mener un déni de service. [grav:1/4; 46103]

Un attaquant peut provoquer l'utilisation d'une zone mémoire libérée via imagepng, afin de mener un déni de service, et éventuellement d'exécuter du code. [grav:3/4; 73549]

Un attaquant peut provoquer une corruption de mémoire via exif_convert_any_to_int(), afin de mener un déni de service, et éventuellement d'exécuter du code. [grav:3/4; 73737, CVE-2016-10158]

Un attaquant peut provoquer une corruption de mémoire via phar, afin de mener un déni de service, et éventuellement d'exécuter du code. [grav:3/4; 73764, CVE-2016-10159]

Un attaquant peut forcer la lecture à une adresse invalide via finish_nested_data(), afin de mener un déni de service, ou d'obtenir des informations sensibles. [grav:2/4; 73825, CVE-2016-10161]

Un attaquant peut forcer la lecture à une adresse invalide via phar_parse_pharfile(), afin de mener un déni de service, ou d'obtenir des informations sensibles. [grav:2/4; 73773, CVE-2017-11147]
Bulletin complet, filtrage par logiciel, emails, correctifs, ... (Demandez votre essai gratuit)

Ce bulletin de faille concerne les logiciels ou systèmes comme Mac OS X, Debian, openSUSE Leap, Solaris, PHP, RHEL, Slackware, SUSE Linux Enterprise Desktop, SLES, Ubuntu.

Notre équipe Vigil@nce a déterminé que la gravité de cet avis cybersécurité est important.

Le niveau de confiance est de type confirmé par l'éditeur, avec une provenance de document.

Ce bulletin concerne 16 vulnérabilités.

Un attaquant avec un niveau de compétence expert peut exploiter cette annonce de faille.

Solutions pour cette menace 

PHP : version 7.1.1.
La version 7.1.1 est corrigée :
  http://php.net/downloads

PHP : version 7.0.15.
La version 7.0.15 est corrigée :
  http://php.net/downloads

PHP : version 5.6.30.
La version 5.6.30 est corrigée :
  http://www.php.net/downloads.php

Apple Mac OS X : version 10.12.4.
La version 10.12.4 est corrigée.

Debian 7 : nouveaux paquetages php5 (07/02/2017).
De nouveaux paquetages sont disponibles :
  Debian 7 : php5 5.4.45-0+deb7u7

Debian 7 : nouveaux paquetages php5 (21/07/2017).
De nouveaux paquetages sont disponibles :
  Debian 7 : php5 5.4.45-0+deb7u9

Debian 8 : nouveaux paquetages php5.
De nouveaux paquetages sont disponibles :
  Debian 8 : php5 5.6.30+dfsg-0+deb8u1

openSUSE Leap 42.2 : nouveaux paquetages php7 (02/03/2017).
De nouveaux paquetages sont disponibles :
  openSUSE Leap 42.2 : php7 7.0.7-12.1

openSUSE Leap : nouveaux paquetages php5 (06/09/2017).
De nouveaux paquetages sont disponibles :
  openSUSE Leap 42.2 : apache2-mod_php5 5.5.14-77.9.1, php5 5.5.14-77.9.1
  openSUSE Leap 42.3 : apache2-mod_php5 5.5.14-82.1, php5 5.5.14-82.1

openSUSE Leap : nouveaux paquetages php7.
De nouveaux paquetages sont disponibles :
  openSUSE Leap 42.2 : apache2-mod_php7 .0.7-14.9.1, php7 7.0.7-14.9.1
  openSUSE Leap 42.3 : apache2-mod_php7 7.0.7-19.1, php7 7.0.7-19.1

Oracle Solaris : patch pour logiciels tiers de avril 2018 v1.
Un patch est disponible :
  https://support.oracle.com/rs?type=doc&id=1448883.1

RHEL : nouveaux paquetages rh-php70-php.
De nouveaux paquetages sont disponibles :
  RHEL 6 : rh-php70-php 7.0.27-1.el6
  RHEL 7 : rh-php70-php 7.0.27-1.el7

Slackware : nouveaux paquetages php.
De nouveaux paquetages sont disponibles :
  Slackware 14.0 : php 5.6.30-*-1_slack14.0
  Slackware 14.1 : php 5.6.30-*-1_slack14.1
  Slackware 14.2 : php 5.6.30-*-1_slack14.2

SUSE LE 11 : nouveaux paquetages php53.
De nouveaux paquetages sont disponibles :
  SUSE LE 11 SP3 : php53 5.3.17-101.1
  SUSE LE 11 SP4 : php53 5.3.17-101.1

SUSE LE 12 : nouveaux paquetages php5.
De nouveaux paquetages sont disponibles :
  SUSE LE 12 RTM-SP2 : php5 5.5.14-96.1

SUSE LE 12 : nouveaux paquetages php7 (22/02/2017).
De nouveaux paquetages sont disponibles :
  SUSE LE 12 RTM-SP2 : php7 7.0.7-35.1

SUSE LE 12 : nouveaux paquetages php7 (31/08/2017).
De nouveaux paquetages sont disponibles :
  SUSE LE 12 SP2 : php7 7.0.7-50.9.2
  SUSE LE 12 SP3 : php7 7.0.7-50.9.2

Ubuntu : nouveaux paquetages php.
De nouveaux paquetages sont disponibles :
  Ubuntu 17.04 : php7.0 7.0.22-0ubuntu0.17.04.1
  Ubuntu 16.04 LTS : php7.0 7.0.22-0ubuntu0.16.04.1
  Ubuntu 14.04 LTS : php5 5.5.9+dfsg-1ubuntu4.22
  Ubuntu 12.04 ESM : php5 5.3.10-1ubuntu3.28

Ubuntu : nouveaux paquetages php5 (15/02/2017).
De nouveaux paquetages sont disponibles :
  Ubuntu 14.04 LTS : php5 5.5.9+dfsg-1ubuntu4.21
  Ubuntu 12.04 LTS : php5 5.3.10-1ubuntu3.26

Ubuntu : nouveaux paquetages php7.0.
De nouveaux paquetages sont disponibles :
  Ubuntu 16.10 : php7.0 7.0.15-0ubuntu0.16.10.4
  Ubuntu 16.04 LTS : php7.0 7.0.15-0ubuntu0.16.04.4
Bulletin complet, filtrage par logiciel, emails, correctifs, ... (Demandez votre essai gratuit)

Service de veille sur les vulnérabilités informatiques 

Vigil@nce fournit des annonces de vulnérabilité de logiciel. L'équipe Vigil@nce surveille les vulnérabilités informatiques de systèmes et d'applications.