L'équipe Vigil@nce veille les vulnérabilités publiques qui affectent votre parc informatique, puis propose des correctifs sécurité, une base de données de vigilance et des outils pour y remédier.

Vulnérabilité de Perl Archive-Tar : traversée de répertoire via Symlink

Synthèse de la vulnérabilité 

Un attaquant peut traverser les répertoires via Symlink de Perl Archive::Tar, afin de créer un fichier situé hors de la racine du service.
Systèmes impactés : Mac OS X, Debian, VNX Operating Environment, VNX Series, Fedora, Data ONTAP 7-Mode, OpenBSD, openSUSE Leap, Oracle DB, Solaris, Perl Module ~ non exhaustif, RHEL, SUSE Linux Enterprise Desktop, SLES, Ubuntu.
Gravité de cette alerte : 2/4.
Date de création : 08/06/2018.
Références de cette alerte : 125523, bulletinjan2019, cpujul2020, CVE-2018-12015, DSA-2020-030, DSA-2020-289, DSA-4226-1, FEDORA-2018-10ae521efa, FEDORA-2018-4e088b6d7c, HT209600, NTAP-20180926-0001, NTAP-20180926-0002, NTAP-20180926-0003, NTAP-20180926-0004, NTAP-20180926-0005, NTAP-20180927-0001, openSUSE-SU-2018:2010-1, openSUSE-SU-2018:2011-1, RHSA-2019:2097-01, SUSE-SU-2018:1972-1, SUSE-SU-2018:1977-1, SUSE-SU-2018:1992-1, USN-3684-1, USN-3684-2, VIGILANCE-VUL-26351.

Description de la vulnérabilité 

Un attaquant peut traverser les répertoires via Symlink de Perl Archive::Tar, afin de créer un fichier situé hors de la racine du service.
Bulletin complet, filtrage par logiciel, emails, correctifs, ... (Demandez votre essai gratuit)

Ce bulletin cybersécurité concerne les logiciels ou systèmes comme Mac OS X, Debian, VNX Operating Environment, VNX Series, Fedora, Data ONTAP 7-Mode, OpenBSD, openSUSE Leap, Oracle DB, Solaris, Perl Module ~ non exhaustif, RHEL, SUSE Linux Enterprise Desktop, SLES, Ubuntu.

Notre équipe Vigil@nce a déterminé que la gravité de ce bulletin sécurité est moyen.

Le niveau de confiance est de type confirmé par l'éditeur, avec une provenance de document.

Un attaquant avec un niveau de compétence expert peut exploiter cette menace informatique.

Solutions pour cette menace 

Perl Archive-Tar : version 2.28.
La version 2.28 est corrigée :
  https://metacpan.org/release/Archive-Tar

Perl Archive-Tar : patch pour Symlink.
Un patch est indiqué dans les sources d'information.

Apple macOS : versions 10.12.6-2019-002, 10.13.6-2019-002 et 10.14.4.
Les versions 10.12.6-2019-002, 10.13.6-2019-002 et 10.14.4 sont corrigées :
  https://support.apple.com/

Debian : nouveaux paquetages perl.
De nouveaux paquetages sont disponibles :
  Debian 8 : perl 5.20.2-3+deb8u11
  Debian 9 : perl 5.24.1-3+deb9u4

Dell EMC VNXe3200 : version 3.1.11.10003441.
La version 3.1.11.10003441 est corrigée :
  https://www.dell.com/support/

Fedora : nouveaux paquetages perl-Archive-Tar.
De nouveaux paquetages sont disponibles :
  Fedora 27 : perl-Archive-Tar 2.28-1.fc27
  Fedora 28 : perl-Archive-Tar 2.28-1.fc28

NetApp Data ONTAP Edge : fin de vie.
La fin de vie est indiquée dans les sources d'information.

OpenBSD : patch pour Perl Archive-Tar.
Un patch est disponible :
  https://ftp.openbsd.org/pub/OpenBSD/patches/6.2/common/016_perl.patch.sig
  https://ftp.openbsd.org/pub/OpenBSD/patches/6.3/common/011_perl.patch.sig

openSUSE Leap : nouveaux paquetages perl.
De nouveaux paquetages sont disponibles :
  openSUSE Leap 42.3 : perl 5.18.2-15.2
  openSUSE Leap 15.0 : perl 5.26.1-lp150.6.3.1

Oracle Database : CPU de juillet 2020.
Un Critical Patch Update est disponible :
  https://support.oracle.com/rs?type=doc&id=2664876.1

Oracle Solaris : patch pour logiciels tiers de janvier 2019 v2.
Un patch est disponible :
  https://support.oracle.com/rs?type=doc&id=1448883.1

RHEL 7 : nouveaux paquetages perl-Archive-Tar.
De nouveaux paquetages sont disponibles :
  RHEL 7 : perl-Archive-Tar 1.92-3.el7

SUSE LE 11 : nouveaux paquetages perl.
De nouveaux paquetages sont disponibles :
  SUSE LE 11 SP3 : perl 5.10.0-64.81.13.1
  SUSE LE 11 SP4 : perl 5.10.0-64.81.13.1

SUSE LE 12 : nouveaux paquetages perl.
De nouveaux paquetages sont disponibles :
  SUSE LE 12 RTM : perl 5.18.2-12.14.1
  SUSE LE 12 SP1 : perl 5.18.2-12.14.1
  SUSE LE 12 SP2 : perl 5.18.2-12.14.1
  SUSE LE 12 SP3 : perl 5.18.2-12.14.1

SUSE LE 15 : nouveaux paquetages perl.
De nouveaux paquetages sont disponibles :
  SUSE LE 15 RTM : perl 5.26.1-7.3.1

Ubuntu : nouveaux paquetages perl.
De nouveaux paquetages sont disponibles :
  Ubuntu 18.04 LTS : perl 5.26.1-6ubuntu0.1
  Ubuntu 17.10 : perl 5.26.0-8ubuntu1.2
  Ubuntu 16.04 LTS : perl 5.22.1-9ubuntu0.5
  Ubuntu 14.04 LTS : perl 5.18.2-2ubuntu1.6
  Ubuntu 12.04 ESM : perl 5.14.2-6ubuntu2.8

VNXe1600 : versions corrigées pour Third-Party Component.
Les versions corrigées sont indiquées dans les sources d'information.
Bulletin complet, filtrage par logiciel, emails, correctifs, ... (Demandez votre essai gratuit)

Service de veille sur les vulnérabilités informatiques 

Vigil@nce fournit une analyse de vulnérabilité de système. Le service de veille sur les vulnérabilités informatiques Vigil@nce alerte vos équipes des failles et des menaces qui concernent votre système d'information.