L'équipe Vigil@nce veille les vulnérabilités publiques qui affectent votre parc informatique, puis propose des correctifs sécurité, une base de données de vigilance et des outils pour y remédier.

Vulnérabilité de Perl Core : buffer overflow via Perl__byte_dump_string

Synthèse de la vulnérabilité 

Un attaquant peut provoquer un buffer overflow via Perl__byte_dump_string de Perl Core, afin de mener un déni de service, et éventuellement d'exécuter du code.
Produits vulnérables : Debian, Fedora, OpenBSD, openSUSE Leap, Oracle DB, Solaris, Perl Core, RHEL, SUSE Linux Enterprise Desktop, SLES, Ubuntu.
Gravité de cette faille : 3/4.
Date de création : 16/04/2018.
Références de ce bulletin : 132063, bulletinjan2019, cpujul2020, CVE-2018-6798, DSA-4172-1, FEDORA-2018-0050f7c0d1, FEDORA-2018-1c8b49fbc7, FEDORA-2018-d1ba58394e, openSUSE-SU-2018:1095-1, RHSA-2018:1192-01, SUSE-SU-2018:1972-1, USN-3625-1, USN-3625-2, VIGILANCE-VUL-25878.

Description de la vulnérabilité 

Un attaquant peut provoquer un buffer overflow via Perl__byte_dump_string de Perl Core, afin de mener un déni de service, et éventuellement d'exécuter du code.
Bulletin complet, filtrage par logiciel, emails, correctifs, ... (Demandez votre essai gratuit)

Cette vulnérabilité cyber-sécurité concerne les logiciels ou systèmes comme Debian, Fedora, OpenBSD, openSUSE Leap, Oracle DB, Solaris, Perl Core, RHEL, SUSE Linux Enterprise Desktop, SLES, Ubuntu.

Notre équipe Vigil@nce a déterminé que la gravité de cette annonce de menace est important.

Le niveau de confiance est de type confirmé par l'éditeur, avec une provenance de document.

Un attaquant avec un niveau de compétence expert peut exploiter cet avis de menace.

Solutions pour cette menace 

Perl Core : version 5.26.2.
La version 5.26.2 est corrigée :
  http://www.cpan.org/src/

Perl Core : version 5.24.4.
La version 5.24.4 est corrigée :
  http://www.cpan.org/src/

Perl Core : patch pour Perl__byte_dump_string.
Un patch est disponible :
  maint-5.24 : https://perl5.git.perl.org/perl.git/commitdiff/0abf1e8d89aecd32dbdabda5da4d52a2d57a7cff
  maint-5.24 : https://perl5.git.perl.org/perl.git/commitdiff/f65da1ca2eee74696d9c120e9d69af37b4fa1920
  maint-5.26 : https://perl5.git.perl.org/perl.git/commitdiff/8e6f44c90c7fa1f63c19a44c45482b09a407e15b
  maint-5.26 : https://perl5.git.perl.org/perl.git/commitdiff/8b80ce67ff257aaa36e47eaf4194d27a51595524

Debian 9 : nouveaux paquetages perl.
De nouveaux paquetages sont disponibles :
  Debian 9 : perl 5.24.1-3+deb9u3

Fedora : nouveaux paquetages perl.
De nouveaux paquetages sont disponibles :
  Fedora 26 : perl 5.24.4-397.fc26
  Fedora 27 : perl 5.26.2-404.fc27
  Fedora 28 : perl 5.26.2-410.fc28

Fedora : nouveaux paquetages perl-Module-CoreList.
De nouveaux paquetages sont disponibles :
  Fedora 26 : perl-Module-CoreList 5.20180414-1.fc26
  Fedora 27 : perl-Module-CoreList 5.20180414-1.fc27

OpenBSD : patch pour perl.
Un patch est disponible :
  https://ftp.openbsd.org/pub/OpenBSD/patches/6.1/common/039_perl.patch.sig
  https://ftp.openbsd.org/pub/OpenBSD/patches/6.2/common/011_perl.patch.sig
  https://ftp.openbsd.org/pub/OpenBSD/patches/6.3/common/001_perl.patch.sig

openSUSE Leap 42.3 : nouveaux paquetages perl.
De nouveaux paquetages sont disponibles :
  openSUSE Leap 42.3 : perl 5.18.2-12.1

Oracle Database : CPU de juillet 2020.
Un Critical Patch Update est disponible :
  https://support.oracle.com/rs?type=doc&id=2664876.1

Oracle Solaris : patch pour logiciels tiers de janvier 2019 v1.
Un patch est disponible :
  https://support.oracle.com/rs?type=doc&id=1448883.1

RHEL : nouveaux paquetages rh-perl524-perl.
De nouveaux paquetages sont disponibles :
  RHEL 6 : rh-perl524-perl 5.24.0-380.el6
  RHEL 7 : rh-perl524-perl 5.24.0-380.el7

SUSE LE 12 : nouveaux paquetages perl.
De nouveaux paquetages sont disponibles :
  SUSE LE 12 RTM : perl 5.18.2-12.14.1
  SUSE LE 12 SP1 : perl 5.18.2-12.14.1
  SUSE LE 12 SP2 : perl 5.18.2-12.14.1
  SUSE LE 12 SP3 : perl 5.18.2-12.14.1

Ubuntu : nouveaux paquetages perl.
De nouveaux paquetages sont disponibles :
  Ubuntu 17.10 : perl 5.26.0-8ubuntu1.1
  Ubuntu 16.04 LTS : perl 5.22.1-9ubuntu0.3
  Ubuntu 14.04 LTS : perl 5.18.2-2ubuntu1.4
  Ubuntu 12.04 ESM : perl 5.14.2-6ubuntu2.7
Bulletin complet, filtrage par logiciel, emails, correctifs, ... (Demandez votre essai gratuit)

Service de veille sur les vulnérabilités informatiques 

Vigil@nce fournit un patch cyber-sécurité. L'équipe Vigil@nce surveille les vulnérabilités informatiques de systèmes et d'applications.