L'équipe Vigil@nce veille les vulnérabilités publiques qui affectent votre parc informatique, puis propose des correctifs sécurité, une base de données de vigilance et des outils pour y remédier.

Vulnérabilité de PostgreSQL : buffer overflow via Password Change

Synthèse de la vulnérabilité 

Un attaquant peut provoquer un buffer overflow via Password Change de PostgreSQL, afin de mener un déni de service, et éventuellement d'exécuter du code.
Produits impactés : openSUSE Leap, PostgreSQL, RHEL, SUSE Linux Enterprise Desktop, SLES, Ubuntu.
Gravité de ce bulletin : 2/4.
Date de création : 20/06/2019.
Références de cette menace : CVE-2019-10164, openSUSE-SU-2019:1773-1, RHSA-2020:0980-01, RHSA-2020:3669-01, SUSE-SU-2019:1783-1, SUSE-SU-2019:1783-2, SUSE-SU-2019:1810-1, USN-4027-1, VIGILANCE-VUL-29583.

Description de la vulnérabilité 

Un attaquant peut provoquer un buffer overflow via Password Change de PostgreSQL, afin de mener un déni de service, et éventuellement d'exécuter du code.
Bulletin complet, filtrage par logiciel, emails, correctifs, ... (Demandez votre essai gratuit)

Cet avis de faille informatique concerne les logiciels ou systèmes comme openSUSE Leap, PostgreSQL, RHEL, SUSE Linux Enterprise Desktop, SLES, Ubuntu.

Notre équipe Vigil@nce a déterminé que la gravité de cette annonce de faille informatique est moyen.

Le niveau de confiance est de type confirmé par l'éditeur, avec une provenance de compte utilisateur.

Un attaquant avec un niveau de compétence expert peut exploiter cet avis cyber-sécurité.

Solutions pour cette menace 

PostgreSQL : version 11.4.
La version 11.4 est corrigée :
  https://www.postgresql.org/download/

PostgreSQL : version 10.9.
La version 10.9 est corrigée :
  https://www.postgresql.org/download/

PostgreSQL : version 9.6.14.
La version 9.6.14 est corrigée :
  https://www.postgresql.org/download/

PostgreSQL : version 9.5.18.
La version 9.5.18 est corrigée :
  https://www.postgresql.org/download/

PostgreSQL : version 9.4.23.
La version 9.4.23 est corrigée :
  https://www.postgresql.org/download/

Cloud Foundry : versions corrigées pour PostgreSQL.
Les versions corrigées sont indiquées dans les sources d'information.

openSUSE Leap : nouveaux paquetages postgresql10.
De nouveaux paquetages sont disponibles :
  openSUSE Leap 15.0 : postgresql10 10.9-lp150.3.10.1
  openSUSE Leap 15.1 : postgresql10 10.9-lp151.2.3.1

Pivotal Cloud Foundry : versions corrigées pour PostgreSQL.
Les versions corrigées sont indiquées dans les sources d'information.

RHEL 7 : nouveaux paquetages rh-postgresql10.
De nouveaux paquetages sont disponibles :
  RHEL 7.0-7.7 : rh-postgresql10 postgresql-10.12-2.el7

RHEL 8 : nouveau module postgresql-10.
Le module suivant est mis à jour :
  RHEL 8 Module : postgresql:10

SUSE LE 12 : nouveaux paquetages postgresql10.
De nouveaux paquetages sont disponibles :
  SUSE LE 12 RTM : postgresql10 10.9-1.12.2
  SUSE LE 12 SP1 : postgresql10 10.9-1.12.2
  SUSE LE 12 SP2 : postgresql10 10.9-1.12.2
  SUSE LE 12 SP3 : postgresql10 10.9-1.12.2
  SUSE LE 12 SP4 : postgresql10 10.9-1.12.2

SUSE LE 12 SP3 : nouveaux paquetages postgresql10.
De nouveaux paquetages sont disponibles :
  SUSE LE 12 SP3 : postgresql10 10.9-1.12.2

SUSE LE 15 RTM : nouveaux paquetages postgresql10.
De nouveaux paquetages sont disponibles :
  SUSE LE 15 RTM : postgresql10 10.9-4.13.2

Ubuntu : nouveaux paquetages postgresql.
De nouveaux paquetages sont disponibles :
  Ubuntu 19.04 : postgresql-11 11.4-0ubuntu0.19.04.1
  Ubuntu 18.10 : postgresql-10 10.9-0ubuntu0.18.10.1
  Ubuntu 18.04 LTS : postgresql-10 10.9-0ubuntu0.18.04.1

Wind River Linux : version 10.18.44.9.
La version 10.18.44.9 est corrigée :
  https://support2.windriver.com/
Bulletin complet, filtrage par logiciel, emails, correctifs, ... (Demandez votre essai gratuit)

Service de veille sur les vulnérabilités informatiques 

Vigil@nce fournit un bulletin de vulnérabilité de réseau. La base de vulnérabilités Vigil@nce contient plusieurs milliers de failles.