L'équipe Vigil@nce veille les vulnérabilités publiques qui affectent votre parc informatique, puis propose des correctifs sécurité, une base de données de vigilance et des outils pour y remédier.

Vulnérabilité de Postgrey : déni de service

Synthèse de la vulnérabilité 

Un attaquant peut envoyer un email spécial afin de stopper Postgrey.
Produits vulnérables : Debian, Postfix.
Gravité de cette faille : 2/4.
Date de création : 18/04/2005.
Références de ce bulletin : CVE-2005-1127, DSA-1121-1, V6-POSTFIXPOSTGREYFMTDOS, VIGILANCE-VUL-4908.

Description de la vulnérabilité 

Le programme Postgrey implémente le Greylisting permettant de limiter le spam.

Ce programme utilise le module Perl Net::Server. Ce module est sensible à une attaque par format (VIGILANCE-VUL-4909).

Lorsqu'une adresse email contient le caractère '%', cette attaque se produit. Les adresses email sont filtrées, ce qui ne permet pas de faire exécuter du code, mais conduit simplement à l'arrêt de Postgrey.

Un attaquant du réseau peut donc construire un email provoquant un déni de service.
Bulletin complet, filtrage par logiciel, emails, correctifs, ... (Demandez votre essai gratuit)

Ce bulletin de vulnérabilité informatique concerne les logiciels ou systèmes comme Debian, Postfix.

Notre équipe Vigil@nce a déterminé que la gravité de cette alerte cybersécurité est moyen.

Le niveau de confiance est de type confirmé par l'éditeur, avec une provenance de serveur internet.

Un attaquant avec un niveau de compétence expert peut exploiter cet avis de faille.

Solutions pour cette menace 

Postgrey : version.
La version 1.21 est corrigée :
  http://isg.ee.ethz.ch/tools/postgrey/pub/postgrey-1.21.tar.gz

Debian : nouveaux paquetages postgrey.
De nouveaux paquetages sont disponibles :
  Source archives:
    http://security.debian.org/pool/updates/main/p/postgrey/postgrey_1.21-1sarge1.dsc
      Size/MD5 checksum: 628 2a0d8c903c9f47b374a9fa871056b5df
    http://security.debian.org/pool/updates/main/p/postgrey/postgrey_1.21-1sarge1.diff.gz
      Size/MD5 checksum: 13354 96eefd0e11745edf1cce5fa833d83396
    http://security.debian.org/pool/updates/main/p/postgrey/postgrey_1.21.orig.tar.gz
      Size/MD5 checksum: 25934 1274e073be5178445e0892a9dcc6fe98
  Architecture independent components:
    http://security.debian.org/pool/updates/main/p/postgrey/postgrey_1.21-1sarge1_all.deb
      Size/MD5 checksum: 41526 43de6a5366b7df928212489a84ec127f
Bulletin complet, filtrage par logiciel, emails, correctifs, ... (Demandez votre essai gratuit)

Service de veille sur les vulnérabilités informatiques 

Vigil@nce fournit une veille de vulnérabilités logicielles. Chaque administrateur peut personnaliser la liste des produits pour lesquels il souhaite recevoir des alertes de vulnérabilités.