L'équipe Vigil@nce veille les vulnérabilités publiques qui affectent votre parc informatique, puis propose des correctifs sécurité, une base de données de vigilance et des outils pour y remédier.

Vulnérabilité de Python : buffer overflow via ctypes PyCArg_repr

Synthèse de la vulnérabilité 

Un attaquant peut provoquer un buffer overflow via ctypes PyCArg_repr() de Python, afin de mener un déni de service, et éventuellement d'exécuter du code.
Logiciels vulnérables : Debian, Fedora, openSUSE Leap, Python, SUSE Linux Enterprise Desktop, SLES, Ubuntu.
Gravité de cette annonce : 2/4.
Date de création : 19/01/2021.
Références de cette vulnérabilité informatique : 42938, CERTFR-2021-AVI-140, CVE-2021-3177, DLA-2619-1, FEDORA-2021-42ba9feb47, FEDORA-2021-851c6e4e2d, FEDORA-2021-ced31f3f0c, FEDORA-2021-d5cde50865, openSUSE-SU-2021:0270-1, openSUSE-SU-2021:0331-1, SUSE-SU-2021:0355-1, SUSE-SU-2021:0428-1, SUSE-SU-2021:0432-1, SUSE-SU-2021:0529-1, USN-4754-1, USN-4754-2, USN-4754-3, USN-4754-4, VIGILANCE-VUL-34369.

Description de la vulnérabilité 

Un attaquant peut provoquer un buffer overflow via ctypes PyCArg_repr() de Python, afin de mener un déni de service, et éventuellement d'exécuter du code.
Bulletin complet, filtrage par logiciel, emails, correctifs, ... (Demandez votre essai gratuit)

Cette menace concerne les logiciels ou systèmes comme Debian, Fedora, openSUSE Leap, Python, SUSE Linux Enterprise Desktop, SLES, Ubuntu.

Notre équipe Vigil@nce a déterminé que la gravité de cette annonce cyber-sécurité est moyen.

Le niveau de confiance est de type confirmé par l'éditeur, avec une provenance de document.

Un attaquant avec un niveau de compétence expert peut exploiter cette faille informatique.

Solutions pour cette menace 

Python : version 3.9.2.
La version 3.9.2 est corrigée :
  https://www.python.org/downloads/

Python : version 3.8.8.
La version 3.8.8 est corrigée :
  https://www.python.org/downloads/

Python : version 3.7.10.
La version 3.7.10 est corrigée :
  https://www.python.org/downloads/

Python : version 3.6.13.
La version 3.6.13 est corrigée :
  https://www.python.org/downloads/

Python : patch pour ctypes PyCArg_repr.
Un patch est disponible :
  https://github.com/python/cpython/commit/ece5dfd403dac211f8d3c72701fe7ba7b7aa5b5f

Debian 9 : nouveaux paquetages python3.5.
De nouveaux paquetages sont disponibles :
  Debian 9 : python3.5 3.5.3-1+deb9u4

Fedora 32-33 : nouveaux paquetages mingw-python3.
De nouveaux paquetages sont disponibles :
  Fedora 32 : mingw-python3 3.8.3-8.fc32
  Fedora 33 : mingw-python3 3.9.1-2.fc33

Fedora 32 : nouveaux paquetages python3.10.
De nouveaux paquetages sont disponibles :
  Fedora 32 : python3.10 3.10.0~a5-1.fc32

Fedora 33 : nouveaux paquetages python3.10.
De nouveaux paquetages sont disponibles :
  Fedora 33 : python3.10 3.10.0~a5-1.fc33

openSUSE Leap 15.2 : nouveaux paquetages python (11/02/2021).
De nouveaux paquetages sont disponibles :
  openSUSE Leap 15.2 : python 2.7.17-lp152.3.12.1

openSUSE Leap 15.2 : nouveaux paquetages python3 (23/02/2021).
De nouveaux paquetages sont disponibles :
  openSUSE Leap 15.2 : python3 3.6.12-lp152.4.17.1

SUSE LE 12 SP2-5 : nouveaux paquetages python.
De nouveaux paquetages sont disponibles :
  SUSE LE 12 SP2 : python 2.7.17-28.64.1
  SUSE LE 12 SP3 : python 2.7.17-28.64.1
  SUSE LE 12 SP4 : python 2.7.17-28.64.1
  SUSE LE 12 SP5 : python 2.7.17-28.64.1

SUSE LE 12 SP5 : nouveaux paquetages python36 (11/02/2021).
De nouveaux paquetages sont disponibles :
  SUSE LE 12 SP5 : python36 3.6.12-4.33.3

SUSE LE 15 RTM-SP3 : nouveaux paquetages python (09/02/2021).
De nouveaux paquetages sont disponibles :
  SUSE LE 15 RTM : python 2.7.17-7.52.2
  SUSE LE 15 SP1 : python 2.7.17-7.52.2
  SUSE LE 15 SP2 : python 2.7.17-7.52.2
  SUSE LE 15 SP3 : python 2.7.17-7.52.2

SUSE LE 15 SP2 : nouveaux paquetages python3.
De nouveaux paquetages sont disponibles :
  SUSE LE 15 SP2 : python3 3.6.12-3.75.1

Ubuntu : nouveaux paquetages python.
De nouveaux paquetages sont disponibles :
  Ubuntu 20.10 : python3.8 3.8.6-1ubuntu0.2
  Ubuntu 20.04 LTS : python2.7 2.7.18-1~20.04.1, python3.8 3.8.5-1~20.04.2
  Ubuntu 18.04 LTS : python2.7 2.7.17-1~18.04ubuntu1.6, python3.6 3.6.9-1~18.04ubuntu1.4, python3.7 3.7.5-2~18.04.4, python3.8 3.8.0-3~18.04.1
  Ubuntu 16.04 LTS : python2.7 2.7.12-1ubuntu0~16.04.18, python3.5 3.5.2-2ubuntu0~16.04.13
  Ubuntu 14.04 ESM : python2.7 2.7.6-8ubuntu0.6+esm9, python3.4 3.4.3-1ubuntu1~14.04.7+esm10
Bulletin complet, filtrage par logiciel, emails, correctifs, ... (Demandez votre essai gratuit)

Service de veille sur les vulnérabilités informatiques 

Vigil@nce fournit des bulletins de vulnérabilités informatiques. Le service de veille sur les vulnérabilités informatiques Vigil@nce alerte vos équipes des failles et des menaces qui concernent votre système d'information.