L'équipe Vigil@nce veille les vulnérabilités publiques qui affectent votre parc informatique, puis propose des correctifs sécurité, une base de données de vigilance et des outils pour y remédier.

Vulnérabilité de Python : déni de service via urllib.request.AbstractBasicAuthHandler

Synthèse de la vulnérabilité 

Un attaquant peut provoquer une erreur fatale via urllib.request.AbstractBasicAuthHandler de Python, afin de mener un déni de service.
Systèmes impactés : Debian, Fedora, IBM i, openSUSE Leap, Solaris, Python, SUSE Linux Enterprise Desktop, SLES, Ubuntu.
Gravité de cette alerte : 2/4.
Date de création : 31/01/2020.
Références de cette alerte : 6206164, 6206166, CVE-2020-8492, DLA-2280-1, FEDORA-2020-16167a66a2, FEDORA-2020-4cf7c3910b, FEDORA-2020-6a88dad4a0, FEDORA-2020-8bdd3fd7a4, FEDORA-2020-ea5bdbcc90, openSUSE-SU-2020:0274-1, SUSE-SU-2020:0467-1, SUSE-SU-2020:0510-1, SUSE-SU-2020:0557-1, SUSE-SU-2020:14306-1, USN-4333-1, USN-4333-2, VIGILANCE-VUL-31481.

Description de la vulnérabilité 

Un attaquant peut provoquer une erreur fatale via urllib.request.AbstractBasicAuthHandler de Python, afin de mener un déni de service.
Bulletin complet, filtrage par logiciel, emails, correctifs, ... (Demandez votre essai gratuit)

Cette annonce cyber-sécurité concerne les logiciels ou systèmes comme Debian, Fedora, IBM i, openSUSE Leap, Solaris, Python, SUSE Linux Enterprise Desktop, SLES, Ubuntu.

Notre équipe Vigil@nce a déterminé que la gravité de ce bulletin de faille est moyen.

Le niveau de confiance est de type confirmé par l'éditeur, avec une provenance de serveur internet.

Un attaquant avec un niveau de compétence expert peut exploiter cette annonce de vulnérabilité.

Solutions pour cette menace 

Python : version 3.8.3.
La version 3.8.3 est corrigée :
  https://www.python.org/downloads/release/python-383/

Python : version 3.7.8.
La version 3.7.8 est corrigée :
  https://www.python.org/

Python : version 3.6.11.
La version 3.6.11 est corrigée :
  https://www.python.org/

Fedora 31-32 : nouveaux paquetages python35.
De nouveaux paquetages sont disponibles :
  Fedora 31 : python35 3.5.10-1.fc31
  Fedora 32 : python35 3.5.10-1.fc32

Python : version 3.5.10.
La version 3.5.10 est corrigée :
  https://www.python.org/downloads/release/python-3510/

Python : patch pour urllib.request.AbstractBasicAuthHandler.
Un patch est indiqué dans les sources d'information.

Debian 9 : nouveaux paquetages python3.5.
De nouveaux paquetages sont disponibles :
  Debian 9 : python3.5 3.5.3-1+deb9u2

Fedora 31 : nouveaux paquetages python36.
De nouveaux paquetages sont disponibles :
  Fedora 31 : python36 3.6.11-1.fc31

Fedora 31 : nouveaux paquetages python38.
De nouveaux paquetages sont disponibles :
  Fedora 31 : python38 3.8.3-1.fc31

Fedora 32 : nouveaux paquetages python36.
De nouveaux paquetages sont disponibles :
  Fedora 32 : python36 3.6.11-1.fc32

IBM i : nouveaux paquetages python3.
De nouveaux paquetages sont disponibles :
  IBM i : python3 3.6.10-2.ibmi7.2

openSUSE Leap 15.1 : nouveaux paquetages python3.
De nouveaux paquetages sont disponibles :
  openSUSE Leap 15.1 : python3 3.6.10-lp151.6.11.1

Oracle Solaris : patch pour logiciels tiers de juillet 2020 v2.
Un patch est disponible :
  https://support.oracle.com/rs?type=doc&id=1448883.1

SUSE LE 11 SP3/4 : nouveaux paquetages python.
De nouveaux paquetages sont disponibles :
  SUSE LE 11 SP3 : python 2.6.9-40.35.1
  SUSE LE 11 SP4 : python 2.6.9-40.35.1

SUSE LE 12 SP5 : nouveaux paquetages python36.
De nouveaux paquetages sont disponibles :
  SUSE LE 12 SP5 : python36 3.6.10-4.6.1

SUSE LE 15 SP1 : nouveaux paquetages python.
De nouveaux paquetages sont disponibles :
  SUSE LE 15 SP1 : python 2.7.17-7.35.1

SUSE LE 15 SP1 : nouveaux paquetages python3.
De nouveaux paquetages sont disponibles :
  SUSE LE 15 SP1 : python3 3.6.10-3.47.2

Ubuntu : nouveaux paquetages Python.
De nouveaux paquetages sont disponibles :
  Ubuntu 20.04 LTS : python3.8 3.8.2-1ubuntu1.1
  Ubuntu 19.10 : python3.7 3.7.5-2~19.10ubuntu1
  Ubuntu 18.04 LTS : python2.7 2.7.17-1~18.04ubuntu1, python3.6 3.6.9-1~18.04ubuntu1
  Ubuntu 16.04 LTS : python2.7 2.7.12-1ubuntu0~16.04.11, python3.5 3.5.2-2ubuntu0~16.04.10
  Ubuntu 14.04 ESM : python2.7 2.7.6-8ubuntu0.6+esm5, python3.4 3.4.3-1ubuntu1~14.04.7+esm6
  Ubuntu 12.04 ESM : python2.7 2.7.3-0ubuntu3.17
Bulletin complet, filtrage par logiciel, emails, correctifs, ... (Demandez votre essai gratuit)

Service de veille sur les vulnérabilités informatiques 

Vigil@nce fournit un patch de vulnérabilités de systèmes. Le service de veille sur les vulnérabilités informatiques Vigil@nce alerte vos équipes des failles et des menaces qui concernent votre système d'information.