L'équipe Vigil@nce veille les vulnérabilités publiques qui affectent votre parc informatique, puis propose des correctifs sécurité, une base de données de vigilance et des outils pour y remédier.

Vulnérabilité de Python urllib : lecture de fichier via Blacklist Bypass

Synthèse de la vulnérabilité 

Un attaquant local peut lire un fichier via Blacklist Bypass de Python urllib, afin d'obtenir des informations sensibles.
Produits vulnérables : Debian, VNX Operating Environment, VNX Series, IBM i, McAfee Web Gateway, openSUSE Leap, Solaris, Python, RHEL, Slackware, SUSE Linux Enterprise Desktop, SLES, Ubuntu.
Gravité de cette faille : 2/4.
Date de création : 25/03/2019.
Références de ce bulletin : 1102875, 35907, bulletinjul2019, CVE-2019-9948, DLA-1834-1, DLA-1852-1, DLA-2280-1, DSA-2019-131, openSUSE-SU-2019:1273-1, openSUSE-SU-2019:1282-1, openSUSE-SU-2019:1580-1, RHSA-2019:1700-01, RHSA-2019:2030-01, RHSA-2019:3335-01, RHSA-2019:3520-01, RHSA-2020:1268-01, RHSA-2020:1346-01, RHSA-2020:1462-01, SSA:2019-293-01, SUSE-SU-2019:0972-1, SUSE-SU-2019:14018-1, SUSE-SU-2019:1439-1, SUSE-SU-2020:0234-1, USN-4127-1, USN-4127-2, VIGILANCE-VUL-28848.

Description de la vulnérabilité 

Un attaquant local peut lire un fichier via Blacklist Bypass de Python urllib, afin d'obtenir des informations sensibles.
Bulletin complet, filtrage par logiciel, emails, correctifs, ... (Demandez votre essai gratuit)

Cet avis de faille informatique concerne les logiciels ou systèmes comme Debian, VNX Operating Environment, VNX Series, IBM i, McAfee Web Gateway, openSUSE Leap, Solaris, Python, RHEL, Slackware, SUSE Linux Enterprise Desktop, SLES, Ubuntu.

Notre équipe Vigil@nce a déterminé que la gravité de cette annonce de faille informatique est moyen.

Le niveau de confiance est de type confirmé par l'éditeur, avec une provenance de document.

Un attaquant avec un niveau de compétence expert peut exploiter cet avis cyber-sécurité.

Solutions pour cette menace 

Python : version 3.7.4.
La version 3.7.4 est corrigée :
  https://www.python.org/downloads/

Python : version 3.6.9.
La version 3.6.9 est corrigée :
  https://www.python.org/downloads/

Python : version 3.5.8.
La version 3.5.8 est corrigée :
  https://www.python.org/downloads/

Python urllib : patch pour Blacklist Bypass.
Un patch est indiqué dans les sources d'information.

Debian 8 : nouveaux paquetages python2.7.
De nouveaux paquetages sont disponibles :
  Debian 8 : python2.7 2.7.9-2+deb8u3

Debian 8 : nouveaux paquetages python3.4.
De nouveaux paquetages sont disponibles :
  Debian 8 : python3.4 3.4.2-1+deb8u5

Debian 9 : nouveaux paquetages python3.5.
De nouveaux paquetages sont disponibles :
  Debian 9 : python3.5 3.5.3-1+deb9u2

Dell EMC VNXe3200 : version 3.1.10.9946299.
La version 3.1.10.9946299 est corrigée :
  https://www.dell.com/

IBM i : solution pour Python.
La solution est indiquée dans les sources d'information.

McAfee Web Gateway : version 8.2.2.
La version 8.2.2 est corrigée :
  https://www.mcafee.com/enterprise/en-us/downloads/my-products.html

McAfee Web Gateway : version 9.0.
La version 9.0 est corrigée :
  https://www.mcafee.com/enterprise/en-us/downloads/my-products.html

openSUSE Leap 15.0 : nouveaux paquetages python.
De nouveaux paquetages sont disponibles :
  openSUSE Leap 15.0 : python 2.7.14-lp150.6.10.1

openSUSE Leap 42.3 : nouveaux paquetages python.
De nouveaux paquetages sont disponibles :
  openSUSE Leap 42.3 : python 2.7.13-27.15.1

Oracle Solaris : patch pour logiciels tiers de juillet 2019 v2.
Un patch est disponible :
  https://support.oracle.com/rs?type=doc&id=1448883.1

RHEL 7.4 : nouveaux paquetages python.
De nouveaux paquetages sont disponibles :
  RHEL 7.4 : python 2.7.5-63.el7_4

RHEL 7.5 : nouveaux paquetages python.
De nouveaux paquetages sont disponibles :
  RHEL 7.5 : python 2.7.5-74.el7_5

RHEL 7.6 : nouveaux paquetages python.
De nouveaux paquetages sont disponibles :
  RHEL 7.6 : python 2.7.5-83.el7_6

RHEL 7 : nouveaux paquetages python.
De nouveaux paquetages sont disponibles :
  RHEL 7 : python 2.7.5-86.el7

RHEL 8 : nouveau module python27-2.7.
Le module suivant est mis à jour :
  RHEL 8 Module : python27:2.7

RHEL 8 : nouveaux paquetages python3.
De nouveaux paquetages sont disponibles :
  RHEL 8 : python3 3.6.8-15.1.el8

RHEL : nouveaux paquetages python27-python.
De nouveaux paquetages sont disponibles :
  RHEL 6 : python27-python 2.7.16-6.el6
  RHEL 7 : python27-python 2.7.16-6.el7

Slackware : nouveaux paquetages python.
De nouveaux paquetages sont disponibles :
  Slackware 14.0 : python 2.7.17-*-1_slack14.0
  Slackware 14.1 : python 2.7.17-*-1_slack14.1
  Slackware 14.2 : python 2.7.17-*-1_slack14.2

SUSE LE 11 : nouveaux paquetages python.
De nouveaux paquetages sont disponibles :
  SUSE LE 11 SP3 : python 2.6.9-40.24.1
  SUSE LE 11 SP4 : python 2.6.9-40.24.1

SUSE LE 12 : nouveaux paquetages python.
De nouveaux paquetages sont disponibles :
  SUSE LE 12 SP1 : python 2.7.13-28.26.1
  SUSE LE 12 SP2 : python 2.7.13-28.26.1
  SUSE LE 12 SP3 : python 2.7.13-28.26.1
  SUSE LE 12 SP4 : python 2.7.13-28.26.1

SUSE LE 15 : nouveaux paquetages python (18/04/2019).
De nouveaux paquetages sont disponibles :
  SUSE LE 15 RTM : python 2.7.14-7.11.1

SUSE LE 15 : nouveaux paquetages python (27/01/2020).
De nouveaux paquetages sont disponibles :
  SUSE LE 15 RTM : python 2.7.17-7.32.2
  SUSE LE 15 SP1 : python 2.7.17-7.32.2

Ubuntu : nouveaux paquetages python.
De nouveaux paquetages sont disponibles :
  Ubuntu 19.04 : python2.7 2.7.16-2ubuntu0.1, python3.7 3.7.3-2ubuntu0.1
  Ubuntu 18.04 LTS : python2.7 2.7.15-4ubuntu4~18.04.1, python3.6 3.6.8-1~18.04.2
  Ubuntu 16.04 LTS : python2.7 2.7.12-1ubuntu0~16.04.8, python3.5 3.5.2-2ubuntu0~16.04.8
  Ubuntu 14.04 ESM : python2.7 2.7.6-8ubuntu0.6+esm2, python3.4 3.4.3-1ubuntu1~14.04.7+esm2
  Ubuntu 12.04 ESM : python2.7 2.7.3-0ubuntu3.14
Bulletin complet, filtrage par logiciel, emails, correctifs, ... (Demandez votre essai gratuit)

Service de veille sur les vulnérabilités informatiques 

Vigil@nce fournit des avis de vulnérabilité de système. Chaque administrateur peut personnaliser la liste des produits pour lesquels il souhaite recevoir des alertes de vulnérabilités.