L'équipe Vigil@nce veille les vulnérabilités publiques qui affectent votre parc informatique, puis propose des correctifs sécurité, une base de données de vigilance et des outils pour y remédier.

Vulnérabilité de QEMU : buffer overflow de ATAPI

Synthèse de la vulnérabilité 

Un attaquant dans un système invité peut provoquer un buffer overflow avec des commandes ATAPI de Xen, afin de mener un déni de service, et éventuellement d'exécuter du code dans le système hôte.
Logiciels vulnérables : XenServer, Debian, Fedora, openSUSE, openSUSE Leap, QEMU, RHEL, SUSE Linux Enterprise Desktop, SLES, Ubuntu, Xen.
Gravité de cette annonce : 2/4.
Date de création : 27/07/2015.
Références de cette vulnérabilité informatique : CERTFR-2015-AVI-319, CERTFR-2015-AVI-320, CTX201593, CVE-2015-5154, DSA-3348-1, FEDORA-2015-12657, FEDORA-2015-12714, FEDORA-2015-13402, FEDORA-2015-13404, openSUSE-SU-2015:1964-1, openSUSE-SU-2015:2003-1, openSUSE-SU-2015:2249-1, RHSA-2015:1507-01, RHSA-2015:1508-01, RHSA-2015:1512-01, SUSE-SU-2015:1299-1, SUSE-SU-2015:1302-1, SUSE-SU-2015:1409-1, SUSE-SU-2015:1421-1, SUSE-SU-2015:1426-1, SUSE-SU-2015:1455-1, SUSE-SU-2015:1472-1, SUSE-SU-2015:1479-1, SUSE-SU-2015:1479-2, SUSE-SU-2015:1643-1, SUSE-SU-2015:1782-1, USN-2692-1, VIGILANCE-VUL-17509, XSA-138.

Description de la vulnérabilité 

Le produit QEMU émule des commandes ATAPI, utilisées par les lecteurs CDROM/DVD.

Cependant, lorsqu'un utilisateur a accès au périphérique CDROM/DVD émulé sur une machine X86, il peut envoyer plus de données que prévu dans un tableau interne, et ainsi provoquer un débordement dans le processus QEMU de la machine hôte.

Un attaquant dans un système invité peut donc provoquer un buffer overflow avec des commandes ATAPI de QEMU, afin de mener un déni de service, et éventuellement d'exécuter du code dans le système hôte.
Bulletin complet, filtrage par logiciel, emails, correctifs, ... (Demandez votre essai gratuit)

Cet avis de faille concerne les logiciels ou systèmes comme XenServer, Debian, Fedora, openSUSE, openSUSE Leap, QEMU, RHEL, SUSE Linux Enterprise Desktop, SLES, Ubuntu, Xen.

Notre équipe Vigil@nce a déterminé que la gravité de cette annonce de menace informatique est moyen.

Le niveau de confiance est de type confirmé par l'éditeur, avec une provenance de shell utilisateur.

Un attaquant avec un niveau de compétence expert peut exploiter cette alerte de faille informatique.

Solutions pour cette menace 

QEMU : version 2.3.1.
La version 2.3.1 est corrigée :
  http://wiki.qemu.org/download/qemu-2.3.1.tar.bz2

QEMU : patch pour ATAPI.
Un patch est disponible dans les sources d'information.

Xen : patch pour ATAPI.
Un patch est disponible dans les sources d'information.

Citrix XenServer : patch.
Un patch est disponible dans les sources d'information.

Debian : nouveaux paquetages qemu.
De nouveaux paquetages sont disponibles :
  Debian 7 : qemu 1.1.2+dfsg-6a+deb7u9
  Debian 8 : qemu 1:2.1+dfsg-12+deb8u2

Fedora 21 : nouveaux paquetages qemu.
De nouveaux paquetages sont disponibles :
  Fedora 21 : qemu 2.1.3-9.fc21

Fedora 22 : nouveaux paquetages qemu.
De nouveaux paquetages sont disponibles :
  Fedora 22 : qemu 2.3.1-1.fc22

Fedora : nouveaux paquetages xen.
De nouveaux paquetages sont disponibles :
  Fedora 21 : xen 4.4.2-9.fc21
  Fedora 22 : xen 4.5.1-5.fc22

openSUSE 13.1 : nouveaux paquetages xen (12/11/2015).
De nouveaux paquetages sont disponibles :
  openSUSE 13.1 : xen 4.3.4_06-50.1

openSUSE 13.2 : nouveaux paquetages xen (17/11/2015).
De nouveaux paquetages sont disponibles :
  openSUSE 13.2 : xen 4.4.3_02-30.1

openSUSE Leap 42.1 : nouveaux paquetages xen (11/12/2015).
De nouveaux paquetages sont disponibles :
  openSUSE Leap 42.1 : xen 4.5.2_01-6.1

RHEL 7.1 : nouveaux paquetages qemu-kvm.
De nouveaux paquetages sont disponibles :
  RHEL 7 : qemu-kvm 1.5.3-86.el7_1.5

RHEL OpenStack : nouveaux paquetages qemu-kvm-rhev.
De nouveaux paquetages sont disponibles :
  RHEL 7 : qemu-kvm-rhev 2.1.2-23.el7_1.6

RHEV-H 7 : nouveaux paquetages qemu-kvm-rhev.
De nouveaux paquetages sont disponibles :
  RHEL 7 : qemu-kvm-rhev 2.1.2-23.el7_1.6

SUSE LE 10 SP4 : nouveaux paquetages xen.
De nouveaux paquetages sont disponibles :
  SUSE LE 10 SP4 : xen 3.2.3_17040_46-0.21.1

SUSE LE 11 : nouveaux paquetages kvm.
De nouveaux paquetages sont disponibles :
  SUSE LE 11 SP1 : kvm 0.12.5-1.30.2
  SUSE LE 11 SP3 : kvm 1.4.2-0.22.34.3
  SUSE LE 11 SP4 : kvm 1.4.2-32.1

SUSE LE 11 SP2 : nouveaux paquetages kvm.
De nouveaux paquetages sont disponibles :
  SUSE LE 11 SP2: kvm 0.15.1-0.32.2

SUSE LE 11 SP3 : nouveaux paquetages xen (03/09/2015).
De nouveaux paquetages sont disponibles :
  SUSE LE 11 SP3 : xen 4.2.5_12-15.1

SUSE LE 12 : nouveaux paquetages qemu.
De nouveaux paquetages sont disponibles :
  SUSE LE 12 RTM : qemu 2.0.2-48.9.1

SUSE LE : nouveaux paquetages xen.
De nouveaux paquetages sont disponibles :
  SUSE LE 11 SP1 : xen 4.0.3_21548_18-29.1
  SUSE LE 11 SP4 : xen 4.4.2_10-5.1
  SUSE LE 12 RTM : xen 4.4.2_08-22.5.1

Ubuntu : nouveaux paquetages qemu-system.
De nouveaux paquetages sont disponibles :
  Ubuntu 14.04 LTS : qemu-system 2.0.0+dfsg-2ubuntu1.15
  Ubuntu 15.04 : qemu-system 1:2.2+dfsg-5expubuntu9.3
Bulletin complet, filtrage par logiciel, emails, correctifs, ... (Demandez votre essai gratuit)

Service de veille sur les vulnérabilités informatiques 

Vigil@nce fournit un patch cybersécurité. Le service de veille sur les vulnérabilités informatiques Vigil@nce alerte vos équipes des failles et des menaces qui concernent votre système d'information.