L'équipe Vigil@nce veille les vulnérabilités publiques qui affectent votre parc informatique, puis propose des correctifs sécurité, une base de données de vigilance et des outils pour y remédier.

Vulnérabilité de QEMU : corruption de mémoire via USB Emulator

Synthèse de la vulnérabilité 

Un attaquant, dans un système invité, peut provoquer une corruption de mémoire via USB Emulator de QEMU, afin de mener un déni de service, et éventuellement d'exécuter du code sur le système hôte.
Produits impactés : XenServer, Debian, BIG-IP Hardware, TMOS, Fedora, Junos Space, Junos Space Network Management Platform, openSUSE Leap, QEMU, RHEL, SUSE Linux Enterprise Desktop, SLES, Ubuntu, Xen.
Gravité de ce bulletin : 2/4.
Date de création : 24/08/2020.
Références de cette menace : CERTFR-2020-AVI-525, CERTFR-2020-AVI-526, CTX280451, CVE-2020-14364, DLA-2373-1, DSA-4760-1, FEDORA-2020-3689b67b53, FEDORA-2020-eeb29955ed, JSA11174, JSA11176, K09081535, openSUSE-SU-2020:1664-1, RHSA-2020:4047-01, RHSA-2020:4048-01, RHSA-2020:4049-01, RHSA-2020:4050-01, RHSA-2020:4051-01, RHSA-2020:4052-01, RHSA-2020:4053-01, RHSA-2020:4054-01, RHSA-2020:4055-01, RHSA-2020:4056-01, RHSA-2020:4058-01, RHSA-2020:4059-01, RHSA-2020:4078-01, RHSA-2020:4079-01, RHSA-2020:4162-01, RHSA-2020:4290-01, RHSA-2020:4291-01, SUSE-SU-2020:14521-1, SUSE-SU-2020:2743-1, SUSE-SU-2020:2786-1, SUSE-SU-2020:2787-1, SUSE-SU-2020:2788-1, SUSE-SU-2020:2789-1, SUSE-SU-2020:2790-1, SUSE-SU-2020:2791-1, SUSE-SU-2020:2822-1, SUSE-SU-2020:2877-1, SUSE-SU-2021:1240-1, SUSE-SU-2021:1241-1, SUSE-SU-2021:1244-1, SUSE-SU-2021:1245-1, SUSE-SU-2021:1305-1, SUSE-SU-2021:14704-1, SUSE-SU-2021:14706-1, USN-4467-2, USN-4511-1, VIGILANCE-VUL-33141, XSA-335.

Description de la vulnérabilité 

Un attaquant, dans un système invité, peut provoquer une corruption de mémoire via USB Emulator de QEMU, afin de mener un déni de service, et éventuellement d'exécuter du code sur le système hôte.
Bulletin complet, filtrage par logiciel, emails, correctifs, ... (Demandez votre essai gratuit)

Cette alerte de vulnérabilité concerne les logiciels ou systèmes comme XenServer, Debian, BIG-IP Hardware, TMOS, Fedora, Junos Space, Junos Space Network Management Platform, openSUSE Leap, QEMU, RHEL, SUSE Linux Enterprise Desktop, SLES, Ubuntu, Xen.

Notre équipe Vigil@nce a déterminé que la gravité de cette menace est moyen.

Le niveau de confiance est de type confirmé par l'éditeur, avec une provenance de shell utilisateur.

Un attaquant avec un niveau de compétence expert peut exploiter ce bulletin cyber-sécurité.

Solutions pour cette menace 

QEMU : version 5.0.1.
La version 5.0.1 est corrigée :
  https://www.qemu.org/download/#source

QEMU : patch pour USB Emulator.
Un patch est indiqué dans les sources d'information.

Xen : patch pour QEMU USB Emulator.
Un patch est disponible :
  http://xenbits.xen.org/xsa/xsa335-qemu.patch
  http://xenbits.xen.org/xsa/xsa335-trad.patch

Citrix Hypervisor : patch pour QEMU USB Emulator.
Un patch est disponible :
  Citrix Hypervisor 8.2 LTSR : CTX280214 - https://support.citrix.com/article/CTX280214
  Citrix Hypervisor 8.1 : CTX280213 - https://support.citrix.com/article/CTX280213
  Citrix Hypervisor 8.0 : CTX280212 - https://support.citrix.com/article/CTX280212
  Citrix XenServer 7.1 LTSR CU2 : CTX280211 - https://support.citrix.com/article/CTX280211
  Citrix XenServer 7.0 : CTX280210 - https://support.citrix.com/article/CTX280210

Debian 10 : nouveaux paquetages qemu.
De nouveaux paquetages sont disponibles :
  Debian 10 : qemu 1:3.1+dfsg-8+deb10u8

Debian 9 : nouveaux paquetages qemu.
De nouveaux paquetages sont disponibles :
  Debian 9 : qemu 1:2.8+dfsg-6+deb9u11

F5 BIG-IP : solution pour QEMU CVE-2020-14364.
La solution est indiquée dans les sources d'information.

Fedora 31 : nouveaux paquetages xen.
De nouveaux paquetages sont disponibles :
  Fedora 31 : xen 4.12.3-4.fc31

Fedora 32 : nouveaux paquetages xen.
De nouveaux paquetages sont disponibles :
  Fedora 32 : xen 4.13.1-5.fc32

Junos Space : version 21.1R1.
La version 21.1R1 est corrigée :
  https://support.juniper.net/support/downloads/
Cette version corrige plus de 450 vulnérabilités, mais uniquement les 100 dernières ont été liées à ce bulletin.

openSUSE Leap 15.2 : nouveaux paquetages qemu.
De nouveaux paquetages sont disponibles :
  openSUSE Leap 15.2 : qemu 4.2.1-lp152.9.6.1

RHEL 6.10 : nouveaux paquetages qemu-kvm.
De nouveaux paquetages sont disponibles :
  RHEL 6.10 : qemu-kvm 0.12.1.2-2.506.el6_10.8

RHEL 7.6 : nouveaux paquetages qemu-kvm-ma.
De nouveaux paquetages sont disponibles :
  RHEL 7.6 : qemu-kvm-ma 2.12.0-18.el7_6.7

RHEL 7.7 : nouveaux paquetages qemu-kvm-ma.
De nouveaux paquetages sont disponibles :
  RHEL 7.7 : qemu-kvm-ma 2.12.0-33.el7_7.4

RHEL 7.9 : nouveaux paquetages qemu-kvm.
De nouveaux paquetages sont disponibles :
  RHEL 7.9 : qemu-kvm 1.5.3-175.el7_9.1

RHEL 7.9 : nouveaux paquetages qemu-kvm-ma.
De nouveaux paquetages sont disponibles :
  RHEL 7.9 : qemu-kvm-ma 2.12.0-48.el7_9.1

RHEL 8.0 : nouveau module virt-rhel.
Le module suivant est mis à jour :
  RHEL 8.0 Module : virt:rhel

RHEL 8.1 : nouveau module virt-8.1.
Le module suivant est mis à jour :
  RHEL 8.1 Module : virt:8.1

RHEL 8.1 : nouveau module virt-rhel.
Le module suivant est mis à jour :
  RHEL 8.1 Module : virt:rhel

RHEL 8.2 : nouveau module virt-8.2.
Le module suivant est mis à jour :
  RHEL 8.2 Module : virt:8.2

RHEL 8 : nouveau module virt-rhel.
Le module suivant est mis à jour :
  RHEL 8 Module : virt:rhel

RHEL : nouveaux paquetages qemu-kvm.
De nouveaux paquetages sont disponibles :
  RHEL 6.5 : qemu-kvm 0.12.1.2-2.415.el6_5.21
  RHEL 6.6 : qemu-kvm 0.12.1.2-2.448.el6_6.9
  RHEL 7.2 : qemu-kvm 1.5.3-105.el7_2.20
  RHEL 7.3 : qemu-kvm 1.5.3-126.el7_3.18
  RHEL 7.4 : qemu-kvm 1.5.3-141.el7_4.11
  RHEL 7.6 : qemu-kvm 1.5.3-160.el7_6.8
  RHEL 7.7 : qemu-kvm 1.5.3-167.el7_7.7

SUSE LE 11 SP3 : nouveaux paquetages kvm.
De nouveaux paquetages sont disponibles :
  SUSE LE 11 SP3 : kvm 1.4.2-53.38.1

SUSE LE 11 SP4 : nouveaux paquetages kvm.
De nouveaux paquetages sont disponibles :
  SUSE LE 11 SP4 : kvm 1.4.2-60.34.1

SUSE LE 11 SP4 : nouveaux paquetages xen.
De nouveaux paquetages sont disponibles :
  SUSE LE 11 SP4 : xen 4.4.4_44-61.55.1

SUSE LE 12 SP2 : nouveaux paquetages qemu.
De nouveaux paquetages sont disponibles :
  SUSE LE 12 SP2 : qemu 2.6.2-41.62.1

SUSE LE 12 SP2 : nouveaux paquetages xen.
De nouveaux paquetages sont disponibles :
  SUSE LE 12 SP2 : xen 4.7.6_10-43.67.1

SUSE LE 12 SP3 : nouveaux paquetages qemu.
De nouveaux paquetages sont disponibles :
  SUSE LE 12 SP3 : qemu 2.9.1-6.47.1

SUSE LE 12 SP4 : nouveaux paquetages qemu.
De nouveaux paquetages sont disponibles :
  SUSE LE 12 SP4 : qemu 2.11.2-5.29.1

SUSE LE 12 SP5 : nouveaux paquetages qemu.
De nouveaux paquetages sont disponibles :
  SUSE LE 12 SP5 : qemu 3.1.1.1-45.1

SUSE LE 15 RTM : nouveaux paquetages qemu.
De nouveaux paquetages sont disponibles :
  SUSE LE 15 RTM : qemu 2.11.2-9.43.1

SUSE LE 15 SP1 : nouveaux paquetages qemu.
De nouveaux paquetages sont disponibles :
  SUSE LE 15 SP1 : qemu 3.1.1.1-9.24.3

SUSE LE 15 SP2 : nouveaux paquetages qemu.
De nouveaux paquetages sont disponibles :
  SUSE LE 15 SP2 : qemu 4.2.1-11.10.1

SUSE LE : nouveaux paquetages xen.
De nouveaux paquetages sont disponibles :
  SUSE LE 12 SP3 : xen 4.9.4_12-3.74.1
  SUSE LE 12 SP4 : xen 4.11.4_08-2.36.1
  SUSE LE 12 SP5 : xen 4.12.3_08-3.24.1
  SUSE LE 15 RTM : xen 4.10.4_16-3.41.1
  SUSE LE 15 SP1 : xen 4.12.3_08-3.28.1
  SUSE LE 15 SP2 : xen 4.13.1_08-3.10.1

Ubuntu 14.04 : nouveaux paquetages qemu.
De nouveaux paquetages sont disponibles :
  Ubuntu 14.04 ESM : qemu 2.0.0+dfsg-2ubuntu1.47+esm1

Ubuntu : nouveaux paquetages qemu.
De nouveaux paquetages sont disponibles :
  Ubuntu 16.04 LTS : qemu 1:2.5+dfsg-5ubuntu10.46
  Ubuntu 18.04 LTS : qemu 1:2.11+dfsg-1ubuntu7.32
  Ubuntu 20.04 LTS : qemu 1:4.2-3ubuntu6.6

Wind River Linux : version 10.19.45.12.
La version 10.19.45.12 est corrigée :
  https://support2.windriver.com/index.php?page=cve&on=list&show=50&product_id=1&product_version%5B0%5D=24&id_status%5B0%5D=4&cve_id_filter=&s=&submit=&order_by=cve_modified_date&order_way=desc#list
Bulletin complet, filtrage par logiciel, emails, correctifs, ... (Demandez votre essai gratuit)

Service de veille sur les vulnérabilités informatiques 

Vigil@nce fournit un correctif de vulnérabilité de système. Le service de veille sur les vulnérabilités informatiques Vigil@nce alerte vos équipes des failles et des menaces qui concernent votre système d'information.